Bug 283132

Summary: Crash Plasma
Product: [Plasma] plasma4 Reporter: varty.rat
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:
Sentry Crash Report:

Description varty.rat 2011-10-01 11:37:54 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-11-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:

I removed icons of equipment management from system tray and when I try to add it again, it causes Plasma to crash. I'm using KDE-4.6.90 on Kubuntu

-- Backtrace:
Application: Оболочка Plasma (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fe84e4307a0 (LWP 1430))]

Thread 4 (Thread 0x7fe82ba70700 (LWP 1433)):
#0  0x00007fe84dd20f03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fe8426fe104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe8426fe639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe84af2f446 in QEventDispatcherGlib::processEvents (this=0x19ddf40, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fe84af03882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fe84af03abc in QEventLoop::exec (this=0x7fe82ba6fdb0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fe84ae1a924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007fe84aee5c2f in QInotifyFileSystemWatcherEngine::run (this=0x19dd350) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fe84ae1d175 in QThreadPrivate::start (arg=0x19dd350) at thread/qthread_unix.cpp:320
#9  0x00007fe843001d8c in start_thread (arg=0x7fe82ba70700) at pthread_create.c:304
#10 0x00007fe84dd2e04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fe82985d700 (LWP 1434)):
#0  0x00007fe843005d9d in __pthread_mutex_unlock_usercnt (mutex=0x1a3d258) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x1a3d258) at pthread_mutex_unlock.c:290
#2  0x00007fe8426fd79a in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe8426fe122 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fe8426fe639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fe84af2f446 in QEventDispatcherGlib::processEvents (this=0x1a3ccf0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00007fe84af03882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fe84af03abc in QEventLoop::exec (this=0x7fe82985cdb0, flags=...) at kernel/qeventloop.cpp:201
#8  0x00007fe84ae1a924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#9  0x00007fe84aee5c2f in QInotifyFileSystemWatcherEngine::run (this=0x1a3c160) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007fe84ae1d175 in QThreadPrivate::start (arg=0x1a3c160) at thread/qthread_unix.cpp:320
#11 0x00007fe843001d8c in start_thread (arg=0x7fe82985d700) at pthread_create.c:304
#12 0x00007fe84dd2e04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fe821787700 (LWP 1440)):
#0  0x00007fe84dd20f03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fe8426fe104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe8426fe9f2 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe82289ec44 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007fe8427253e4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fe843001d8c in start_thread (arg=0x7fe821787700) at pthread_create.c:304
#6  0x00007fe84dd2e04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fe84e4307a0 (LWP 1430)):
[KCrash Handler]
#6  QGraphicsLayoutItemPrivate::hasHeightForWidth (this=0x4d0057005f0054) at graphicsview/qgraphicslayoutitem.cpp:280
#7  0x00007fe84a8f1581 in QGridLayoutItem::hasDynamicConstraint (this=0x1dd2100) at graphicsview/qgridlayoutengine.cpp:576
#8  0x00007fe84a8f2839 in QGridLayoutEngine::ensureDynamicConstraint (this=0x116f040) at graphicsview/qgridlayoutengine.cpp:1657
#9  0x00007fe84a8f28e9 in QGridLayoutEngine::hasDynamicConstraint (this=0x116f040) at graphicsview/qgridlayoutengine.cpp:1677
#10 0x00007fe84a8f6638 in QGridLayoutEngine::sizeHint (this=0x116f040, styleInfo=..., which=Qt::MaximumSize, constraint=...) at graphicsview/qgridlayoutengine.cpp:1134
#11 0x00007fe84a8812ca in QGraphicsGridLayout::sizeHint (this=<value optimized out>, which=Qt::MaximumSize, constraint=...) at graphicsview/qgraphicsgridlayout.cpp:656
#12 0x00007fe84a8abd68 in QGraphicsLayoutItemPrivate::effectiveSizeHints (this=0x116ef30, constraint=...) at graphicsview/qgraphicslayoutitem.cpp:169
#13 0x00007fe84a8ac651 in QGraphicsLayoutItem::effectiveSizeHint (this=<value optimized out>, which=<value optimized out>, constraint=<value optimized out>) at graphicsview/qgraphicslayoutitem.cpp:818
#14 0x00007fe84a8e8b21 in QGraphicsWidget::sizeHint (this=<value optimized out>, which=<value optimized out>, constraint=<value optimized out>) at graphicsview/qgraphicswidget.cpp:729
#15 0x00007fe84a8abe4b in QGraphicsLayoutItemPrivate::effectiveSizeHints (this=0x116ee10, constraint=...) at graphicsview/qgraphicslayoutitem.cpp:175
#16 0x00007fe84a8ac651 in QGraphicsLayoutItem::effectiveSizeHint (this=<value optimized out>, which=<value optimized out>, constraint=<value optimized out>) at graphicsview/qgraphicslayoutitem.cpp:818
#17 0x00007fe84a8ac8b4 in QGraphicsLayoutItem::minimumSize (this=<value optimized out>) at graphicsview/qgraphicslayoutitem.cpp:526
#18 0x00007fe84d8953b9 in Plasma::PopupAppletPrivate::popupConstraintsEvent (this=0x1427dc0, constraints=...) at ../../plasma/popupapplet.cpp:252
#19 0x00007fe84d83da59 in Plasma::Applet::flushPendingConstraintsEvents (this=0x142d850) at ../../plasma/applet.cpp:1341
#20 0x00007fe84d83e67d in Plasma::Applet::timerEvent (this=0x142d850, event=<value optimized out>) at ../../plasma/applet.cpp:2432
#21 0x00007fe84af181c9 in QObject::event (this=0x142d850, e=<value optimized out>) at kernel/qobject.cpp:1190
#22 0x00007fe84a8e91bb in QGraphicsWidget::event (this=0x142d850, event=0x7fff327163b0) at graphicsview/qgraphicswidget.cpp:1423
#23 0x00007fe84a2c19f4 in QApplicationPrivate::notify_helper (this=0x117bee0, receiver=0x142d850, e=0x7fff327163b0) at kernel/qapplication.cpp:4462
#24 0x00007fe84a2c63ba in QApplication::notify (this=<value optimized out>, receiver=0x142d850, e=0x7fff327163b0) at kernel/qapplication.cpp:4341
#25 0x00007fe84bbbc866 in KApplication::notify (this=0x1169500, receiver=0x142d850, event=0x7fff327163b0) at ../../kdeui/kernel/kapplication.cpp:311
#26 0x00007fe84af0449c in QCoreApplication::notifyInternal (this=0x1169500, receiver=0x142d850, event=0x7fff327163b0) at kernel/qcoreapplication.cpp:731
#27 0x00007fe84af31f12 in sendEvent (this=0x117ed50) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#28 QTimerInfoList::activateTimers (this=0x117ed50) at kernel/qeventdispatcher_unix.cpp:604
#29 0x00007fe84af2ecf4 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#30 0x00007fe8426fdbcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007fe8426fe3a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007fe8426fe639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#33 0x00007fe84af2f3ef in QEventDispatcherGlib::processEvents (this=0x10fe340, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#34 0x00007fe84a36b4de in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#35 0x00007fe84af03882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#36 0x00007fe84af03abc in QEventLoop::exec (this=0x7fff32716620, flags=...) at kernel/qeventloop.cpp:201
#37 0x00007fe84af07ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#38 0x00007fe84e01a897 in kdemain (argc=1, argv=0x7fff327169e8) at ../../../../plasma/desktop/shell/main.cpp:118
#39 0x00007fe84dc66eff in __libc_start_main (main=0x400740 <main(int, char**)>, argc=1, ubp_av=0x7fff327169e8, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff327169d8) at libc-start.c:226
#40 0x0000000000400669 in _start ()

This bug may be a duplicate of or related to bug 277367.

Possible duplicates by query: bug 282922, bug 282748, bug 282738, bug 282680, bug 282622.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-10-18 12:51:56 UTC

*** This bug has been marked as a duplicate of bug 282552 ***