Bug 282922 - Crash when openng a new desktop
Summary: Crash when openng a new desktop
Status: RESOLVED DUPLICATE of bug 282552
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-27 18:05 UTC by Stephen
Modified: 2011-09-27 18:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stephen 2011-09-27 18:05:38 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.00 (4.7.0)
Qt Version: 4.8.0
Operating System: Linux 3.1.0-0.rc6.git0.3.fc16.i686.PAE i686
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:


Installed OS . Logged in as user. Clicked on right corner to get desktop button open. Systme then crashed

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb7787780 (LWP 1856))]

Thread 2 (Thread 0xb684db40 (LWP 1857)):
#0  0x00a4f424 in __kernel_vsyscall ()
#1  0x004b280c in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:172
#2  0x00284fb1 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x3857e0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#3  0x00284ff0 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x3857e0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#4  0x004aec8e in start_thread (arg=0xb684db40) at pthread_create.c:305
#5  0x022c14ee in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 1 (Thread 0xb7787780 (LWP 1856)):
[KCrash Handler]
#7  0x01ee0874 in QGraphicsLayoutItem::graphicsItem (this=0x0) at graphicsview/qgraphicslayoutitem.cpp:915
#8  0x01ee0a25 in QGraphicsLayoutItemPrivate::hasHeightForWidth (this=0xa22d8f8) at graphicsview/qgraphicslayoutitem.cpp:286
#9  0x01f2d519 in QGridLayoutItem::hasDynamicConstraint (this=0xa2d4750) at graphicsview/qgridlayoutengine.cpp:576
#10 0x01f2e59e in ensureDynamicConstraint (this=0xa997d18) at graphicsview/qgridlayoutengine.cpp:1666
#11 QGridLayoutEngine::ensureDynamicConstraint (this=0xa997d18) at graphicsview/qgridlayoutengine.cpp:1661
#12 0x01f2e641 in QGridLayoutEngine::hasDynamicConstraint (this=0xa997d18) at graphicsview/qgridlayoutengine.cpp:1686
#13 0x01f32783 in QGridLayoutEngine::sizeHint (this=0xa997d18, styleInfo=..., which=Qt::MaximumSize, constraint=...) at graphicsview/qgridlayoutengine.cpp:1143
#14 0x01eb2371 in QGraphicsGridLayout::sizeHint (this=0xa988eb0, which=Qt::MaximumSize, constraint=...) at graphicsview/qgraphicsgridlayout.cpp:668
#15 0x01edfa80 in QGraphicsLayoutItemPrivate::effectiveSizeHints (this=0xa997c28, constraint=...) at graphicsview/qgraphicslayoutitem.cpp:169
#16 0x01ee0464 in effectiveSizeHint (constraint=..., which=Qt::MinimumSize, this=<optimized out>) at graphicsview/qgraphicslayoutitem.cpp:813
#17 QGraphicsLayoutItem::effectiveSizeHint (this=0xa988eb0, which=Qt::MinimumSize, constraint=...) at graphicsview/qgraphicslayoutitem.cpp:805
#18 0x01f2333d in QGraphicsWidget::sizeHint (this=0xa997078, which=Qt::MinimumSize, constraint=...) at graphicsview/qgraphicswidget.cpp:743
#19 0x01edfb2c in QGraphicsLayoutItemPrivate::effectiveSizeHints (this=0xa997b30, constraint=...) at graphicsview/qgraphicslayoutitem.cpp:175
#20 0x01ee0464 in effectiveSizeHint (constraint=..., which=Qt::PreferredSize, this=<optimized out>) at graphicsview/qgraphicslayoutitem.cpp:813
#21 QGraphicsLayoutItem::effectiveSizeHint (this=0xa997088, which=Qt::PreferredSize, constraint=...) at graphicsview/qgraphicslayoutitem.cpp:805
#22 0x05663d12 in SystemTray::TaskArea::adjustHiddentTasksWidget (this=0xa989590) at /usr/src/debug/kdebase-workspace-4.7.0/kdebase-workspace-4.7.0/plasma/generic/applets/systemtray/ui/taskarea.cpp:429
#23 0x05665ec2 in SystemTray::TaskArea::addWidgetForTask (this=0xa989590, task=0xab2d690) at /usr/src/debug/kdebase-workspace-4.7.0/kdebase-workspace-4.7.0/plasma/generic/applets/systemtray/ui/taskarea.cpp:309
#24 0x05666230 in SystemTray::TaskArea::addTask (this=0xa989590, task=0xab2d690) at /usr/src/debug/kdebase-workspace-4.7.0/kdebase-workspace-4.7.0/plasma/generic/applets/systemtray/ui/taskarea.cpp:189
#25 0x06e06621 in QMetaObject::activate (sender=0x98f19c8, m=0x5672378, local_signal_index=0, argv=0xbfc7b748) at kernel/qobject.cpp:3546
#26 0x056450a6 in SystemTray::Manager::taskAdded (this=0x98f19c8, _t1=0xab2d690) at /usr/src/debug/kdebase-workspace-4.7.0/kdebase-workspace-4.7.0/i686-redhat-linux-gnu/plasma/generic/applets/systemtray/manager.moc:113
#27 0x05645349 in SystemTray::Manager::addTask (this=0x98f19c8, task=0xab2d690) at /usr/src/debug/kdebase-workspace-4.7.0/kdebase-workspace-4.7.0/plasma/generic/applets/systemtray/core/manager.cpp:87
#28 0x06e06621 in QMetaObject::activate (sender=0x98f2128, m=0x56723dc, local_signal_index=0, argv=0xbfc7b888) at kernel/qobject.cpp:3546
#29 0x05645ae6 in SystemTray::Protocol::taskCreated (this=0x98f2128, _t1=0xab2d690) at /usr/src/debug/kdebase-workspace-4.7.0/kdebase-workspace-4.7.0/i686-redhat-linux-gnu/plasma/generic/applets/systemtray/protocol.moc:105
#30 0x0564dd57 in SystemTray::PlasmoidProtocol::addApplet (this=0x98f2128, appletName=..., id=0, parent=0xa995598) at /usr/src/debug/kdebase-workspace-4.7.0/kdebase-workspace-4.7.0/plasma/generic/applets/systemtray/protocols/plasmoid/plasmoidtaskprotocol.cpp:112
#31 0x05644e3a in SystemTray::Manager::addApplet (this=0x98f19c8, appletName=..., parent=0xa995598) at /usr/src/debug/kdebase-workspace-4.7.0/kdebase-workspace-4.7.0/plasma/generic/applets/systemtray/core/manager.cpp:110
#32 0x05659bab in SystemTray::Applet::checkDefaultApplets (this=0xa995598) at /usr/src/debug/kdebase-workspace-4.7.0/kdebase-workspace-4.7.0/plasma/generic/applets/systemtray/ui/applet.cpp:755
#33 0x06e02ed2 in QMetaCallEvent::placeMetaCall (this=0xa2d3d80, object=0xa995598) at kernel/qobject.cpp:524
#34 0x06e0bb9b in QObject::event (this=0xa995598, e=0xa2d3d80) at kernel/qobject.cpp:1194
#35 0x01f23b7c in QGraphicsWidget::event (this=0xa995598, event=0xa2d3d80) at graphicsview/qgraphicswidget.cpp:1455
#36 0x018476d4 in notify_helper (e=0xa2d3d80, receiver=0xa995598, this=0x94cee40) at kernel/qapplication.cpp:4495
#37 QApplicationPrivate::notify_helper (this=0x94cee40, receiver=0xa995598, e=0xa2d3d80) at kernel/qapplication.cpp:4467
#38 0x0184cb73 in QApplication::notify (this=0xa2d3d80, receiver=0xa995598, e=0xa2d3d80) at kernel/qapplication.cpp:4224
#39 0x014b5352 in KApplication::notify (this=0x94c55e8, receiver=0xa995598, event=0xa2d3d80) at /usr/src/debug/kdelibs-4.7.0/kdeui/kernel/kapplication.cpp:311
#40 0x06df0d7e in QCoreApplication::notifyInternal (this=0x94c55e8, receiver=0xa995598, event=0xa2d3d80) at kernel/qcoreapplication.cpp:853
#41 0x06df4cd8 in sendEvent (event=<optimized out>, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#42 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x948b230) at kernel/qcoreapplication.cpp:1477
#43 0x06df500d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1370
#44 0x06e235f5 in sendPostedEvents () at kernel/qcoreapplication.h:236
#45 postEventSourceDispatch (s=0x94cf560) at kernel/qeventdispatcher_glib.cpp:279
#46 0x0835c5bf in g_main_dispatch (context=0x94d18f0) at gmain.c:2441
#47 g_main_context_dispatch (context=0x94d18f0) at gmain.c:3011
#48 0x0835cd00 in g_main_context_iterate (context=0x94d18f0, block=137803744, dispatch=1, self=0x94d2e28) at gmain.c:3089
#49 0x0835cfaf in g_main_context_iteration (context=0x94d18f0, may_block=1) at gmain.c:3152
#50 0x06e239f8 in QEventDispatcherGlib::processEvents (this=0x948bd98, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#51 0x018fbb3b in QGuiEventDispatcherGlib::processEvents (this=0x948bd98, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#52 0x06defc6e in QEventLoop::processEvents (this=0xbfc7c1f4, flags=...) at kernel/qeventloop.cpp:149
#53 0x06deff19 in QEventLoop::exec (this=0xbfc7c1f4, flags=...) at kernel/qeventloop.cpp:204
#54 0x06df50bb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1125
#55 0x018454d5 in QApplication::exec () at kernel/qapplication.cpp:3756
#56 0x009b3816 in kdemain (argc=1, argv=0xbfc7c3f4) at /usr/src/debug/kdebase-workspace-4.7.0/kdebase-workspace-4.7.0/plasma/desktop/shell/main.cpp:120
#57 0x0804875c in main (argc=1, argv=0xbfc7c3f4) at /usr/src/debug/kdebase-workspace-4.7.0/kdebase-workspace-4.7.0/i686-redhat-linux-gnu/plasma/desktop/shell/plasma-desktop_dummy.cpp:3

This bug may be a duplicate of or related to bug 282552.

Possible duplicates by query: bug 282680, bug 282552, bug 281782, bug 281575, bug 280549.

Reported using DrKonqi
Comment 1 Rex Dieter 2011-09-27 18:30:07 UTC

*** This bug has been marked as a duplicate of bug 282552 ***