Bug 282738 - Adding Default panel cause Plasma crash (4.7.x, SysTray related) [QGraphicsLayoutItemPrivate::hasHeightForWidth, QGridLayoutItem::hasDynamicConstraint, ensureDynamicConstraint]
Summary: Adding Default panel cause Plasma crash (4.7.x, SysTray related) [QGraphicsLa...
Status: RESOLVED DUPLICATE of bug 282552
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 281854 282748 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-09-25 13:50 UTC by jomi86
Modified: 2011-10-29 01:30 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments
New crash information added by DrKonqi (19.92 KB, text/plain)
2011-10-06 11:42 UTC, m.wege
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jomi86 2011-09-25 13:50:50 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.1 (4.7.1)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-11-generic x86_64
Distribution: Ubuntu oneiric (development branch)

-- Information about the crash:
- What I was doing when the application crashed:

On Desktop, right click - Add panel - Default panel and app crashes

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f1efde257a0 (LWP 1515))]

Thread 6 (Thread 0x7f1edb312700 (LWP 1516)):
#0  0x00007f1ef1c9504c in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f1ef1c95519 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1efa8fbf3e in QEventDispatcherGlib::processEvents (this=0x2010dd0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#3  0x00007f1efa8cfcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#4  0x00007f1efa8cfef7 in QEventLoop::exec (this=0x7f1edb311db0, flags=...) at kernel/qeventloop.cpp:201
#5  0x00007f1efa7e727f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#6  0x00007f1efa8b2cbf in QInotifyFileSystemWatcherEngine::run (this=0x2010cc0) at io/qfilesystemwatcher_inotify.cpp:248
#7  0x00007f1efa7e9d05 in QThreadPrivate::start (arg=0x2010cc0) at thread/qthread_unix.cpp:331
#8  0x00007f1ef27a1edc in start_thread (arg=0x7f1edb312700) at pthread_create.c:304
#9  0x00007f1efd71389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f1ed898d700 (LWP 1517)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f1ed898cad0 in ?? ()
#2  0x00007fff052c97e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 4 (Thread 0x7f1ed13e3700 (LWP 1947)):
#0  0x00007f1ef27a4014 in __pthread_mutex_lock (mutex=0x3ecb5f8) at pthread_mutex_lock.c:61
#1  0x00007f1ef1c945ba in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1ef1c95072 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1ef1c95882 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f1ecb4f69a6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#5  0x00007f1ef1cba616 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f1ef27a1edc in start_thread (arg=0x7f1ed13e3700) at pthread_create.c:304
#7  0x00007f1efd71389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#8  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f1ecfd8e700 (LWP 2008)):
#0  0x00007f1ef27a401e in __pthread_mutex_lock (mutex=0x2fed688) at pthread_mutex_lock.c:62
#1  0x00007f1ef1c94113 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1ef1c94eed in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1ef1c95519 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f1efa8fbf3e in QEventDispatcherGlib::processEvents (this=0x3ebf600, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f1efa8cfcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f1efa8cfef7 in QEventLoop::exec (this=0x7f1ecfd8dde0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f1efa7e727f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#8  0x00007f1efa7e9d05 in QThreadPrivate::start (arg=0x2457390) at thread/qthread_unix.cpp:331
#9  0x00007f1ef27a1edc in start_thread (arg=0x7f1ecfd8e700) at pthread_create.c:304
#10 0x00007f1efd71389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f1ec9d36700 (LWP 2312)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f1ef7900fe2 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f1ef7901019 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f1ef27a1edc in start_thread (arg=0x7f1ec9d36700) at pthread_create.c:304
#4  0x00007f1efd71389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f1efde257a0 (LWP 1515)):
[KCrash Handler]
#6  QGraphicsLayoutItemPrivate::hasHeightForWidth (this=0x2f273d687461702c) at graphicsview/qgraphicslayoutitem.cpp:280
#7  0x00007f1efa2a81c1 in QGridLayoutItem::hasDynamicConstraint (this=<optimized out>) at graphicsview/qgridlayoutengine.cpp:576
#8  0x00007f1efa2a92e2 in ensureDynamicConstraint (this=0x3703220) at graphicsview/qgridlayoutengine.cpp:1657
#9  QGridLayoutEngine::ensureDynamicConstraint (this=0x3703220) at graphicsview/qgridlayoutengine.cpp:1652
#10 0x00007f1efa2a9399 in QGridLayoutEngine::hasDynamicConstraint (this=0x3703220) at graphicsview/qgridlayoutengine.cpp:1677
#11 0x00007f1efa2ad6c8 in QGridLayoutEngine::sizeHint (this=0x3703220, styleInfo=..., which=Qt::MaximumSize, constraint=...) at graphicsview/qgridlayoutengine.cpp:1134
#12 0x00007f1efa236c4a in QGraphicsGridLayout::sizeHint (this=<optimized out>, which=Qt::MaximumSize, constraint=...) at graphicsview/qgraphicsgridlayout.cpp:656
#13 0x00007f1efa261809 in QGraphicsLayoutItemPrivate::effectiveSizeHints (this=0x3703110, constraint=...) at graphicsview/qgraphicslayoutitem.cpp:169
#14 0x00007f1efa2620c1 in effectiveSizeHint (constraint=<optimized out>, which=<optimized out>, this=<optimized out>) at graphicsview/qgraphicslayoutitem.cpp:818
#15 QGraphicsLayoutItem::effectiveSizeHint (this=<optimized out>, which=<optimized out>, constraint=<optimized out>) at graphicsview/qgraphicslayoutitem.cpp:810
#16 0x00007f1efa29ee61 in QGraphicsWidget::sizeHint (this=<optimized out>, which=<optimized out>, constraint=<optimized out>) at graphicsview/qgraphicswidget.cpp:743
#17 0x00007f1efa2618df in QGraphicsLayoutItemPrivate::effectiveSizeHints (this=0x3703020, constraint=...) at graphicsview/qgraphicslayoutitem.cpp:175
#18 0x00007f1efa2620c1 in effectiveSizeHint (constraint=<optimized out>, which=<optimized out>, this=<optimized out>) at graphicsview/qgraphicslayoutitem.cpp:818
#19 QGraphicsLayoutItem::effectiveSizeHint (this=<optimized out>, which=<optimized out>, constraint=<optimized out>) at graphicsview/qgraphicslayoutitem.cpp:810
#20 0x00007f1ee3c57905 in SystemTray::TaskArea::adjustHiddentTasksWidget (this=0x36febe0) at ../../../../../plasma/generic/applets/systemtray/ui/taskarea.cpp:452
#21 0x00007f1ee3c595d9 in SystemTray::TaskArea::addWidgetForTask (this=0x36febe0, task=0x53390a0) at ../../../../../plasma/generic/applets/systemtray/ui/taskarea.cpp:320
#22 0x00007f1ee3c59926 in SystemTray::TaskArea::addTask (this=0x36febe0, task=<optimized out>) at ../../../../../plasma/generic/applets/systemtray/ui/taskarea.cpp:196
#23 0x00007f1ee3c5a124 in SystemTray::TaskArea::qt_metacall (this=0x36febe0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff05233f20) at ./taskarea.moc:89
#24 0x00007f1efa8e3eba in QMetaObject::activate (sender=0x1ad68e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff05233f20) at kernel/qobject.cpp:3278
#25 0x00007f1ee3c3c87f in SystemTray::Manager::taskAdded (this=<optimized out>, _t1=0x53390a0) at ./manager.moc:99
#26 0x00007f1ee3c3ca95 in SystemTray::Manager::addTask (this=0x1ad68e0, task=0x53390a0) at ../../../../../plasma/generic/applets/systemtray/core/manager.cpp:87
#27 0x00007f1ee3c3cbe4 in SystemTray::Manager::qt_metacall (this=0x1ad68e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff05234090) at ./manager.moc:86
#28 0x00007f1efa8e3eba in QMetaObject::activate (sender=0x1ad6520, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff05234090) at kernel/qobject.cpp:3278
#29 0x00007f1ee3c3d08f in SystemTray::Protocol::taskCreated (this=<optimized out>, _t1=0x53390a0) at ./protocol.moc:91
#30 0x00007f1ee3c44178 in SystemTray::PlasmoidProtocol::addApplet (this=0x1ad6520, appletName=..., id=<optimized out>, parent=0x3d7da00) at ../../../../../plasma/generic/applets/systemtray/protocols/plasmoid/plasmoidtaskprotocol.cpp:112
#31 0x00007f1ee3c3c6d6 in SystemTray::Manager::addApplet (this=<optimized out>, appletName=<optimized out>, parent=<optimized out>) at ../../../../../plasma/generic/applets/systemtray/core/manager.cpp:110
#32 0x00007f1ee3c4ea30 in SystemTray::Applet::checkDefaultApplets (this=0x3d7da00) at ../../../../../plasma/generic/applets/systemtray/ui/applet.cpp:737
#33 0x00007f1ee3c4fa4c in SystemTray::Applet::qt_metacall (this=0x3d7da00, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x37d3490) at ./applet.moc:91
#34 0x00007f1efa8e7a5e in QObject::event (this=0x3d7da00, e=<optimized out>) at kernel/qobject.cpp:1217
#35 0x00007f1efa29f4cb in QGraphicsWidget::event (this=0x3d7da00, event=0x37d13b0) at graphicsview/qgraphicswidget.cpp:1455
#36 0x00007f1ef9c81434 in notify_helper (e=0x37d13b0, receiver=0x3d7da00, this=0x1791cd0) at kernel/qapplication.cpp:4486
#37 QApplicationPrivate::notify_helper (this=0x1791cd0, receiver=0x3d7da00, e=0x37d13b0) at kernel/qapplication.cpp:4458
#38 0x00007f1ef9c862a1 in QApplication::notify (this=0x1784400, receiver=0x3d7da00, e=0x37d13b0) at kernel/qapplication.cpp:4365
#39 0x00007f1efb57f266 in KApplication::notify (this=0x1784400, receiver=0x3d7da00, event=0x37d13b0) at ../../kdeui/kernel/kapplication.cpp:311
#40 0x00007f1efa8d0afc in QCoreApplication::notifyInternal (this=0x1784400, receiver=0x3d7da00, event=0x37d13b0) at kernel/qcoreapplication.cpp:787
#41 0x00007f1efa8d451f in sendEvent (event=0x37d13b0, receiver=0x3d7da00) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#42 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1723430) at kernel/qcoreapplication.cpp:1428
#43 0x00007f1efa8fba73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#44 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#45 0x00007f1ef1c94b4d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#46 0x00007f1ef1c95348 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#47 0x00007f1ef1c95519 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#48 0x00007f1efa8fbed6 in QEventDispatcherGlib::processEvents (this=0x1724f40, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#49 0x00007f1ef9d28cce in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#50 0x00007f1efa8cfcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#51 0x00007f1efa8cfef7 in QEventLoop::exec (this=0x7fff05234af0, flags=...) at kernel/qeventloop.cpp:201
#52 0x00007f1efa8d4789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#53 0x00007f1efda121a3 in kdemain (argc=1, argv=0x7fff05234ed8) at ../../../../plasma/desktop/shell/main.cpp:120
#54 0x00007f1efd65330d in __libc_start_main (main=0x400640 <main(int, char**)>, argc=1, ubp_av=0x7fff05234ed8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff05234ec8) at libc-start.c:226
#55 0x0000000000400671 in _start ()

Possible duplicates by query: bug 282680, bug 282622, bug 282552, bug 281854, bug 281822.

Reported using DrKonqi
Comment 1 Dario Andres 2011-09-29 13:25:29 UTC
[Comment from a bug report cleaner]
This is related to bug 282552, as the backtrace is mostly the same, and the situation also matches.
Comment 2 Dario Andres 2011-09-29 13:25:31 UTC
*** Bug 282748 has been marked as a duplicate of this bug. ***
Comment 3 Dario Andres 2011-09-29 13:25:34 UTC
*** Bug 281854 has been marked as a duplicate of this bug. ***
Comment 4 m.wege 2011-10-06 11:42:18 UTC
Created attachment 64282 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.7.1 (4.7.1) using Qt 4.7.2

- What I was doing when the application crashed: I was adding a panel on my second screen, then the crash occured.

-- Backtrace (Reduced):
#6  QGraphicsLayoutItemPrivate::hasHeightForWidth (this=<value optimized out>) at graphicsview/qgraphicslayoutitem.cpp:282
#7  0x0000003dc05e9581 in QGridLayoutItem::hasDynamicConstraint (this=0x8260c20) at graphicsview/qgridlayoutengine.cpp:576
#8  0x0000003dc05ea839 in QGridLayoutEngine::ensureDynamicConstraint (this=0x828d1b0) at graphicsview/qgridlayoutengine.cpp:1657
#9  0x0000003dc05ea8e9 in QGridLayoutEngine::hasDynamicConstraint (this=0x828d1b0) at graphicsview/qgridlayoutengine.cpp:1677
#10 0x0000003dc05ee638 in QGridLayoutEngine::sizeHint (this=0x828d1b0, styleInfo=..., which=Qt::MaximumSize, constraint=...) at graphicsview/qgridlayoutengine.cpp:1134
Comment 5 Lamarque V. Souza 2011-10-29 01:30:58 UTC

*** This bug has been marked as a duplicate of bug 282552 ***