Bug 282748 - Plasma crashed by adding a default panel
Summary: Plasma crashed by adding a default panel
Status: RESOLVED DUPLICATE of bug 282738
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-25 18:25 UTC by Gatoso
Modified: 2011-10-17 21:55 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments
New crash information added by DrKonqi (17.82 KB, text/plain)
2011-10-17 21:55 UTC, tadeas hollan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gatoso 2011-09-25 18:25:01 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.1 (4.7.1) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0-pae i686
Distribution (Platform): Archlinux Packages

-- Information about the crash:
- What I was doing when the application crashed:

When I add a new default (or predetermined) panel, plasma crashes.

It occurs every time I do this.

Thanks so much.

- Unusual behavior I noticed:

The crash can be reproduced every time.

-- Backtrace:
Application: Shell de escritorio Plasma (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb5599710 (LWP 1214))]

Thread 3 (Thread 0xa95e8b70 (LWP 1215)):
#0  0xb5a69d80 in clock_gettime () from /lib/librt.so.1
#1  0xb6d2dee5 in do_gettime (frac=0xa95e7f60, sec=0xa95e7f58) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6e10376 in QTimerInfoList::updateCurrentTime (this=0x8a0823c) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb6e1073a in QTimerInfoList::timerWait (this=0x8a0823c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb6e0eb53 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xa95e806c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb6e0ebf5 in timerSourcePrepare (source=0x8a08208, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb59b6f8c in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#8  0xb59b7e47 in g_main_context_iterate.isra.19 () from /usr/lib/libglib-2.0.so.0
#9  0xb59b84da in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#10 0xb6e0f75f in QEventDispatcherGlib::processEvents (this=0x89e6798, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb6ddaf7d in QEventLoop::processEvents (this=0xa95e81f0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb6ddb1c9 in QEventLoop::exec (this=0xa95e81f0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb6ccca35 in QThread::exec (this=0x89e57d8) at thread/qthread.cpp:498
#14 0xb6db8ab3 in QInotifyFileSystemWatcherEngine::run (this=0x89e57d8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb6ccff0b in QThreadPrivate::start (arg=0x89e57d8) at thread/qthread_unix.cpp:331
#16 0xb235d9cd in ?? () from /usr/lib/libGL.so.1
#17 0xb5f5d8ce in clone () from /lib/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 2 (Thread 0xa32f0b70 (LWP 1997)):
#0  0xb7831424 in __kernel_vsyscall ()
#1  0xb6c5895b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb31c3561 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0xb32c8ac0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#3  0xb31c359f in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0xb32c8ac0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#4  0xb235d9cd in ?? () from /usr/lib/libGL.so.1
#5  0xb5f5d8ce in clone () from /lib/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb5599710 (LWP 1214)):
[KCrash Handler]
#7  QGraphicsLayoutItemPrivate::hasHeightForWidth (this=0x75006e) at graphicsview/qgraphicslayoutitem.cpp:280
#8  0xb69813e8 in QGridLayoutItem::hasDynamicConstraint (this=0xa048930) at graphicsview/qgridlayoutengine.cpp:576
#9  0xb6982829 in ensureDynamicConstraint (this=0xa056570) at graphicsview/qgridlayoutengine.cpp:1657
#10 QGridLayoutEngine::ensureDynamicConstraint (this=0xa056570) at graphicsview/qgridlayoutengine.cpp:1652
#11 0xb69828b0 in QGridLayoutEngine::hasDynamicConstraint (this=0xa056570) at graphicsview/qgridlayoutengine.cpp:1677
#12 0xb6989162 in QGridLayoutEngine::sizeHint (this=0xa056570, styleInfo=..., which=Qt::MaximumSize, constraint=...) at graphicsview/qgridlayoutengine.cpp:1134
#13 0xb68f858f in QGraphicsGridLayout::sizeHint (this=0x9ffb7a8, which=Qt::MaximumSize, constraint=...) at graphicsview/qgraphicsgridlayout.cpp:656
#14 0xb692b1e5 in QGraphicsLayoutItemPrivate::effectiveSizeHints (this=0xa056480, constraint=...) at graphicsview/qgraphicslayoutitem.cpp:169
#15 0xb692c00c in effectiveSizeHint (constraint=..., which=Qt::MinimumSize, this=<optimized out>) at graphicsview/qgraphicslayoutitem.cpp:818
#16 QGraphicsLayoutItem::effectiveSizeHint (this=0x9ffb7a8, which=Qt::MinimumSize, constraint=...) at graphicsview/qgraphicslayoutitem.cpp:810
#17 0xb69769fc in QGraphicsWidget::sizeHint (this=0xa04f010, which=Qt::MinimumSize, constraint=...) at graphicsview/qgraphicswidget.cpp:743
#18 0xb692b297 in QGraphicsLayoutItemPrivate::effectiveSizeHints (this=0xa056d60, constraint=...) at graphicsview/qgraphicslayoutitem.cpp:175
#19 0xb692c00c in effectiveSizeHint (constraint=..., which=Qt::PreferredSize, this=<optimized out>) at graphicsview/qgraphicslayoutitem.cpp:818
#20 QGraphicsLayoutItem::effectiveSizeHint (this=0xa04f020, which=Qt::PreferredSize, constraint=...) at graphicsview/qgraphicslayoutitem.cpp:810
#21 0xaf19c1c1 in SystemTray::TaskArea::adjustHiddentTasksWidget (this=0xa050920) at /home/zuargo/Paquetes/kdebase-workspace/src/kde-workspace-4.7.1/plasma/generic/applets/systemtray/ui/taskarea.cpp:452
#22 0xaf19dc16 in SystemTray::TaskArea::addWidgetForTask (this=0xa050920, task=0x99922c0) at /home/zuargo/Paquetes/kdebase-workspace/src/kde-workspace-4.7.1/plasma/generic/applets/systemtray/ui/taskarea.cpp:320
#23 0xaf19df1f in SystemTray::TaskArea::addTask (this=0xa050920, task=0x99922c0) at /home/zuargo/Paquetes/kdebase-workspace/src/kde-workspace-4.7.1/plasma/generic/applets/systemtray/ui/taskarea.cpp:196
#24 0xaf19e765 in SystemTray::TaskArea::qt_metacall (this=0xa050920, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf88d4f8) at /home/zuargo/Paquetes/kdebase-workspace/src/build/plasma/generic/applets/systemtray/taskarea.moc:89
#25 0xb6de3aa4 in metacall (argv=<optimized out>, idx=23, cl=QMetaObject::InvokeMetaMethod, object=0xa050920) at kernel/qmetaobject.cpp:237
#26 QMetaObject::metacall (object=0xa050920, cl=QMetaObject::InvokeMetaMethod, idx=23, argv=0xbf88d4f8) at kernel/qmetaobject.cpp:232
#27 0xb6df30e0 in QMetaObject::activate (sender=0x856c060, m=0xaf1b9358, local_signal_index=0, argv=0xbf88d4f8) at kernel/qobject.cpp:3278
#28 0xaf17a345 in SystemTray::Manager::taskAdded (this=0x856c060, _t1=0x99922c0) at /home/zuargo/Paquetes/kdebase-workspace/src/build/plasma/generic/applets/systemtray/manager.moc:99
#29 0xaf17a6d4 in SystemTray::Manager::addTask (this=0x856c060, task=0x99922c0) at /home/zuargo/Paquetes/kdebase-workspace/src/kde-workspace-4.7.1/plasma/generic/applets/systemtray/core/manager.cpp:87
#30 0xaf17a8f5 in SystemTray::Manager::qt_metacall (this=0x856c060, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf88d6a8) at /home/zuargo/Paquetes/kdebase-workspace/src/build/plasma/generic/applets/systemtray/manager.moc:86
#31 0xb6de3aa4 in metacall (argv=<optimized out>, idx=7, cl=QMetaObject::InvokeMetaMethod, object=0x856c060) at kernel/qmetaobject.cpp:237
#32 QMetaObject::metacall (object=0x856c060, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbf88d6a8) at kernel/qmetaobject.cpp:232
#33 0xb6df30e0 in QMetaObject::activate (sender=0x8541130, m=0xaf1b93bc, local_signal_index=0, argv=0xbf88d6a8) at kernel/qobject.cpp:3278
#34 0xaf17b365 in SystemTray::Protocol::taskCreated (this=0x8541130, _t1=0x99922c0) at /home/zuargo/Paquetes/kdebase-workspace/src/build/plasma/generic/applets/systemtray/protocol.moc:91
#35 0xaf1868d0 in SystemTray::PlasmoidProtocol::addApplet (this=0x8541130, appletName=..., id=0, parent=0xa090670) at /home/zuargo/Paquetes/kdebase-workspace/src/kde-workspace-4.7.1/plasma/generic/applets/systemtray/protocols/plasmoid/plasmoidtaskprotocol.cpp:112
#36 0xaf17a1b0 in SystemTray::Manager::addApplet (this=0x856c060, appletName=..., parent=0xa090670) at /home/zuargo/Paquetes/kdebase-workspace/src/kde-workspace-4.7.1/plasma/generic/applets/systemtray/core/manager.cpp:110
#37 0xaf191cb7 in SystemTray::Applet::checkDefaultApplets (this=0xa090670) at /home/zuargo/Paquetes/kdebase-workspace/src/kde-workspace-4.7.1/plasma/generic/applets/systemtray/ui/applet.cpp:737
#38 0xaf1928b8 in SystemTray::Applet::qt_metacall (this=0xa090670, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0x9fabe18) at /home/zuargo/Paquetes/kdebase-workspace/src/build/plasma/generic/applets/systemtray/applet.moc:91
#39 0xb6de3aa4 in metacall (argv=<optimized out>, idx=83, cl=QMetaObject::InvokeMetaMethod, object=0xa090670) at kernel/qmetaobject.cpp:237
#40 QMetaObject::metacall (object=0xa090670, cl=QMetaObject::InvokeMetaMethod, idx=83, argv=0x9fabe18) at kernel/qmetaobject.cpp:232
#41 0xb6def505 in QMetaCallEvent::placeMetaCall (this=0xa043190, object=0xa090670) at kernel/qobject.cpp:535
#42 0xb6df84b2 in QObject::event (this=0xa090670, e=0xa043190) at kernel/qobject.cpp:1217
#43 0xb697724c in QGraphicsWidget::event (this=0xa090670, event=0xa043190) at graphicsview/qgraphicswidget.cpp:1455
#44 0xb621b59c in notify_helper (e=0xa043190, receiver=0xa090670, this=0x836a820) at kernel/qapplication.cpp:4481
#45 QApplicationPrivate::notify_helper (this=0x836a820, receiver=0xa090670, e=0xa043190) at kernel/qapplication.cpp:4453
#46 0xb6221740 in QApplication::notify (this=0x836a820, receiver=0xa090670, e=0xa043190) at kernel/qapplication.cpp:4360
#47 0xb7540b48 in KApplication::notify (this=0x8332a80, receiver=0xa090670, event=0xa043190) at /home/zuargo/Paquetes/kdelibs/src/kdelibs-4.7.1/kdeui/kernel/kapplication.cpp:311
#48 0xb6ddc8ce in QCoreApplication::notifyInternal (this=0x8332a80, receiver=0xa090670, event=0xa043190) at kernel/qcoreapplication.cpp:787
#49 0xb6de0ba8 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#50 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x82706d8) at kernel/qcoreapplication.cpp:1428
#51 0xb6de0dfc in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#52 0xb6e0f224 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#53 postEventSourceDispatch (s=0x836c900) at kernel/qeventdispatcher_glib.cpp:277
#54 0xb59b7a1f in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#55 0xb59b8198 in g_main_context_iterate.isra.19 () from /usr/lib/libglib-2.0.so.0
#56 0xb59b84da in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#57 0xb6e0f6fa in QEventDispatcherGlib::processEvents (this=0x8366fb0, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#58 0xb62df3ba in QGuiEventDispatcherGlib::processEvents (this=0x8366fb0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#59 0xb6ddaf7d in QEventLoop::processEvents (this=0xbf88df24, flags=...) at kernel/qeventloop.cpp:149
#60 0xb6ddb1c9 in QEventLoop::exec (this=0xbf88df24, flags=...) at kernel/qeventloop.cpp:201
#61 0xb6de0ead in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#62 0xb6219384 in QApplication::exec () at kernel/qapplication.cpp:3755
#63 0xb056dbc0 in kdemain (argc=1, argv=0x83137e8) at /home/zuargo/Paquetes/kdebase-workspace/src/kde-workspace-4.7.1/plasma/desktop/shell/main.cpp:120
#64 0x0804ec4b in launch (argc=1, _name=0x832ffa4 "/usr/bin/plasma-desktop", args=<optimized out>, cwd=0x0, envc=0, envs=<optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x8052df9 "0") at /home/zuargo/Paquetes/kdelibs/src/kdelibs-4.7.1/kinit/kinit.cpp:734
#65 0x0804fbe6 in handle_launcher_request (sock=<optimized out>, who=<optimized out>) at /home/zuargo/Paquetes/kdelibs/src/kdelibs-4.7.1/kinit/kinit.cpp:1226
#66 0x080500ac in handle_requests (waitForPid=0) at /home/zuargo/Paquetes/kdelibs/src/kdelibs-4.7.1/kinit/kinit.cpp:1419
#67 0x0804b955 in main (argc=) at /home/zuargo/Paquetes/kdelibs/src/kdelibs-4.7.1/kinit/kinit.cpp:1907

This bug may be a duplicate of or related to bug 282552.

Possible duplicates by query: bug 282738, bug 282680, bug 282622, bug 282552, bug 281854.

Reported using DrKonqi
Comment 1 Dario Andres 2011-09-29 13:25:31 UTC
[Comment from a bug triager]
This issue is being tracked at bug 282738 (and other related reports), merging.
Thanks

*** This bug has been marked as a duplicate of bug 282738 ***
Comment 2 tadeas hollan 2011-10-17 21:55:11 UTC
Created attachment 64652 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.7.1 (4.7.1) using Qt 4.7.4

- What I was doing when the application crashed: Addidng default panel. The desktop enviroment crashed and restarted. Panel was not created.

-- Backtrace (Reduced):
#6  QGraphicsLayoutItemPrivate::hasHeightForWidth (this=0x0) at graphicsview/qgraphicslayoutitem.cpp:280
#7  0x00007f66db004591 in QGridLayoutItem::hasDynamicConstraint (this=<optimized out>) at graphicsview/qgridlayoutengine.cpp:576
#8  0x00007f66db0056b2 in ensureDynamicConstraint (this=0x4bde260) at graphicsview/qgridlayoutengine.cpp:1657
#9  QGridLayoutEngine::ensureDynamicConstraint (this=0x4bde260) at graphicsview/qgridlayoutengine.cpp:1652
#10 0x00007f66db005769 in QGridLayoutEngine::hasDynamicConstraint (this=0x4bde260) at graphicsview/qgridlayoutengine.cpp:1677