Bug 282182

Summary: root mode (su) applications crash from GUI & cli
Product: [I don't know] kde Reporter: Thomas Taylor <linxt>
Component: generalAssignee: Unassigned bugs mailing-list <unassigned-bugs>
Severity: crash CC: inster.css, johanp, mark, sebzag, sidicas, stonecold.1995, ubuntuaddictedubu
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: openSUSE   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: install logs from todays zypper dup

Description Thomas Taylor 2011-09-17 07:37:57 UTC
Created attachment 63715 [details]
install logs from todays zypper dup 

Version:           unspecified (using KDE 4.7.1) 
OS:                Linux

Root-mode applications (kate & krusader) crash apparently because dbus is not started first.  This happens both in GUI and CLI modes.  Dolphin in super-user mode starts properly.  Haven't tried other programs.

This is in openSUSE 12.1 and has occurred in all the milestones.  I submitted bug #702247 to them. 

Reproducible: Always

Steps to Reproduce:
From cli, enter "krusader" (w/o quotes).  It then displays an error message about needing to enter "export $(dbus-launch)".  
after that krusader or kate will run in root-mode.

Actual Results:  
Error about either session bus (since todays zypper dup) or dbus-launch (before today).  

When "export $(dbus-launch)" is entered the apps run properly in root-mode. 

Expected Results:  
The apps should start up in either GUI or CLI w/o needing export command.

******* cli message after crash ********

root@desktop-linux1= /home/tom # krusader
KGlobal::locale::Warning your global KLocale is being recreated with a valid
main component instead of a fake component, this usually means you tried to call
i18n related functions before your main component was created. You should not do
that since it most likely will not work
krusader(9170)/kdeui (kdelibs): Session bus not found
To circumvent this problem try the following command (with Linux and bash)
export $(dbus-launch)
KCrash: Application 'krusader' crashing...
KCrash: Attempting to start /usr/lib64/kde4/libexec/drkonqi from kdeinit

[1]+  Stopped                 krusader
root@desktop-linux1= /home/tom #

******* crash report ********

Application: krusader (2.0.0 "Mars Pathfinder")
KDE Platform Version: 4.7.1 (4.7.1)
Qt Version: 4.7.4
Operating System: Linux 3.1.0-rc5-2-desktop x86_64
Distribution: "openSUSE 12.1 Milestone 5 (x86_64)"

-- Information about the crash:
<In detail, tell us what you were doing  when the application crashed.>

The crash can be reproduced every time.

-- Backtrace:
Application: Krusader - ROOT PRIVILEGES (krusader), signal: Aborted
[KCrash Handler]
#6  0x00007f93ec874d05 in raise () from /lib64/libc.so.6
#7  0x00007f93ec87621b in abort () from /lib64/libc.so.6
#8  0x00007f93ed4189e4 in qt_message_output (msgType=<optimized out>, buf=<optimized out>) at global/qglobal.cpp:2291
#9  0x00007f93eff8564d in ~QDebug (this=0x7fff8d0a1750, __in_chrg=<optimized out>) at /usr/include/QtCore/qdebug.h:85
#10 QDebug::~QDebug (this=0x7fff8d0a1750, __in_chrg=<optimized out>) at /usr/include/QtCore/qdebug.h:81
#11 0x00007f93f006e2fb in KApplicationPrivate::init (this=0x9605e0, GUIenabled=<optimized out>) at /usr/src/debug/kdelibs-4.7.1/kdeui/kernel/kapplication.cpp:516
#12 0x00007f93f006f378 in KApplication::KApplication (this=0x7fff8d0a1bb0, GUIenabled=true) at /usr/src/debug/kdelibs-4.7.1/kdeui/kernel/kapplication.cpp:352
#13 0x000000000047cdae in ?? ()
#14 0x00000000004544a5 in ?? ()
#15 0x00007f93ec86121d in __libc_start_main () from /lib64/libc.so.6
#16 0x0000000000457b75 in _start ()

Also, the crash reporter failed to send report after repeatedly downloading debugging symbols.
Comment 1 Christoph Feck 2011-09-17 10:23:09 UTC

*** This bug has been marked as a duplicate of bug 270442 ***
Comment 2 Christoph Feck 2012-09-24 10:11:36 UTC
*** Bug 307311 has been marked as a duplicate of this bug. ***
Comment 3 Christoph Feck 2012-09-29 15:15:00 UTC
*** Bug 307558 has been marked as a duplicate of this bug. ***
Comment 4 Christoph Feck 2012-10-04 17:11:22 UTC
*** Bug 307852 has been marked as a duplicate of this bug. ***
Comment 5 Frank Reininghaus 2013-10-01 22:17:50 UTC
*** Bug 325519 has been marked as a duplicate of this bug. ***
Comment 6 Frank Reininghaus 2014-04-16 20:19:30 UTC
*** Bug 333513 has been marked as a duplicate of this bug. ***
Comment 7 Christoph Feck 2014-07-22 03:40:02 UTC
*** Bug 337662 has been marked as a duplicate of this bug. ***
Comment 8 Christoph Feck 2014-11-01 14:47:41 UTC
*** Bug 340544 has been marked as a duplicate of this bug. ***