Bug 275177

Summary: Marble crashes while zooming in
Product: marble Reporter: Patricia Wilson <wilson.pr.gm>
Component: generalAssignee: marble-bugs
Status: RESOLVED DUPLICATE    
Severity: crash CC: nienhueser
Priority: NOR    
Version: unspecified   
Target Milestone: 1.1.0   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In: 1.0.4

Description Patricia Wilson 2011-06-08 04:25:26 UTC
Application: marble (1.0.2 (Stable Release))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic-pae i686
Distribution: Ubuntu 11.04

-- Information about the crash:
I was zooming into the globe immediately after startup. 
Problem repeats.
OS is Ubuntu 11.04 running on a 686.

The crash can be reproduced every time.

-- Backtrace:
Application: Marble Virtual Globe (marble), signal: Segmentation fault
[Current thread is 1 (Thread 0xb3881970 (LWP 22615))]

Thread 7 (Thread 0xb343fb70 (LWP 22617)):
#0  0xb7873424 in __kernel_vsyscall ()
#1  0xb5cfbf76 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb424084b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb42301af in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb423092b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb357c304 in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#6  0xb42592df in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0xb42dee99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0xb5d0a73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 6 (Thread 0xaf5e7b70 (LWP 22619)):
#0  0xb7873424 in __kernel_vsyscall ()
#1  0xb5cfbf76 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb424084b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb42301af in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb4230524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb6bb1577 in QEventDispatcherGlib::processEvents (this=0x8d72328, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0xb6b83289 in QEventLoop::processEvents (this=0xaf5e7290, flags=...) at kernel/qeventloop.cpp:149
#7  0xb6b83522 in QEventLoop::exec (this=0xaf5e7290, flags=...) at kernel/qeventloop.cpp:201
#8  0xb6a8d2a0 in QThread::exec (this=0x8d71f40) at thread/qthread.cpp:492
#9  0xb6b64fdb in QInotifyFileSystemWatcherEngine::run (this=0x8d71f40) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb6a8fda2 in QThreadPrivate::start (arg=0x8d71f40) at thread/qthread_unix.cpp:320
#11 0xb42dee99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb5d0a73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 5 (Thread 0xaeb9eb70 (LWP 22620)):
#0  0xb42e27af in __pthread_mutex_unlock_usercnt () from /lib/i386-linux-gnu/libpthread.so.0
#1  0xb5d18656 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#2  0xb422f648 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb423003a in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb4230524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb6bb1577 in QEventDispatcherGlib::processEvents (this=0x8e4fa50, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0xb6b83289 in QEventLoop::processEvents (this=0xaeb9e290, flags=...) at kernel/qeventloop.cpp:149
#7  0xb6b83522 in QEventLoop::exec (this=0xaeb9e290, flags=...) at kernel/qeventloop.cpp:201
#8  0xb6a8d2a0 in QThread::exec (this=0x8d08910) at thread/qthread.cpp:492
#9  0xb6b64fdb in QInotifyFileSystemWatcherEngine::run (this=0x8d08910) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb6a8fda2 in QThreadPrivate::start (arg=0x8d08910) at thread/qthread_unix.cpp:320
#11 0xb42dee99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb5d0a73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 4 (Thread 0xae39db70 (LWP 22621)):
#0  0xb42c9d41 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb6ae5dd8 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6bb24f2 in updateCurrentTime (this=0xb2b08034, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0xb2b08034, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb6bb0d32 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xae39d0dc) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb6bb0dcd in timerSourcePrepare (source=0xb2b08000, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb422efd4 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb422fe63 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb4230524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb6bb1577 in QEventDispatcherGlib::processEvents (this=0x8e589f0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb6b83289 in QEventLoop::processEvents (this=0xae39d290, flags=...) at kernel/qeventloop.cpp:149
#12 0xb6b83522 in QEventLoop::exec (this=0xae39d290, flags=...) at kernel/qeventloop.cpp:201
#13 0xb6a8d2a0 in QThread::exec (this=0x8e59e00) at thread/qthread.cpp:492
#14 0xb6b64fdb in QInotifyFileSystemWatcherEngine::run (this=0x8e59e00) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb6a8fda2 in QThreadPrivate::start (arg=0x8e59e00) at thread/qthread_unix.cpp:320
#16 0xb42dee99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0xb5d0a73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xaab96b70 (LWP 22628)):
#0  0xb42c9d41 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb6ae5dd8 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6bb24f2 in updateCurrentTime (this=0x8f88214, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0x8f88214, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb6bb0d32 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xaab960cc) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb6bb0dcd in timerSourcePrepare (source=0x8f881e0, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb422efd4 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb422fe63 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb4230524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb6bb1577 in QEventDispatcherGlib::processEvents (this=0x8ea66b8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb6b83289 in QEventLoop::processEvents (this=0xaab96280, flags=...) at kernel/qeventloop.cpp:149
#12 0xb6b83522 in QEventLoop::exec (this=0xaab96280, flags=...) at kernel/qeventloop.cpp:201
#13 0xb6a8d2a0 in QThread::exec (this=0xb2b05338) at thread/qthread.cpp:492
#14 0xb76d4ef8 in Marble::FileStorageWatcher::run (this=0xb2b05338) at ../../../../marble/src/lib/FileStorageWatcher.cpp:401
#15 0xb6a8fda2 in QThreadPrivate::start (arg=0xb2b05338) at thread/qthread_unix.cpp:320
#16 0xb42dee99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0xb5d0a73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xb2089b70 (LWP 22638)):
#0  0xb7873424 in __kernel_vsyscall ()
#1  0xb42e3834 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb5d18454 in pthread_cond_timedwait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb6a903e5 in wait (this=0x983baf4, mutex=0x983baf0, time=30000) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0x983baf4, mutex=0x983baf0, time=30000) at thread/qwaitcondition_unix.cpp:160
#5  0xb6a838f1 in QThreadPoolThread::run (this=0x98c5980) at concurrent/qthreadpool.cpp:140
#6  0xb6a8fda2 in QThreadPrivate::start (arg=0x98c5980) at thread/qthread_unix.cpp:320
#7  0xb42dee99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0xb5d0a73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb3881970 (LWP 22615)):
[KCrash Handler]
#7  0xb76c8425 in Marble::AbstractScanlineTextureMapper::pixelValue (this=0x8ea27a8, lon=-2.0500900439374838, lat=0.64657715726826781, scanLine=0xa9733008) at ../../../../marble/src/lib/AbstractScanlineTextureMapper.cpp:163
#8  0xb76ca020 in Marble::SphericalScanlineTextureMapper::mapTexture (this=0x8ea27a8, viewParams=0x8d7896c, texColorizer=0x8ec9e98) at ../../../../marble/src/lib/SphericalScanlineTextureMapper.cpp:235
#9  0xb76ca263 in Marble::SphericalScanlineTextureMapper::mapTexture (this=0x8ea27a8, painter=0xbf96c5fc, viewParams=0x8d7896c, dirtyRect=..., texColorizer=0x8ec9e98) at ../../../../marble/src/lib/SphericalScanlineTextureMapper.cpp:51
#10 0xb76bf8b6 in Marble::TextureLayer::paintGlobe (this=0x8d7898c, painter=0xbf96c5fc, viewParams=0x8d7896c, dirtyRect=...) at ../../../../marble/src/lib/TextureLayer.cpp:161
#11 0xb76365d2 in Marble::MarbleMapPrivate::paintGround (this=0x8d78960, painter=..., dirtyRect=...) at ../../../../marble/src/lib/MarbleMap.cpp:188
#12 0xb7626458 in Marble::MarbleWidget::paintEvent (this=0x8d70e70, evt=0xbf96cbc4) at ../../../../marble/src/lib/MarbleWidget.cpp:805
#13 0xb613718e in QWidget::event (this=0x8d70e70, event=0xbf96cbc4) at kernel/qwidget.cpp:8405
#14 0xb60ded24 in QApplicationPrivate::notify_helper (this=0x8bb49b0, receiver=0x8d70e70, e=0xbf96cbc4) at kernel/qapplication.cpp:4462
#15 0xb60e397b in QApplication::notify (this=0xbf96e894, receiver=0x8d70e70, e=0xbf96cbc4) at kernel/qapplication.cpp:4427
#16 0xb71143ca in KApplication::notify (this=0xbf96e894, receiver=0x8d70e70, event=0xbf96cbc4) at ../../kdeui/kernel/kapplication.cpp:311
#17 0xb6b840bb in QCoreApplication::notifyInternal (this=0xbf96e894, receiver=0x8d70e70, event=0xbf96cbc4) at kernel/qcoreapplication.cpp:731
#18 0xb6133f0c in sendSpontaneousEvent (this=0x8d711c8, pdev=0x8e7384c, rgn=..., offset=..., flags=68, sharedPainter=0x0, backingStore=0x8e75370) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#19 QWidgetPrivate::drawWidget (this=0x8d711c8, pdev=0x8e7384c, rgn=..., offset=..., flags=68, sharedPainter=0x0, backingStore=0x8e75370) at kernel/qwidget.cpp:5492
#20 0xb630f899 in QWidgetBackingStore::sync (this=0x8e75370) at painting/qbackingstore.cpp:1325
#21 0xb6129843 in QWidgetPrivate::syncBackingStore (this=0x8cf9408) at kernel/qwidget.cpp:1842
#22 0xb61377e5 in QWidget::event (this=0x8cec0e8, event=0xbf96d6e8) at kernel/qwidget.cpp:8552
#23 0xb6545a97 in QMainWindow::event (this=0x8cec0e8, event=0xbf96d6e8) at widgets/qmainwindow.cpp:1480
#24 0xb71ef2bc in KMainWindow::event (this=0x8cec0e8, ev=0xbf96d6e8) at ../../kdeui/widgets/kmainwindow.cpp:1100
#25 0xb722fb5f in KXmlGuiWindow::event (this=0x8cec0e8, ev=0xbf96d6e8) at ../../kdeui/xmlgui/kxmlguiwindow.cpp:126
#26 0xb60ded24 in QApplicationPrivate::notify_helper (this=0x8bb49b0, receiver=0x8cec0e8, e=0xbf96d6e8) at kernel/qapplication.cpp:4462
#27 0xb60e397b in QApplication::notify (this=0xbf96e894, receiver=0x8cec0e8, e=0xbf96d6e8) at kernel/qapplication.cpp:4427
#28 0xb71143ca in KApplication::notify (this=0xbf96e894, receiver=0x8cec0e8, event=0xbf96d6e8) at ../../kdeui/kernel/kapplication.cpp:311
#29 0xb6b840bb in QCoreApplication::notifyInternal (this=0xbf96e894, receiver=0x8cec0e8, event=0xbf96d6e8) at kernel/qcoreapplication.cpp:731
#30 0xb630b01b in sendEvent (this=0x8e75370, rect=..., widget=0x8d70e70, updateImmediately=true, invalidateBuffer=false) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 sendUpdateRequest (this=0x8e75370, rect=..., widget=0x8d70e70, updateImmediately=true, invalidateBuffer=false) at painting/qbackingstore.cpp:507
#32 QWidgetBackingStore::markDirty (this=0x8e75370, rect=..., widget=0x8d70e70, updateImmediately=true, invalidateBuffer=false) at painting/qbackingstore.cpp:695
#33 0xb6128fb6 in QWidget::repaint (this=0x8d70e70, rect=...) at kernel/qwidget.cpp:10322
#34 0xb61290cc in QWidget::repaint (this=0x8d70e70) at kernel/qwidget.cpp:10278
#35 0xb7628d14 in repaint (this=0x8d70e70, newLookAt=..., mode=Marble::Linear) at ../../../../marble/src/lib/MarbleWidget.cpp:272
#36 Marble::MarbleWidget::flyTo (this=0x8d70e70, newLookAt=..., mode=Marble::Linear) at ../../../../marble/src/lib/MarbleWidget.cpp:1316
#37 0xb7651c1f in Marble::MarbleWidgetDefaultInputHandler::Private::ZoomAt (this=0x8dc19f8, marbleWidget=0x8d70e70, pos=..., newDistance=575.76286887758329) at ../../../../marble/src/lib/MarbleWidgetInputHandler.cpp:271
#38 0xb7653402 in Marble::MarbleWidgetDefaultInputHandler::eventFilter (this=0x8d79058, o=0x8d70e70, e=0xbf96df24) at ../../../../marble/src/lib/MarbleWidgetInputHandler.cpp:738
#39 0xb6b8425a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x8bb49b0, receiver=0x8d70e70, event=0xbf96df24) at kernel/qcoreapplication.cpp:846
#40 0xb60ded00 in QApplicationPrivate::notify_helper (this=0x8bb49b0, receiver=0x8d70e70, e=0xbf96df24) at kernel/qapplication.cpp:4458
#41 0xb60e3ee0 in QApplication::notify (this=0xbf96e894, receiver=0x8d70e70, e=0xbf96df24) at kernel/qapplication.cpp:4078
#42 0xb71143ca in KApplication::notify (this=0xbf96e894, receiver=0x8d70e70, event=0xbf96df24) at ../../kdeui/kernel/kapplication.cpp:311
#43 0xb6b840bb in QCoreApplication::notifyInternal (this=0xbf96e894, receiver=0x8d70e70, event=0xbf96df24) at kernel/qcoreapplication.cpp:731
#44 0xb6154ced in sendSpontaneousEvent (this=0x8cec0e8, global_x=983, global_y=343, delta=120, buttons=..., modifiers=..., orient=Qt::Vertical) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#45 QETWidget::translateWheelEvent (this=0x8cec0e8, global_x=983, global_y=343, delta=120, buttons=..., modifiers=..., orient=Qt::Vertical) at kernel/qapplication_x11.cpp:4594
#46 0xb6168de8 in QETWidget::translateMouseEvent (this=0x8cec0e8, event=0xbf96e52c) at kernel/qapplication_x11.cpp:4371
#47 0xb6167746 in QApplication::x11ProcessEvent (this=0xbf96e894, event=0xbf96e52c) at kernel/qapplication_x11.cpp:3678
#48 0xb6192b84 in x11EventSourceDispatch (s=0x8bb4d20, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#49 0xb422faa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#50 0xb4230270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#51 0xb4230524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#52 0xb6bb153c in QEventDispatcherGlib::processEvents (this=0x8b80b60, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#53 0xb6192775 in QGuiEventDispatcherGlib::processEvents (this=0x8b80b60, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#54 0xb6b83289 in QEventLoop::processEvents (this=0xbf96e7f4, flags=...) at kernel/qeventloop.cpp:149
#55 0xb6b83522 in QEventLoop::exec (this=0xbf96e7f4, flags=...) at kernel/qeventloop.cpp:201
#56 0xb6b87ecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#57 0xb60dc8e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#58 0x08064055 in main (argc=) at ../../../marble/src/kdemain.cpp:351

Possible duplicates by query: bug 274526, bug 273273, bug 273047, bug 272083, bug 272082.

Reported using DrKonqi
Comment 1 Dennis Nienhüser 2011-06-08 15:17:15 UTC

*** This bug has been marked as a duplicate of bug 265599 ***