Bug 272082

Summary: crash during zoom
Product: [Applications] marble Reporter: csylvain <kb3cs>
Component: generalAssignee: marble-bugs
Status: RESOLVED DUPLICATE    
Severity: crash CC: nienhueser
Priority: NOR    
Version: unspecified   
Target Milestone: 1.1.0   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description csylvain 2011-04-30 19:39:59 UTC
Application: marble (1.0.0 (Stable Release))
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.1-1.2-desktop i686
Distribution: "openSUSE 11.4 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
rotated globe, zoomed a few times, centered crosshairs on WashingtonDC after it appeared on map, zoomed a couple more times

-- Backtrace:
Application: Marble Virtual Globe (marble), signal: Segmentation fault
[Current thread is 1 (Thread 0xb37d7710 (LWP 3166))]

Thread 5 (Thread 0xb1328b70 (LWP 3167)):
#0  0xb3f2822b in clock_gettime () from /lib/librt.so.1
#1  0xb68a6ae5 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6979726 in updateCurrentTime (this=0x81eb7cc, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0x81eb7cc, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb6977f6b in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb132811c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb697800d in timerSourcePrepare (source=0x81eb798, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb3e71a70 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0xb3e728e2 in ?? () from /lib/libglib-2.0.so.0
#9  0xb3e72fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0xb69787b7 in QEventDispatcherGlib::processEvents (this=0x81eb958, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb69492bd in QEventLoop::processEvents (this=0xb13282b0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb69494e9 in QEventLoop::exec (this=0xb13282b0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb684a7b9 in QThread::exec (this=0x823f0f8) at thread/qthread.cpp:490
#14 0xb692923d in QInotifyFileSystemWatcherEngine::run (this=0x823f0f8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb684d3aa in QThreadPrivate::start (arg=0x823f0f8) at thread/qthread_unix.cpp:285
#16 0xb57c9b05 in start_thread () from /lib/libpthread.so.0
#17 0xb5a8ad5e in clone () from /lib/libc.so.6

Thread 4 (Thread 0xb091cb70 (LWP 3168)):
#0  0xb57cbfcd in pthread_mutex_lock () from /lib/libpthread.so.0
#1  0xb5a98d04 in pthread_mutex_lock () from /lib/libc.so.6
#2  0xb3e72b0f in ?? () from /lib/libglib-2.0.so.0
#3  0xb3e72fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0xb69787b7 in QEventDispatcherGlib::processEvents (this=0x832aa28, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0xb69492bd in QEventLoop::processEvents (this=0xb091c2b0, flags=...) at kernel/qeventloop.cpp:149
#6  0xb69494e9 in QEventLoop::exec (this=0xb091c2b0, flags=...) at kernel/qeventloop.cpp:201
#7  0xb684a7b9 in QThread::exec (this=0x81f23c0) at thread/qthread.cpp:490
#8  0xb692923d in QInotifyFileSystemWatcherEngine::run (this=0x81f23c0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0xb684d3aa in QThreadPrivate::start (arg=0x81f23c0) at thread/qthread_unix.cpp:285
#10 0xb57c9b05 in start_thread () from /lib/libpthread.so.0
#11 0xb5a8ad5e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xb011bb70 (LWP 3169)):
#0  0xb57cd484 in __pthread_mutex_unlock_usercnt () from /lib/libpthread.so.0
#1  0xb5a98d44 in pthread_mutex_unlock () from /lib/libc.so.6
#2  0xb3e7217b in g_main_context_check () from /lib/libglib-2.0.so.0
#3  0xb3e72ac8 in ?? () from /lib/libglib-2.0.so.0
#4  0xb3e72fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0xb69787b7 in QEventDispatcherGlib::processEvents (this=0x832bdd8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0xb69492bd in QEventLoop::processEvents (this=0xb011b2b0, flags=...) at kernel/qeventloop.cpp:149
#7  0xb69494e9 in QEventLoop::exec (this=0xb011b2b0, flags=...) at kernel/qeventloop.cpp:201
#8  0xb684a7b9 in QThread::exec (this=0x820eea0) at thread/qthread.cpp:490
#9  0xb692923d in QInotifyFileSystemWatcherEngine::run (this=0x820eea0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb684d3aa in QThreadPrivate::start (arg=0x820eea0) at thread/qthread_unix.cpp:285
#11 0xb57c9b05 in start_thread () from /lib/libpthread.so.0
#12 0xb5a8ad5e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xae918b70 (LWP 3176)):
#0  0xb3f2822b in clock_gettime () from /lib/librt.so.1
#1  0xb68a6ae5 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6979726 in updateCurrentTime (this=0xac601554, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0xac601554, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb6977f6b in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xae9180ec) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb697800d in timerSourcePrepare (source=0xac601520, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb3e71a70 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0xb3e728e2 in ?? () from /lib/libglib-2.0.so.0
#9  0xb3e72fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0xb69787b7 in QEventDispatcherGlib::processEvents (this=0xac600b38, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb69492bd in QEventLoop::processEvents (this=0xae918280, flags=...) at kernel/qeventloop.cpp:149
#12 0xb69494e9 in QEventLoop::exec (this=0xae918280, flags=...) at kernel/qeventloop.cpp:201
#13 0xb684a7b9 in QThread::exec (this=0x812c500) at thread/qthread.cpp:490
#14 0xb7576090 in Marble::FileStorageWatcher::run (this=0x812c500) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/FileStorageWatcher.cpp:401
#15 0xb684d3aa in QThreadPrivate::start (arg=0x812c500) at thread/qthread_unix.cpp:285
#16 0xb57c9b05 in start_thread () from /lib/libpthread.so.0
#17 0xb5a8ad5e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb37d7710 (LWP 3166)):
[KCrash Handler]
#7  0xb756969b in Marble::AbstractScanlineTextureMapper::pixelValueF (this=0x8371fa0, lon=-1.4246864854920493, lat=0.75056569047400024, scanLine=0xac761008) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/AbstractScanlineTextureMapper.cpp:130
#8  0xb756a9ca in Marble::SphericalScanlineTextureMapper::mapTexture (this=0x8371fa0, viewParams=0x82275c4, texColorizer=0x8391598) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/SphericalScanlineTextureMapper.cpp:233
#9  0xb756acbd in Marble::SphericalScanlineTextureMapper::mapTexture (this=0x8371fa0, painter=0xbffd290c, viewParams=0x82275c4, dirtyRect=..., texColorizer=0x8391598) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/SphericalScanlineTextureMapper.cpp:51
#10 0xb755fe49 in Marble::TextureLayer::paintGlobe (this=0x82275e4, painter=0xbffd290c, viewParams=0x82275c4, dirtyRect=...) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/TextureLayer.cpp:161
#11 0xb74d2b1d in Marble::MarbleMapPrivate::paintGround (this=0x82275b8, painter=..., dirtyRect=...) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleMap.cpp:188
#12 0xb74c2456 in Marble::MarbleWidget::paintEvent (this=0x81ec7d0, evt=0xbffd2ec4) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleWidget.cpp:805
#13 0xb5ecd60a in QWidget::event (this=0x81ec7d0, event=0xbffd2ec4) at kernel/qwidget.cpp:8346
#14 0xb5e72414 in QApplicationPrivate::notify_helper (this=0x80e7b58, receiver=0x81ec7d0, e=0xbffd2ec4) at kernel/qapplication.cpp:4445
#15 0xb5e7b174 in QApplication::notify (this=0xbffd4d24, receiver=0x81ec7d0, e=0xbffd2ec4) at kernel/qapplication.cpp:4324
#16 0xb6e671f1 in KApplication::notify (this=0xbffd4d24, receiver=0x81ec7d0, event=0xbffd2ec4) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#17 0xb6949fde in QCoreApplication::notifyInternal (this=0xbffd4d24, receiver=0x81ec7d0, event=0xbffd2ec4) at kernel/qcoreapplication.cpp:732
#18 0xb5eca2a2 in sendSpontaneousEvent (this=0x8262bd8, pdev=0x8354674, rgn=..., offset=..., flags=68, sharedPainter=0x0, backingStore=0x8358600) at ../../src/corelib/kernel/qcoreapplication.h:218
#19 QWidgetPrivate::drawWidget (this=0x8262bd8, pdev=0x8354674, rgn=..., offset=..., flags=68, sharedPainter=0x0, backingStore=0x8358600) at kernel/qwidget.cpp:5433
#20 0xb60b8627 in QWidgetBackingStore::sync (this=0x8358600) at painting/qbackingstore.cpp:1325
#21 0xb5ebf03b in QWidgetPrivate::syncBackingStore (this=0x81c3900) at kernel/qwidget.cpp:1816
#22 0xb5ece0da in QWidget::event (this=0x818cde8, event=0xbffd39e4) at kernel/qwidget.cpp:8493
#23 0xb62f929c in QMainWindow::event (this=0x818cde8, event=0xbffd39e4) at widgets/qmainwindow.cpp:1478
#24 0xb6f2aae4 in KMainWindow::event (this=0x818cde8, ev=0xbffd39e4) at /usr/src/debug/kdelibs-4.6.0/kdeui/widgets/kmainwindow.cpp:1100
#25 0xb6f2ad82 in KXmlGuiWindow::event (this=0x818cde8, ev=0xbffd39e4) at /usr/src/debug/kdelibs-4.6.0/kdeui/xmlgui/kxmlguiwindow.cpp:126
#26 0xb5e72414 in QApplicationPrivate::notify_helper (this=0x80e7b58, receiver=0x818cde8, e=0xbffd39e4) at kernel/qapplication.cpp:4445
#27 0xb5e7b174 in QApplication::notify (this=0xbffd4d24, receiver=0x818cde8, e=0xbffd39e4) at kernel/qapplication.cpp:4324
#28 0xb6e671f1 in KApplication::notify (this=0xbffd4d24, receiver=0x818cde8, event=0xbffd39e4) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#29 0xb6949fde in QCoreApplication::notifyInternal (this=0xbffd4d24, receiver=0x818cde8, event=0xbffd39e4) at kernel/qcoreapplication.cpp:732
#30 0xb60b4be9 in sendEvent (this=0x8358600, rect=..., widget=0x81ec7d0, updateImmediately=true, invalidateBuffer=false) at ../../src/corelib/kernel/qcoreapplication.h:215
#31 sendUpdateRequest (this=0x8358600, rect=..., widget=0x81ec7d0, updateImmediately=true, invalidateBuffer=false) at painting/qbackingstore.cpp:507
#32 QWidgetBackingStore::markDirty (this=0x8358600, rect=..., widget=0x81ec7d0, updateImmediately=true, invalidateBuffer=false) at painting/qbackingstore.cpp:695
#33 0xb5ebe782 in QWidget::repaint (this=0x81ec7d0, rect=...) at kernel/qwidget.cpp:10250
#34 0xb5ebe8a1 in QWidget::repaint (this=0x81ec7d0) at kernel/qwidget.cpp:10206
#35 0xb74c5c6c in repaint (this=0x81ec7d0, newZoom=1608, mode=Marble::Automatic) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleWidget.cpp:272
#36 Marble::MarbleWidget::zoomView (this=0x81ec7d0, newZoom=1608, mode=Marble::Automatic) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleWidget.cpp:539
#37 0xb74c5d0a in Marble::MarbleWidget::zoomViewBy (this=0x81ec7d0, zoomStep=40, mode=Marble::Automatic) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleWidget.cpp:552
#38 0xb74c5d8d in Marble::MarbleWidget::zoomIn (this=0x81ec7d0, mode=Marble::Automatic) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleWidget.cpp:558
#39 0xb74c7bbc in Marble::MarbleWidget::qt_metacall (this=0x81ec7d0, _c=QMetaObject::InvokeMetaMethod, _id=20, _a=0xbffd3c2c) at /usr/src/debug/kdeedu-4.6.0/build/marble/src/lib/MarbleWidget.moc:310
#40 0xb69508cd in QMetaObject::metacall (object=0x81ec7d0, cl=QMetaObject::InvokeMetaMethod, idx=47, argv=0xbffd3c2c) at kernel/qmetaobject.cpp:237
#41 0xb6960a2c in QMetaObject::activate (sender=0x81cac70, m=0xb767b550, local_signal_index=1, argv=0x0) at kernel/qobject.cpp:3272
#42 0xb74d7675 in Marble::NavigationWidget::zoomIn (this=0x81cac70) at /usr/src/debug/kdeedu-4.6.0/build/marble/src/lib/NavigationWidget.moc:136
#43 0xb74d79a4 in Marble::NavigationWidget::qt_metacall (this=0x81cac70, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbffd3d88) at /usr/src/debug/kdeedu-4.6.0/build/marble/src/lib/NavigationWidget.moc:102
#44 0xb69508cd in QMetaObject::metacall (object=0x81cac70, cl=QMetaObject::InvokeMetaMethod, idx=28, argv=0xbffd3d88) at kernel/qmetaobject.cpp:237
#45 0xb6960a2c in QMetaObject::activate (sender=0x82012b8, m=0xb67db824, local_signal_index=2, argv=0xbffd3d88) at kernel/qobject.cpp:3272
#46 0xb65946cd in QAbstractButton::clicked (this=0x82012b8, _t1=false) at .moc/release-shared/moc_qabstractbutton.cpp:206
#47 0xb628f5ad in QAbstractButtonPrivate::emitClicked (this=0x8250b80) at widgets/qabstractbutton.cpp:546
#48 0xb6290e8b in QAbstractButtonPrivate::click (this=0x8250b80) at widgets/qabstractbutton.cpp:539
#49 0xb6291146 in QAbstractButton::mouseReleaseEvent (this=0x82012b8, e=0xbffd44b4) at widgets/qabstractbutton.cpp:1121
#50 0xb636854d in QToolButton::mouseReleaseEvent (this=0x82012b8, e=0xbffd44b4) at widgets/qtoolbutton.cpp:721
#51 0xb5ecd5b0 in QWidget::event (this=0x82012b8, event=0xbffd44b4) at kernel/qwidget.cpp:8200
#52 0xb6290160 in QAbstractButton::event (this=0x82012b8, e=0xbffd44b4) at widgets/qabstractbutton.cpp:1080
#53 0xb6369cbc in QToolButton::event (this=0x82012b8, event=0xbffd44b4) at widgets/qtoolbutton.cpp:1163
#54 0xb5e72414 in QApplicationPrivate::notify_helper (this=0x80e7b58, receiver=0x82012b8, e=0xbffd44b4) at kernel/qapplication.cpp:4445
#55 0xb5e7bc20 in QApplication::notify (this=0xbffd41cc, receiver=0x82012b8, e=0xbffd44b4) at kernel/qapplication.cpp:4006
#56 0xb6e671f1 in KApplication::notify (this=0xbffd4d24, receiver=0x82012b8, event=0xbffd44b4) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#57 0xb6949fde in QCoreApplication::notifyInternal (this=0xbffd4d24, receiver=0x82012b8, event=0xbffd44b4) at kernel/qcoreapplication.cpp:732
#58 0xb5e7345c in sendSpontaneousEvent (receiver=0x82012b8, event=0xbffd44b4, alienWidget=0x82012b8, nativeWidget=0x818cde8, buttonDown=0xb67e4c00, lastMouseReceiver=..., spontaneous=true) at ../../src/corelib/kernel/qcoreapplication.h:218
#59 QApplicationPrivate::sendMouseEvent (receiver=0x82012b8, event=0xbffd44b4, alienWidget=0x82012b8, nativeWidget=0x818cde8, buttonDown=0xb67e4c00, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3103
#60 0xb5eff030 in QETWidget::translateMouseEvent (this=0x818cde8, event=0xbffd49cc) at kernel/qapplication_x11.cpp:4438
#61 0xb5efe13e in QApplication::x11ProcessEvent (this=0xbffd4d24, event=0xbffd49cc) at kernel/qapplication_x11.cpp:3442
#62 0xb5f28960 in x11EventSourceDispatch (s=0x80e74c0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#63 0xb3e72509 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#64 0xb3e72d10 in ?? () from /lib/libglib-2.0.so.0
#65 0xb3e72fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#66 0xb697876b in QEventDispatcherGlib::processEvents (this=0x80d1298, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#67 0xb5f2855a in QGuiEventDispatcherGlib::processEvents (this=0x80d1298, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#68 0xb69492bd in QEventLoop::processEvents (this=0xbffd4c84, flags=...) at kernel/qeventloop.cpp:149
#69 0xb69494e9 in QEventLoop::exec (this=0xbffd4c84, flags=...) at kernel/qeventloop.cpp:201
#70 0xb694df90 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#71 0xb5e70104 in QApplication::exec () at kernel/qapplication.cpp:3719
#72 0x08065935 in main (argc=) at /usr/src/debug/kdeedu-4.6.0/marble/src/kdemain.cpp:351

This bug may be a duplicate of or related to bug 265599.

Possible duplicates by query: bug 269181.

Reported using DrKonqi
Comment 1 Dennis Nienhüser 2011-05-01 22:25:51 UTC
*** Bug 272083 has been marked as a duplicate of this bug. ***
Comment 2 Dennis Nienhüser 2011-05-01 22:26:10 UTC

*** This bug has been marked as a duplicate of bug 265599 ***