Bug 269314

Summary: KWin crash while reverting from full screen mode in live stream video in chrome
Product: [Plasma] kwin Reporter: Yash <yashdhingra9690>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: openSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description Yash 2011-03-24 15:48:01 UTC
Application: kwin (4.6.00 (4.6.0) "release 6")
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.1-1.2-desktop i686
Distribution: "openSUSE 11.4 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:

KWin crashed while reverting from full screen mode in flash video in chrome. I tried it 4 times and it crashed each time. Here is the URL of the page with the embedded flash live stream video.

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb25e7ac0 (LWP 12209))]

Thread 2 (Thread 0xadaadb70 (LWP 12236)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb6334105 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb7690aec in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xb6d27e17 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0xb6e3e1a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0xb6d27e5f in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0xb6e3e1a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0xb632fb05 in start_thread () from /lib/libpthread.so.0
#6  0xb7682d5e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb25e7ac0 (LWP 12209)):
[KCrash Handler]
#7  intel_region_buffer (intel=0x81e69e0, region=0x0, flag=2) at intel_regions.c:514
#8  0xaf63093a in intelClearWithBlit (ctx=0x81e69e0, mask=2) at intel_blit.c:262
#9  0xaf628f2d in intelClear (ctx=0x81e69e0, mask=2) at intel_clear.c:177
#10 0xaf7e9018 in _mesa_Clear (mask=<value optimized out>) at main/clear.c:241
#11 0xb77edebb in KWin::SceneOpenGL::paintBackground (this=0x8166d90, region=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene_opengl.cpp:921
#12 0xb77e432c in KWin::Scene::paintGenericScreen (this=0x8166d90, orig_mask=32) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene.cpp:188
#13 0xb77ee0d1 in KWin::SceneOpenGL::paintGenericScreen (this=0x8166d90, mask=32, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene_opengl.cpp:909
#14 0xb77e1110 in KWin::Scene::finalPaintScreen (this=0x8166d90, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene.cpp:178
#15 0xb7802c45 in KWin::EffectsHandlerImpl::paintScreen (this=0x8148ba8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:173
#16 0xae42b796 in KWin::StartupFeedbackEffect::paintScreen (this=0x817fa18, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/startupfeedback/startupfeedback.cpp:166
#17 0xb7802cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8148ba8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#18 0xb6b12d7a in KWin::Effect::paintScreen (this=0x818cb18, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#19 0xb7802cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8148ba8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#20 0xae3c9cb2 in KWin::LogoutEffect::paintScreen (this=0x852bed0, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/logout/logout.cpp:207
#21 0xb7802cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8148ba8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#22 0xae3e681f in KWin::ShadowEffect::paintScreen (this=0x81585f0, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/shadow/shadow.cpp:189
#23 0xb7802cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8148ba8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#24 0xae3ceda4 in KWin::PresentWindowsEffect::paintScreen (this=0x814b0e0, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/presentwindows/presentwindows.cpp:205
#25 0xb7802cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8148ba8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#26 0xb6b12d7a in KWin::Effect::paintScreen (this=0x81414a8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#27 0xb7802cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8148ba8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#28 0xb6b12d7a in KWin::Effect::paintScreen (this=0x81a4d90, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#29 0xb7802cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8148ba8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#30 0xb6b12d7a in KWin::Effect::paintScreen (this=0x8562258, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#31 0xb7802cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8148ba8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#32 0xb6b12d7a in KWin::Effect::paintScreen (this=0x81ac660, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#33 0xb7802cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8148ba8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#34 0xb6b12d7a in KWin::Effect::paintScreen (this=0x81884b8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#35 0xb7802cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8148ba8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#36 0xae3b3e64 in KWin::DesktopGridEffect::paintScreen (this=0x8198d80, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/desktopgrid/desktopgrid.cpp:155
#37 0xb7802cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8148ba8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#38 0xae3abdec in KWin::BoxSwitchEffect::paintScreen (this=0x819f498, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/boxswitch/boxswitch.cpp:143
#39 0xb7802cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8148ba8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#40 0xae40ac00 in KWin::CubeEffect::paintScreen (this=0x818de10, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/cube/cube.cpp:698
#41 0xb7802cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8148ba8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#42 0xb6b12d7a in KWin::Effect::paintScreen (this=0x81801d8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#43 0xb7802cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8148ba8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#44 0xb6b12d7a in KWin::Effect::paintScreen (this=0x85606c8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#45 0xb7802cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8148ba8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#46 0xae414697 in KWin::CubeSlideEffect::paintScreen (this=0x852bf18, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/cube/cubeslide.cpp:111
#47 0xb7802cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8148ba8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#48 0xb6b12d7a in KWin::Effect::paintScreen (this=0x8532c50, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#49 0xb7802cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8148ba8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#50 0xb6b12d7a in KWin::Effect::paintScreen (this=0x85506d8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#51 0xb7802cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8148ba8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#52 0xb6b12d7a in KWin::Effect::paintScreen (this=0x81ade90, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#53 0xb7802cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8148ba8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#54 0xb6b12d7a in KWin::Effect::paintScreen (this=0x8197128, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#55 0xb7802cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8148ba8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#56 0xb6b12d7a in KWin::Effect::paintScreen (this=0x845ddb8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#57 0xb7802cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8148ba8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#58 0xb77e3a09 in KWin::Scene::paintScreen (this=0x8166d90, mask=0xbfa2f290, region=0xbfa2f330) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene.cpp:137
#59 0xb77f917a in KWin::SceneOpenGL::paint (this=0x8166d90, damage=..., toplevels=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene_opengl.cpp:772
#60 0xb77de213 in KWin::Workspace::performCompositing (this=0x8134870) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/composite.cpp:448
#61 0xb64bc3f4 in QObject::event (this=0x8134870, e=0xbfa2f87c) at kernel/qobject.cpp:1175
#62 0xb59b4414 in QApplicationPrivate::notify_helper (this=0x80712d0, receiver=0x8134870, e=0xbfa2f87c) at kernel/qapplication.cpp:4445
#63 0xb59bd0c7 in QApplication::notify (this=0xbfa2fbb4, receiver=0x8134870, e=0xbfa2f87c) at kernel/qapplication.cpp:3845
#64 0xb72c91f1 in KApplication::notify (this=0xbfa2fbb4, receiver=0x8134870, event=0xbfa2f87c) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#65 0xb776a131 in KWin::Application::notify (this=0xbfa2fbb4, o=0x8134870, e=0xbfa2f87c) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/main.cpp:376
#66 0xb64a6fde in QCoreApplication::notifyInternal (this=0xbfa2fbb4, receiver=0x8134870, event=0xbfa2f87c) at kernel/qcoreapplication.cpp:732
#67 0xb64d8379 in sendEvent (this=0x8071a58) at kernel/qcoreapplication.h:215
#68 QTimerInfoList::activateTimers (this=0x8071a58) at kernel/qeventdispatcher_unix.cpp:618
#69 0xb64d8b1d in QEventDispatcherUNIX::processEvents (this=0x8054d88, flags=...) at kernel/qeventdispatcher_unix.cpp:937
#70 0xb5a6b64a in QEventDispatcherX11::processEvents (this=0x8054d88, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#71 0xb64a62bd in QEventLoop::processEvents (this=0xbfa2fae4, flags=...) at kernel/qeventloop.cpp:149
#72 0xb64a64e9 in QEventLoop::exec (this=0xbfa2fae4, flags=...) at kernel/qeventloop.cpp:201
#73 0xb64aaf90 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#74 0xb59b2104 in QApplication::exec () at kernel/qapplication.cpp:3719
#75 0xb776cbc7 in kdemain (argc=3, argv=0xbfa2fe24) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/main.cpp:542
#76 0x0804860b in main (argc=3, argv=0xbfa2fe24) at /usr/src/debug/kdebase-workspace-4.6.0/build/kwin/kwin_dummy.cpp:3

Possible duplicates by query: bug 268394, bug 267939, bug 266132, bug 264258, bug 257115.

Reported using DrKonqi
Comment 1 Yash 2011-03-24 15:52:28 UTC
Forgot to add the URL. Here it is :
http://www.espnstar.com/cwclive/
Comment 2 Thomas L├╝bking 2011-03-24 18:15:17 UTC
driver bug. see comment #28 in the dupe and pick a working mesa version (no gallium?) :-(

*** This bug has been marked as a duplicate of bug 252817 ***