Bug 222366

Summary: KMail crashed when replying to an email
Product: [Applications] kmail Reporter: Anze <ces>
Component: generalAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: andresbajotierra
Priority: NOR    
Version: 1.13.0   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:
Sentry Crash Report:

Description Anze 2010-01-12 13:06:53 UTC
Application: kmail (1.13.0)
KDE Platform Version: 4.3.90 (KDE 4.3.90 (KDE 4.4 RC1))
Qt Version: 4.6.0
Operating System: Linux 2.6.31-17-generic i686
Distribution: Ubuntu 9.10

-- Information about the crash:
It crashed while trying to send an email, not while typing it.

 -- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
[KCrash Handler]
#6  memmove () at ../sysdeps/i386/i686/memmove.S:100
#7  0x02606a70 in mem_copy (this=0x9f4a2d8) at /usr/include/bits/string3.h:59
#8  DwString::_copy (this=0x9f4a2d8) at ../../mimelib/dwstring.cpp:1228
#9  0x0103daa2 in DwString::c_str (aDwBodyPart=0x9f4a2b0, aPart=0x9cf628c, withBody=true) at ../../mimelib/mimelib/string.h:620
#10 DwMessageComponent::partId (aDwBodyPart=0x9f4a2b0, aPart=0x9cf628c, withBody=true) at ../../mimelib/mimelib/msgcmp.h:259
#11 KMMessage::bodyPart (aDwBodyPart=0x9f4a2b0, aPart=0x9cf628c, withBody=true) at ../../kmail/kmmessage.cpp:2677
#12 0x013a5125 in partNode::msgPart (this=0x9d97e90, url=..., w=0x948bb60) at ../../kmail/partNode.h:103
#13 statusBarMessage (this=0x9d97e90, url=..., w=0x948bb60) at ../../kmail/urlhandlermanager.cpp:688
#14 0x013a380c in KMail::URLHandlerManager::statusBarMessage (this=0x9dcf958, url=..., w=0x948bb60) at ../../kmail/urlhandlermanager.cpp:355
#15 0x011453aa in KMReaderWin::slotUrlOn (this=0x948bb60, aUrl=...) at ../../kmail/kmreaderwin.cpp:1965
#16 0x011474c3 in KMReaderWin::qt_metacall (this=0x948bb60, _c=QMetaObject::InvokeMetaMethod, _id=16, _a=0xbfe0c8b8) at ./kmreaderwin.moc:189
#17 0x085de11a in QMetaObject::metacall (object=0x948bb60, cl=43377152, idx=43, argv=0xbfe0c8b8) at kernel/qmetaobject.cpp:237
#18 0x085ec89b in QMetaObject::activate (sender=0x949c8d0, m=0x1d16348, local_signal_index=0, argv=0xbfe0c8b8) at kernel/qobject.cpp:3294
#19 0x017ff343 in KHTMLPart::onURL (this=0x949c8d0, _t1=...) at ./khtml_part.moc:406
#20 0x0182368d in KHTMLPart::overURL (this=0x949c8d0, url=..., target=...) at ../../khtml/khtml_part.cpp:3530
#21 0x01825be3 in KHTMLPart::handleMouseMoveEventOver (this=0x949c8d0, event=0xbfe0d530) at ../../khtml/khtml_part.cpp:6367
#22 0x0182609c in KHTMLPart::khtmlMouseMoveEvent (this=0x949c8d0, event=0xbfe0d530) at ../../khtml/khtml_part.cpp:6415
#23 0x017ffd8f in KHTMLPart::customEvent (this=0x949c8d0, event=0xbfe0d530) at ../../khtml/khtml_part.cpp:5962
#24 0x085e990c in QObject::event (this=0x949c8d0, e=0x9f4a2d8) at kernel/qobject.cpp:1291
#25 0x0384919c in QApplicationPrivate::notify_helper (this=0x911ac88, receiver=0x949c8d0, e=0xbfe0d530) at kernel/qapplication.cpp:4242
#26 0x0384fdf7 in QApplication::notify (this=0xbfe0e70c, receiver=0x949c8d0, e=0xbfe0d530) at kernel/qapplication.cpp:3661
#27 0x0041067a in KApplication::notify (this=0xbfe0e70c, receiver=0x949c8d0, event=0xbfe0d530) at ../../kdeui/kernel/kapplication.cpp:302
#28 0x085d8eab in QCoreApplication::notifyInternal (this=0xbfe0e70c, receiver=0x949c8d0, event=0xbfe0d530) at kernel/qcoreapplication.cpp:704
#29 0x017f7c81 in QCoreApplication::sendEvent (this=0x94cf1b0, _mouse=0xbfe0ddb0) at /usr/include/qt4/QtCore/qcoreapplication.h:215
#30 KHTMLView::mouseMoveEvent (this=0x94cf1b0, _mouse=0xbfe0ddb0) at ../../khtml/khtmlview.cpp:1541
#31 0x038a5fd6 in QWidget::event (this=0x94cf1b0, event=0xbfe0ddb0) at kernel/qwidget.cpp:7959
#32 0x03c9f433 in QFrame::event (this=0x94cf1b0, e=0xbfe0ddb0) at widgets/qframe.cpp:557
#33 0x017f37ac in KHTMLView::widgetEvent (this=0x94cf1b0, e=0x8a9ec2d0) at ../../khtml/khtmlview.cpp:2338
#34 0x017f3a95 in KHTMLView::eventFilter (this=0x94cf1b0, o=0x94dac30, e=0xbfe0ddb0) at ../../khtml/khtmlview.cpp:2191
#35 0x085d814a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x911ac88, receiver=0x94dac30, event=0xbfe0ddb0) at kernel/qcoreapplication.cpp:819
#36 0x03849179 in QApplicationPrivate::notify_helper (this=0x911ac88, receiver=0x94dac30, e=0xbfe0ddb0) at kernel/qapplication.cpp:4238
#37 0x0385076b in QApplication::notify (this=0xbfe0e70c, receiver=0x94dac30, e=0xbfe0ddb0) at kernel/qapplication.cpp:3822
#38 0x0041067a in KApplication::notify (this=0xbfe0e70c, receiver=0x94dac30, event=0xbfe0ddb0) at ../../kdeui/kernel/kapplication.cpp:302
#39 0x085d8eab in QCoreApplication::notifyInternal (this=0xbfe0e70c, receiver=0x94dac30, event=0xbfe0ddb0) at kernel/qcoreapplication.cpp:704
#40 0x0384f71f in QCoreApplication::sendEvent (receiver=0x94dac30, event=0xbfe0ddb0, alienWidget=0x94dac30, nativeWidget=0x93c00a8, buttonDown=0x4184060, lastMouseReceiver=..., spontaneous=true)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#41 QApplicationPrivate::sendMouseEvent (receiver=0x94dac30, event=0xbfe0ddb0, alienWidget=0x94dac30, nativeWidget=0x93c00a8, buttonDown=0x4184060, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:2956
#42 0x038d8d18 in QETWidget::translateMouseEvent (this=0x93c00a8, event=0xbfe0e2cc) at kernel/qapplication_x11.cpp:4368
#43 0x038d81f1 in QApplication::x11ProcessEvent (this=0xbfe0e70c, event=0xbfe0e2cc) at kernel/qapplication_x11.cpp:3379
#44 0x0390704a in x11EventSourceDispatch (s=0x9125a80, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#45 0x08ffce88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#46 0x09000730 in ?? () from /lib/libglib-2.0.so.0
#47 0x09000863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#48 0x08604bd5 in QEventDispatcherGlib::processEvents (this=0x9161510, flags=...) at kernel/qeventdispatcher_glib.cpp:407
#49 0x03906b75 in QGuiEventDispatcherGlib::processEvents (this=0x9161510, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#50 0x085d74c9 in QEventLoop::processEvents (this=0xbfe0e5c4, flags=) at kernel/qeventloop.cpp:149
#51 0x085d791a in QEventLoop::exec (this=0xbfe0e5c4, flags=...) at kernel/qeventloop.cpp:201
#52 0x085dbb0f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#53 0x03849237 in QApplication::exec () at kernel/qapplication.cpp:3570
#54 0x0804abae in main (argc=1, argv=0xbfe0e8d4) at ../../kmail/main.cpp:156

Possible duplicates by query: bug 214010.

Reported using DrKonqi
Comment 1 Dario Andres 2010-01-12 19:27:44 UTC
s bug 211461 and bug 209084, this is bug 128357. Thanks

*** This bug has been marked as a duplicate of bug 128357 ***