Bug 214010 - kmail chrashed while checking for new mail in new tab
Summary: kmail chrashed while checking for new mail in new tab
Status: RESOLVED DUPLICATE of bug 136145
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-10 18:13 UTC by Filipe
Modified: 2009-11-12 10:06 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Filipe 2009-11-10 18:13:14 UTC
Application that crashed: kmail
Version of the application: 1.12.2
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
Every time I open a tab in kmail it blocks all remaining tabs. Instead of let me check an existent tab of email the new tab overlaps everything. Normally the process of verifying email on a IMAP (Gmail) folder is very very slow. Now it crashed badly, maybe the third time.

 -- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
[KCrash Handler]
#6  0x006eeaad in memmove () from /lib/tls/i686/cmov/libc.so.6
#7  0x031059e0 in mem_copy (this=0x224b48) at /usr/include/bits/string3.h:59
#8  DwString::_copy (this=0x224b48) at ../../mimelib/dwstring.cpp:1228
#9  0x00ef07bc in DwString::c_str (this=0x99116d8, msg=0xa806c88, partSpecifier=...) at ../../mimelib/mimelib/string.h:620
#10 DwMessageComponent::partId (this=0x99116d8, msg=0xa806c88, partSpecifier=...) at ../../mimelib/mimelib/msgcmp.h:259
#11 KMLoadPartsCommand::slotPartRetrieved (this=0x99116d8, msg=0xa806c88, partSpecifier=...) at ../../kmail/kmcommands.cpp:2762
#12 0x00ef239b in KMLoadPartsCommand::qt_metacall (this=0x99116d8, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0xbfd1af34) at ./kmcommands.moc:1858
#13 0x072a4263 in QMetaObject::activate (sender=0x9e0d4e8, from_signal_index=5, to_signal_index=5, argv=0xbfd1af34) at kernel/qobject.cpp:3113
#14 0x072a4ec2 in QMetaObject::activate (sender=0x9e0d4e8, m=0x13224d0, local_signal_index=1, argv=0xbfd1af34) at kernel/qobject.cpp:3187
#15 0x00f473d9 in KMail::FolderJob::messageUpdated (this=0x9e0d4e8, _t1=0xa806c88, _t2=...) at ./folderjob.moc:106
#16 0x00f53ef6 in KMail::ImapJob::slotGetMessageResult (this=0x9e0d4e8, job=0xa878a18) at ../../kmail/imapjob.cpp:476
#17 0x00f5860f in KMail::ImapJob::qt_metacall (this=0x9e0d4e8, _c=QMetaObject::InvokeMetaMethod, _id=12, _a=0xbfd1b0d8) at ./imapjob.moc:82
#18 0x072a4263 in QMetaObject::activate (sender=0xa878a18, from_signal_index=7, to_signal_index=7, argv=0xbfd1b0d8) at kernel/qobject.cpp:3113
#19 0x072a4ec2 in QMetaObject::activate (sender=0xa878a18, m=0x671d68, local_signal_index=3, argv=0xbfd1b0d8) at kernel/qobject.cpp:3187
#20 0x0050bfe3 in KJob::result (this=0xa878a18, _t1=0xa878a18) at ./kjob.moc:188
#21 0x0050c469 in KJob::emitResult (this=0xa878a18) at ../../kdecore/jobs/kjob.cpp:304
#22 0x01632660 in KIO::SimpleJob::slotFinished (this=0xa878a18) at ../../kio/kio/job.cpp:477
#23 0x01632b7a in KIO::TransferJob::slotFinished (this=0xa878a18) at ../../kio/kio/job.cpp:948
#24 0x016308a3 in KIO::TransferJob::qt_metacall (this=0xa878a18, _c=QMetaObject::InvokeMetaMethod, _id=47, _a=0xbfd1b33c) at ./jobclasses.moc:343
#25 0x072a4263 in QMetaObject::activate (sender=0x9e3b328, from_signal_index=8, to_signal_index=8, argv=0x0) at kernel/qobject.cpp:3113
#26 0x072a4ec2 in QMetaObject::activate (sender=0x9e3b328, m=0x17e4f64, local_signal_index=4, argv=0x0) at kernel/qobject.cpp:3187
#27 0x016fc557 in KIO::SlaveInterface::finished (this=0x9e3b328) at ./slaveinterface.moc:165
#28 0x0170044d in KIO::SlaveInterface::dispatch (this=0x9e3b328, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:175
#29 0x016fca13 in KIO::SlaveInterface::dispatch (this=0x9e3b328) at ../../kio/kio/slaveinterface.cpp:91
#30 0x016eeaea in KIO::Slave::gotInput (this=0x9e3b328) at ../../kio/kio/slave.cpp:322
#31 0x016f0ee3 in KIO::Slave::qt_metacall (this=0x9e3b328, _c=QMetaObject::InvokeMetaMethod, _id=30, _a=0xbfd1b61c) at ./slave.moc:76
#32 0x072a4263 in QMetaObject::activate (sender=0x9e42e10, from_signal_index=4, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3113
#33 0x072a4ec2 in QMetaObject::activate (sender=0x9e42e10, m=0x17e18a0, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3187
#34 0x015f8f97 in KIO::Connection::readyRead (this=0x9e42e10) at ./connection.moc:86
#35 0x015fad5e in KIO::ConnectionPrivate::dequeue (this=0x9f240c8) at ../../kio/kio/connection.cpp:82
#36 0x015fae8e in KIO::Connection::qt_metacall (this=0x9e42e10, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xa818410) at ./connection.moc:73
#37 0x0729cf0b in QMetaCallEvent::placeMetaCall (this=0xa8325c8, object=0x9e42e10) at kernel/qobject.cpp:477
#38 0x0729e5fe in QObject::event (this=0x9e42e10, e=0xa8325c8) at kernel/qobject.cpp:1111
#39 0x04ffdf54 in QApplicationPrivate::notify_helper (this=0x973aa60, receiver=0x9e42e10, e=0xa8325c8) at kernel/qapplication.cpp:4056
#40 0x0500567c in QApplication::notify (this=0xbfd1bf50, receiver=0x9e42e10, e=0xa8325c8) at kernel/qapplication.cpp:3603
#41 0x009c5bfa in KApplication::notify (this=0xbfd1bf50, receiver=0x9e42e10, event=0xa8325c8) at ../../kdeui/kernel/kapplication.cpp:302
#42 0x0728e6cb in QCoreApplication::notifyInternal (this=0xbfd1bf50, receiver=0x9e42e10, event=0xa8325c8) at kernel/qcoreapplication.cpp:610
#43 0x0728f2b2 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x96cefa8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#44 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x96cefa8) at kernel/qcoreapplication.cpp:1247
#45 0x0728f47d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#46 0x072b93ff in QCoreApplication::sendPostedEvents (s=0x96f7c10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#47 postEventSourceDispatch (s=0x96f7c10) at kernel/qeventdispatcher_glib.cpp:210
#48 0x07bbae78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#49 0x07bbe720 in ?? () from /lib/libglib-2.0.so.0
#50 0x07bbe853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#51 0x072b902c in QEventDispatcherGlib::processEvents (this=0x96cf180, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#52 0x0509ebe5 in QGuiEventDispatcherGlib::processEvents (this=0x96cf180, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#53 0x0728cc79 in QEventLoop::processEvents (this=0xbfd1be14, flags=) at kernel/qeventloop.cpp:149
#54 0x0728d0ca in QEventLoop::exec (this=0xbfd1be14, flags=...) at kernel/qeventloop.cpp:201
#55 0x0728f53f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#56 0x04ffddd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#57 0x0804a702 in main (argc=3, argv=0xbfd1c104) at ../../kmail/main.cpp:146

Reported using DrKonqi
Comment 1 Filipe 2009-11-10 18:47:50 UTC
After read the backtrace I noticed some MIME lines. I request an attachment to open right before the tab :P 
It was a picture from a signature, and it did not open.
Comment 2 Christophe Marin 2009-11-12 10:06:24 UTC
Thanks. Merging with 136145.

*** This bug has been marked as a duplicate of bug 136145 ***