Bug 209213

Summary: No reason given why some desktop effects cannot be activated
Product: [Plasma] kwin Reporter: Lubos Lunak <l.lunak>
Component: compositingAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED FIXED    
Severity: wishlist CC: gabextreme, KaiUweBroulik2, kde-2011.08
Priority: NOR Flags: mgraesslin: ReviewRequest+
Version: unspecified   
Target Milestone: 4.9   
Platform: OpenSUSE   
OS: Unspecified   
URL: https://git.reviewboard.kde.org/r/104847/
Latest Commit: Version Fixed In: 4.9.0
Attachments: Corrupted notebook screen (strip at the right)

Description Lubos Lunak 2009-10-02 14:59:06 UTC
Version:            (using KDE 4.3.1)
Installed from:    SuSE RPMs

From https://bugzilla.novell.com/show_bug.cgi?id=540670:

If I want turn on some effect, then after click on apply it writes to k-notifier that 
"Following effects could not be activated:
Sharpen
Explosion"
There is no information why it cannot be activated (maybe another effect prevent this effects).
Comment 1 Christoph Feck 2010-01-25 20:28:09 UTC
*** Bug 224214 has been marked as a duplicate of this bug. ***
Comment 2 Martin Flöser 2010-10-03 11:01:01 UTC
*** Bug 210141 has been marked as a duplicate of this bug. ***
Comment 3 Mari Donkers 2010-12-06 13:41:55 UTC
Created attachment 54205 [details]
Corrupted notebook screen (strip at the right)

Photograph of my laptop screen that has a strip at the right with content of
external screen.

Although the photograph is a bit out of focus the vertical strip at the right
of the clock, cpu temperature and cpu load widgets is clearly visible.
Comment 4 Mari Donkers 2010-12-06 13:47:28 UTC
Comment on attachment 54205 [details]
Corrupted notebook screen (strip at the right)

Sorry, wrong bug; will attempt to delete the attachment
Comment 5 Martin Flöser 2012-04-06 20:56:28 UTC
*** Bug 263323 has been marked as a duplicate of this bug. ***
Comment 6 Martin Flöser 2012-04-07 06:42:13 UTC
Idea on how to implement:
add
RequiresOpenGL=true
RequiresARBShaders=true
RequiresGLSL=true
to the service files.

Whenever the KCM notices that an effect fails it queries the service file and adds one of the following messages in a KMessageWidget:
* "Effect Foo requires OpenGL Compositing."
* "Effect Foo requires OpenGL Shaders."
* "Effect Foo requires OpenGL 2 Compositing."
* "Effect Foo could not be activated due to unknown reason"

As we have already the information when an effect could not be activated, I'll try to target 4.9
Comment 7 Martin Flöser 2012-05-15 16:04:18 UTC
Git commit 5978810cd7ab481ceb2a716bee69af5013126eb8 by Martin Gräßlin.
Committed on 04/05/2012 at 11:13.
Pushed by graesslin into branch 'master'.

Show detailed information why an effect cannot be loaded

Effects can specify their minimum requirements in their
desktop file:
* OpenGL
* OpenGL 2 (GLSL required)
* Shaders (either ARB or OpenGL 2)

The configuration module uses this information in combination
with which backend KWin is currently using. So if e.g. OpenGL
is used and an effect requires OpenGL 2 a detailed error
message can be showed that OpenGL 2 is required.
FIXED-IN: 4.9.0
REVIEW: 104847

M  +22   -0    kwin/composite.cpp
M  +2    -1    kwin/effects/blur/blur.desktop
M  +1    -0    kwin/effects/coverswitch/coverswitch.desktop
M  +1    -0    kwin/effects/cube/cube.desktop
M  +1    -0    kwin/effects/cube/cubeslide.desktop
M  +1    -0    kwin/effects/explosion/explosion.desktop
M  +1    -0    kwin/effects/flipswitch/flipswitch.desktop
M  +1    -0    kwin/effects/glide/glide.desktop
M  +1    -0    kwin/effects/invert/invert.desktop
M  +9    -0    kwin/effects/kwineffect.desktop
M  +1    -0    kwin/effects/lookingglass/lookingglass.desktop
M  +1    -0    kwin/effects/magiclamp/magiclamp.desktop
M  +1    -0    kwin/effects/sheet/sheet.desktop
M  +1    -0    kwin/effects/startupfeedback/startupfeedback.desktop
M  +1    -0    kwin/effects/wobblywindows/wobblywindows.desktop
M  +108  -18   kwin/kcmkwin/kwincompositing/main.cpp
M  +2    -0    kwin/kcmkwin/kwincompositing/main.h
M  +20   -4    kwin/kcmkwin/kwincompositing/main.ui
M  +10   -0    kwin/org.kde.KWin.xml
M  +9    -0    kwin/workspace.h

http://commits.kde.org/kde-workspace/5978810cd7ab481ceb2a716bee69af5013126eb8