Bug 210141 - Inform user why cylinder/sphere don't work
Summary: Inform user why cylinder/sphere don't work
Status: RESOLVED DUPLICATE of bug 209213
Alias: None
Product: kwin
Classification: Plasma
Component: compositing (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-11 02:24 UTC by Gabe A
Modified: 2010-10-03 11:01 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gabe A 2009-10-11 02:24:35 UTC
Version:            (using KDE 4.3.2)
OS:                Linux
Installed from:    Ubuntu Packages

My setup: Kubuntu 9.04 KDE 4.3.2 packages, blank desktop, latest 2.9 Intel drivers and drm, latest kernel 2.6.31.3, the works. Gfx card: GMA4500, with native opengl 2.0 support, full shaders, etc. Settings for the desktop cube plugin are the defaults, but any settings don't work.  

How to reproduce: set a toggle to the sphere or cylinder as a key combo or as an "edge effect" -- nothing happens at all when I try these combos/edges. The effect won't start up, and I get no error, no message, no warning, no explanation. Normal cube works fine in all its glory, with reflection, 3D windows etc, even while playing videos, at 60 fps. In other words, ridiculously fast. 

Expected behavior: Either for the plugin to work or explain why it can't.
Comment 1 Martin Flöser 2009-10-11 10:58:08 UTC
The cylinder and sphere effect require OpenGL Shader support. Unfortunately the Intel graphics driver do not (yet) support the OpenGL Shading Language (your setup sounds strange - Intel in 9.04 does not support shaders). When you start kwin from a console there should be some debug output telling the reason why it doesn't work. It should say "Sorry shaders are not available - cannot activate Cylinder".

I can't see a way how I could provide information to the user. Showing a notification is probably not the right thing and giving the information that it cannot be activated because shaders are not supported, does not help any user. If you have an idea: please let us know.
Comment 2 Martin Flöser 2010-10-03 11:01:01 UTC

*** This bug has been marked as a duplicate of bug 209213 ***