Bug 188533

Summary: Selection is deleted if a window is selected/pops up/maximized/focused
Product: [Frameworks and Libraries] kdelibs Reporter: Salim <salim>
Component: generalAssignee: kdelibs bugs <kdelibs-bugs>
Status: RESOLVED UPSTREAM    
Severity: normal CC: andresbajotierra, BatchDrake, homoludens1000, kde-bugs, peebhat, PVince81, rrchan
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: openSUSE   
OS: Linux   
Latest Commit: Version Fixed In:
Sentry Crash Report:

Description Salim 2009-03-31 12:40:06 UTC
Version:            (using KDE 4.2.1)
OS:                Linux
Installed from:    SuSE RPMs

When in an text-box/editbox text is written and selected, then if the window with that text-box element with selected text pops up/is maximized/focused etc. then the selection is removed. This is very very annoying and happens in every kde4 application for me.
I have KDE 4.2.1 "Release 109" for openSUSE 11.1 installed from the packages.

How to reproduce it: in kAddressbook, double-click on an already existing entry/contact to edit the contact details, the edit-box/text-box where you can change the contact's name gets deleted upon popup of the window. You have to rewrite the name...
OR: open dolphin, on the address bar select the address or any text in the address bar, minimize that dolphin window and then select it/bring it to foreground again. You will find the selection deleted.
OR: Press F2 on a file to rename it, the name of the file (e.g. "file_name" of "file_name.xyz") gets deleted and you can only see the file extension with dot :-(
This is very annoying.
Comment 1 Dario Andres 2009-04-01 15:47:17 UTC
Really strange :(
I can't reproduce here (4.3trunk)
I will try to fetch more opinions on this.
Thanks
Comment 2 Torben Hansen 2009-04-06 23:22:02 UTC
I can confirm this bug!
Maybe it is a openSuSE problem or even a openSuSE/Qt4 problem.
I see the problem in all KDE4 applications but also in QtOctave, but not in gimp.
Running openSuSE 11.1
KDE 4.2.2 Release 111
AMD x86_64
It has been in all KDE4  versions (4.0.?, 4.1.?, 4.2.1 and now 4.2.2) I have tested, all from openSuSE
Comment 3 Dario Andres 2009-04-06 23:26:52 UTC
If it's happening on QtOctave, it would be a Qt bug.
Can you compare your own hardware ? It's strange that you are the only one I ever heard about this issue. (and if it's that old to be since KDE4). May be it's something related to your hardware combination (+ using OpenSUSE)
Thanks
Comment 4 Torben Hansen 2009-04-06 23:44:36 UTC
Just deleted scim and skim and the problem disapeared.
Salim, are you using skim/scim?
Comment 5 Salim 2009-04-06 23:58:34 UTC
(In reply to comment #4)
> Just deleted scim and skim and the problem disapeared.
> Salim, are you using skim/scim?
Yes, I'm using scim.
This could be a reason for the bug. But I really do need scim and can't uninstall it. I think scim is a great and important part of Linux. I hope this bug gets solved soon. (will this bug be marked as confirmed now?)
Comment 6 Dario Andres 2009-04-07 00:26:13 UTC
SCIM is not part of KDE, but SKIM it is. Also there is a Qt-only interface to SCIM (afaik) Currently a replacement for SKIM is being created (as a Plasma widget) for a future KDE release.
@Salim: do you also experience this problem on Qt-only apps ? If you do, we may need to report this upstream on Trolltech's bugtracker.

Thanks
Comment 7 Torben Hansen 2009-04-08 15:35:47 UTC
This issue has been solved by phuang for the fedora project.
https://admin.fedoraproject.org/updates/scim-bridge-0.4.15-8.fc9

I'll send a bug-report to opensuse and requist them to add the patch.

I the meanwhile I've build a new rpm for opensuse 11.1 (src and x86_64). Contact be by e-mail if you want it.
Comment 8 Torben Hansen 2009-04-08 15:58:38 UTC
This repository
http://download.opensuse.org/repositories/home:/hujq/openSUSE_11.1/
is said to hold a fixed rpm.

The bug was already submitted at opensuse Bug #463177
Comment 9 Dario Andres 2009-04-08 19:47:03 UTC
@Torben Hansen: thanks for the information
Marking as UPSTREAM
Comment 10 Salim 2009-04-08 20:09:40 UTC
It works now, and it's great! Thank you!
Comment 11 Dario Andres 2009-04-10 04:14:54 UTC
*** Bug 189215 has been marked as a duplicate of this bug. ***
Comment 12 Dario Andres 2009-05-18 14:13:03 UTC
*** Bug 186670 has been marked as a duplicate of this bug. ***
Comment 13 Vincent Petry 2009-07-26 06:18:36 UTC
*** Bug 201457 has been marked as a duplicate of this bug. ***
Comment 14 rrchan 2009-08-22 01:08:47 UTC
*** Bug 204691 has been marked as a duplicate of this bug. ***
Comment 15 Dario Andres 2009-10-01 14:19:00 UTC
*** Bug 209023 has been marked as a duplicate of this bug. ***