Bug 186670 - Renaming files deletes existing text
Summary: Renaming files deletes existing text
Status: RESOLVED DUPLICATE of bug 188533
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: SVN
Platform: openSUSE Linux
: NOR normal
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-09 14:24 UTC by homoludens
Modified: 2009-05-18 14:13 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description homoludens 2009-03-09 14:24:52 UTC
Version:            (using KDE 4.2.1)
OS:                Linux
Installed from:    SuSE RPMs

Renaming files in Dolphin deletes the existing text. This is more problematic when renaming inline (when using the rename dialog, one can still look at the existing text in the Dolphin window in the background).

It would be useful to have the existing text copied into the text field and highlighted (which would make it possible to edit it if necessary).

(This might not be a bug but by design, in which case this report should probably be filed under Wishes ... )
Comment 1 Peter Penz 2009-03-09 14:29:41 UTC
Thanks for the report, but it's unclear for me what you mean with "deletes the existing text": The current text is only marked, not deleted. Do I miss here something?
Comment 2 homoludens 2009-03-09 14:38:33 UTC
Hm, on my installation the text is deleted.

Yes, being marked only would be the desirable setup.
Comment 3 Rahman Duran 2009-03-22 18:02:36 UTC
Nope, both 4.3 trunk and 4.2.1 opensuse 11.1 install, work fine as expected. The original file name remains and gets selected (except extension) both for inline and dialog renaming. Maybe something wrong with your installation?
Comment 4 Geoff Cutter 2009-04-12 02:48:34 UTC
Text is removed for me too and it's the same in Konqueror. Annoying if you only need to change a few characters.
Comment 5 Geoff Cutter 2009-04-19 07:52:54 UTC
Text removed also in Beesoft Commander, ver. 4.1.0. 
Version 4.2.2 (KDE 4.2.2) "release 112"
openSUSE 11.1 (i586)
Comment 6 Geoff Cutter 2009-04-19 13:22:08 UTC
Suggest New Name (Konqueror) when moving a file to where a copy already exists does not suggest. It's blank instead. Might be the same problem.
Comment 7 Geoff Cutter 2009-04-22 16:05:16 UTC
Workaround: Rename via the properties of the file.
Comment 8 homoludens 2009-04-23 01:28:41 UTC
Geoff, thanks for the workaround.

Are you using SCIM/SKIM, by the way? Some people have suggested that it is the source of the problem, so I'm curious about your system setup.
Comment 9 Geoff Cutter 2009-04-23 02:35:11 UTC
Yes, I see SKIM.
Comment 10 Geoff Cutter 2009-04-23 02:36:29 UTC
SCIM  :)
Comment 11 Geoff Cutter 2009-04-24 05:44:54 UTC
Thanks for the clue.

SCIM (Smart Chinese/Common Input....
SCIM (KDE Integration for SCIM)

both removed (ignoring dependency messages many times) since I don't need it.

Restarted the computer and renaming is now normal.
Comment 12 homoludens 2009-04-24 06:08:53 UTC
Thanks for the comment, you confirm that SCIM/SKIM is in fact the culprit, that is, somehow in connection with KDE applications (since all GTK applications work normally).

This bug should probably be categorized differently, not as a Dolphin bug.
Comment 13 Peter Penz 2009-04-30 11:45:05 UTC
Hmm, I'm unsure how to proceed with this bug report. The root cause seems to be out of scope of Dolphin, but I don't know whether SCIM/SKIM must be fixed or if there is an issue in kdelibs. I've changed the product to kdelibs with the hope that someone is able to categorize this issue.
Comment 14 homoludens 2009-05-04 10:17:11 UTC
Thanks for the change, Peter. I don't know either what problem lies as the root of this. SCIM seems to be a likely candidate, but I've been running the same versions of SCIM/SKIM in KDE 3.5 without problems, so obviously there is some connection to KDE 4.

I've filed a bug report at the SCIM bug tracker (see http://sourceforge.net/tracker/?func=detail&aid=2780129&group_id=108454&atid=650539), perhaps we can get some help in narrowing the problem down.
Comment 15 Dario Andres 2009-05-10 17:54:20 UTC
There is also a bug report (related to SCIM/SKIM): text selected is deleted when the windows lost focus (ex. you select another window): bug 188533
AFAIK a new input method selector is being developed: http://www.nabble.com/-RFC--kimpanel-applet-in-kdereview-td23335635.html
Comment 16 Dario Andres 2009-05-10 18:03:31 UTC
I wonder which is duplicate of which as this report has the reference to the upstream report...
Comment 17 homoludens 2009-05-18 08:28:26 UTC
Dario, thanks for the link to bug 188533.

I've installed the revised scim-bridge package from the repository mentioned in the thread (http://download.opensuse.org/repositories/home:/hujq/openSUSE_11.1/, which installs scim-bridge (/-gtk, /-qt) version 0.4.15-13.3-i586; the most recent version in the openSUSE 11.1 repositories is 0.4.15-6.1-i586), and now renaming file names works fine on my system.
Comment 18 Dario Andres 2009-05-18 14:13:03 UTC
Marking as duplicate of bug 188533. Thanks

*** This bug has been marked as a duplicate of bug 188533 ***