Bug 201457 - Rename file dialog edit box empty instead of using the initial file name
Summary: Rename file dialog edit box empty instead of using the initial file name
Status: RESOLVED DUPLICATE of bug 188533
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: openSUSE Linux
: NOR normal
Target Milestone: ---
Assignee: Peter Penz
Depends on:
Reported: 2009-07-25 14:49 UTC by Vincent Petry
Modified: 2009-07-26 06:18 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Note You need to log in before you can comment on or make changes to this bug.
Description Vincent Petry 2009-07-25 14:49:01 UTC
Version:           dolphin-4.2.98-98.2 (using KDE 4.2.98)
OS:                Linux
Installed from:    SuSE RPMs

Steps to reproduce:
1. Open either dolphin or konqueror
2. Go into any folder containing files or directories that you have permissions to rename
3. Select one file
4. Press the F2 key or select "Rename" from the context menu
5. Look at the rename dialog

Expected result:
The rename dialog edit box contains the original file name, so I can edit it.

Actual result:
The rename dialog edit box is empty, so I have to re-type the name if I only wanted to change it slightly.

More information:
For some known file types like "png" and "jpg", the dialog only contains the extension with the dot, like ".png" or ".jpg". For unknown file types, the box is empty.

It also occurs when trying to rename a photo file in digikam. The only difference is that in digikam if I open the rename dialog twice in a row, the first time it's empty, the second time it contains the file name.

So the problem might be related to the underlying layer that manages file operations (kio?)

Using openSUSE 11.1
Comment 1 Vincent Petry 2009-07-25 15:07:53 UTC
A similar issue just occured. I took a screenshot with ksnapshot, and when I clicked "Save", the save dialog's suggested file name is ".png" instead of maybe "Snapshot001.png".
Comment 2 Vincent Petry 2009-07-25 15:20:41 UTC
I've tried to create a new user for testing, but the same problem appears.
What I just noticed is that the file name does appear in the rename box (selected), but for only a few milliseconds, then it disappears.
Comment 3 Frank Reininghaus 2009-07-25 21:38:55 UTC
Thanks for the bug report! I can't reproduce in recent checkouts of 4.3 branch (r1002213) and trunk (r1002360). Do you have this problem with every file and in every view mode (Icons, Details, Columns)? Do you select the file using the keyboard or using the mouse?
Comment 4 Dario Andres 2009-07-25 23:13:52 UTC
Are you using / do you have installed SCIM ? This remembers me bug 188533 (bug 188533 is the same as this)
Comment 5 Vincent Petry 2009-07-26 06:17:54 UTC
The problem occurs with every mode and every file, whenever I used either mouse or keyboard.

Thanks Dario for the link. I updated my scim/skim version accoring to the comments in that bug, and now it works fine.
Comment 6 Vincent Petry 2009-07-26 06:18:35 UTC
Marking as duplicate of 188522, since it is related to scim/skim.

*** This bug has been marked as a duplicate of bug 188533 ***