Bug 186872

Summary: kopete don't respect kde proxy settings
Product: kopete Reporter: Paulo Fidalgo <paulo.fidalgo.pt>
Component: generalAssignee: Kopete Developers <kopete-bugs-null>
Status: RESOLVED FIXED    
Severity: normal CC: adamk, armindiaz, augustuslogos, bekesa, berend.de.schouwer, bigbrovar, budinero, ernestopheles, gleb, gliporace, hengzhi.liu, hugo.m.palma, jan, maednoldor, marix, roberto.castagnola, serzholino, shafff, v1c70rp, ytimenkov
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description Paulo Fidalgo 2009-03-11 16:11:59 UTC
Version:           0.70.0 (using 4.2.00 (KDE 4.2.0), 4.2.0-15.fc10 Fedora)
Compiler:          gcc
OS:                Linux (x86_64) release 2.6.27.19-170.2.35.fc10.x86_64

I've setted the proxy settings in KDE system settings, but since I only access through proxy, I cannot connect to the IM's, like jabber (google), WLM and ICQ.

If some debug info is needed please let me know.

Best regards,

Paulo Fidalgo
Comment 1 Matt Rogers 2009-03-29 20:17:32 UTC
Since i believe those proxy settings only apply to things that use kio_http, that would be why the settings don't work.
Comment 2 Yuri Timenkov 2009-04-16 20:48:02 UTC
Looking through the sources, I've noticed that there are generic way to use proxy in for different protocols.
But now, this proxy factory is not implemented. Moreover, the usage of proxy settings is dropped while porting from kde 3.5.
Comment 3 Jan Holthuis 2009-05-16 22:37:36 UTC
Does still not work in KDE 4.3 Beta 1 (4.2.85) on OpenSuSE 11.1. This is the only reason I have to keep using Pidgin.
Comment 4 Tatu Lahtela 2009-07-15 07:50:14 UTC
*** This bug has been confirmed by popular vote. ***
Comment 5 Bobby 2009-07-26 11:21:56 UTC
AM using kde 4.3 RC3 on kubuntu and i can confirm that kopete still doesnt work with http proxy, it doesnt have any UI for configuring http_proxy and doesnt respect the one configured in the kde systemsettings network proxy. i had to use pidgin for my IM needs but its always feels out of place. like its belong to another world (which is is) so please it would be nice if a kind soul can code the functionality into kopete. i would have if i could have
Comment 6 Hugo Palma 2009-07-31 10:42:32 UTC
Is any kopete dev even looking into this ?

I see that the severity of this bug is normal i would think that critical would be a more correct value because until this bug is fixed most people that would like to use kopete at work won't be able to.
Comment 7 Adam Kirchhoff 2009-08-17 16:05:27 UTC
Can someone please explain what the "Use proxy instead" option in the Account Preferences actually does if it doesn't tell kopete to use the proxy settings?
Comment 8 Matthias Bach 2009-08-17 16:11:33 UTC
The "Use proxy instead" relates to file transfers. It will make those relay through some central server instead of being handled via direct IP connection.
Comment 9 Bobby 2009-08-31 12:01:28 UTC
seems i would never live to see the day kopete would support http-proxy. this has be one of the oldest bugs in the history of FOSS kde, Its really sad because Kopete is the only secured IM client which would could be used in an Enterprise Environment due the way it secures passwords (unlike pidgin) At the same time it cant be used because it doesn't  work behind a network proxy found in many Enterprise set up
Comment 10 Joel 2009-09-15 13:00:37 UTC
That is so true. I'm waiting (patiently) since the year 2003 for kopete to get a proxy support. It has prevent me to use it in every place I have worked (several universities and several compagnies, which all were using a http proxy). Please beloved developers, this bug is the most critical bug of Kopete right now and should be definitely solved one day!
Comment 11 Armin 2010-01-22 12:11:41 UTC
Excuse me.
There is some hope that this bug is resolved?
Comment 12 Hugo Palma 2010-01-22 12:14:31 UTC
I've lost hope so i've moved on to using Pidgin as my instant messenger.
Comment 13 Bobby 2010-01-22 12:41:22 UTC
Same here. This bug is one of the oldest in the history of free desktop and from the response of the kopete developers I don't see this would ever be fixed. Kde really needs a new IM system if its ever going to complete the social desktop desktop user  experience.  I have since moved to pidgin 
--
Sent from my Nokia N900
----- Original message -----
> https://bugs.kde.org/show_bug.cgi?id=186872
>
>
>
>
>
> --- Comment #12 from Hugo Palma <hugo m palma gmail com>  2010-01-22 12:14:31 ---
> I've lost hope so i've moved on to using Pidgin as my instant messenger.
>
> --
> Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are a voter for the bug.
> You are on the CC list for the bug.
Comment 14 Andras Georgy Bekes 2010-01-25 09:56:56 UTC
*** Bug 210684 has been marked as a duplicate of this bug. ***
Comment 15 Dotan Cohen 2010-05-11 20:17:27 UTC
*** Bug 216219 has been marked as a duplicate of this bug. ***
Comment 16 Dotan Cohen 2010-05-11 20:17:39 UTC
*** Bug 220771 has been marked as a duplicate of this bug. ***
Comment 17 Nick Shaforostoff 2010-05-27 09:22:13 UTC
SVN commit 1131073 by shaforo:

make kopete respect global KIO proxy settings when connecting to ICQ.

It uses 'https proxy' field of Systemsettings -> Network -> Proxy dialog.

CCBUG: 186872
CCBUG: 236721



 M  +24 -1     oscaraccount.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1131073
Comment 18 Nick Shaforostoff 2010-05-27 20:53:53 UTC
WLM plugin already has proxy support: http://websvn.kde.org/?view=revision&revision=987423 (available in KDE 4.4)
Comment 19 Facundo Aguilera 2010-05-27 21:12:40 UTC
(In reply to comment #18)
> WLM plugin already has proxy support:
> http://websvn.kde.org/?view=revision&revision=987423 (available in KDE 4.4)

I can't make it work (with http proxy), using account settings.
Comment 20 Nick Shaforostoff 2010-05-27 21:14:18 UTC
do pidgin or other win32 apps work via your proxy?
Comment 21 Facundo Aguilera 2010-05-27 21:27:06 UTC
win32? i'm using (In reply to comment #20)
> do pidgin or other win32 apps work via your proxy?

win32? AFAIK some people is using WLM there. I will try amsn in my laptop tomorrow and tell you.  Thanks.
Comment 22 Gleb Kulikov 2010-05-31 17:38:21 UTC
(In reply to comment #20)
> do pidgin or other win32 apps work via your proxy?

Defenitely, yes.
Any of (licq, psi, pidgin) works well.

ps: our corporate proxy is squid/2.6.STABLE17
Comment 23 Facundo Aguilera 2010-05-31 17:40:58 UTC
(In reply to comment #20)
> do pidgin or other win32 apps work via your proxy?

It works with pidgin, but through http method. Maybe this is the problem.
Comment 24 Nick Shaforostoff 2010-06-16 10:34:27 UTC
SVN commit 1138562 by shaforo:

add UI for proxy parameters configuration to ICQ account preferences dialog.

it will be more obvious to users as to where to configure proxy settings for ICQ.
and it is done the way WLM protocol plugin does.

future plans include:
-proxy requiring authentication
-SOCKS5
-system-wide proxy/account-wide proxy selection

CCBUG: 119806
CCBUG: 186872
CCBUG: 236721




 M  +229 -211  icq/ui/icqeditaccountui.ui  
 M  +17 -2     icq/ui/icqeditaccountwidget.cpp  
 M  +29 -5     oscaraccount.cpp  
 M  +8 -0      oscaraccount.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1138562
Comment 25 Serhiy Kachanuk 2010-06-17 10:27:14 UTC
Thanks for your efforts, kopete really needs more love.
As i understand, proxy support should be implemented in each protocol? Would be great to have proxy support for jabber protocol as well. Or maybe implement some global proxy connection framework for all protocols...
Comment 26 Hugo Palma 2010-10-08 15:19:01 UTC
It seems that the solution being implemented is having custom proxy settings for kopete and for each individual protocol.

Is this true ?
If so, it doesn't make any sense to me.
Please, just change kopete so that it uses the KDE configured proxy settings.
Comment 27 Gianfranco Liporace 2010-10-08 15:29:19 UTC
(In reply to comment #26)
> It seems that the solution being implemented is having custom proxy settings
> for kopete and for each individual protocol.
> 
> Is this true ?
> If so, it doesn't make any sense to me.
> Please, just change kopete so that it uses the KDE configured proxy settings.
 Hi,
I think the problem here is not only using proxy settings to work but it should be also implemented methods to access IM server through the http protocol.
Comment 28 Hugo Palma 2010-10-08 15:34:09 UTC
(In reply to comment #27)
> (In reply to comment #26)
> > It seems that the solution being implemented is having custom proxy settings
> > for kopete and for each individual protocol.
> > 
> > Is this true ?
> > If so, it doesn't make any sense to me.
> > Please, just change kopete so that it uses the KDE configured proxy settings.
>  Hi,
> I think the problem here is not only using proxy settings to work but it should
> be also implemented methods to access IM server through the http protocol.

I get that it's not trivial. But it's simply annoying that an application that only functions when connected to the internet doesn't support proxies when this has been reported 2 years ago.
Comment 29 Facundo Aguilera 2010-10-08 15:57:06 UTC
(In reply to comment #28)
> (In reply to comment #27)
> > (In reply to comment #26)
> > > It seems that the solution being implemented is having custom proxy settings
> > > for kopete and for each individual protocol.
> > > 
> > > Is this true ?
> > > If so, it doesn't make any sense to me.
> > > Please, just change kopete so that it uses the KDE configured proxy settings.
> >  Hi,
> > I think the problem here is not only using proxy settings to work but it should
> > be also implemented methods to access IM server through the http protocol.
> 
> I get that it's not trivial. But it's simply annoying that an application that
> only functions when connected to the internet doesn't support proxies when this
> has been reported 2 years ago.

Yes, the problem here is not how it is implemented, but just that it doesn't work (I don't know for icq)
Comment 30 Dawit Alemayehu 2011-05-28 04:15:36 UTC
The reason none of the previous patches will work is because the wrong assumption people get from the badly designed QNetworkProxy class. I am specifically talking about the HttpProxy and FtpProxy types specified in the afforementioned class. 

Unfortunately unlike SocksProxy and HttpsProxy (which also is badly labeled AFAIAC), the former types are only application when used in QNetworkAccessManager, not low level classes like QTcpSocket that inherit from QABstractSocket. If you chose to use QTcpSocket, then you have to connect to the proxy server yourself, just like QNetworkAccessManager would. You cannot simply call the setProxy(...) like it is currently done in both of the patches shown in this bug report. Anyhow, good luck...
Comment 31 Pali Rohár 2014-05-23 16:24:44 UTC
Git commit c3ebe03d3fb61659e59ce58d1f452cd2d5cac16a by Pali Rohár.
Committed on 20/05/2014 at 00:00.
Pushed by pali into branch 'master'.

Add support for system proxy settings via KProtocolManager in ICQ protocol
Related: bug 236721

M  +1    -1    protocols/oscar/icq/ui/icqeditaccountui.ui
M  +12   -17   protocols/oscar/oscaraccount.cpp

http://commits.kde.org/kopete/c3ebe03d3fb61659e59ce58d1f452cd2d5cac16a
Comment 32 Justin Zobel 2021-03-09 22:40:44 UTC
Thank you for the bug report.

As this report hasn't seen any changes in 5 years or more, we ask if you can please confirm that the issue still persists.

If this bug is no longer persisting or relevant please change the status to resolved.