Bug 236721 - system-wide proxy settings not respected at all
Summary: system-wide proxy settings not respected at all
Status: RESOLVED INTENTIONAL
Alias: None
Product: kio
Classification: Unclassified
Component: general (show other bugs)
Version: 4.4
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Friedrich W. H. Kossebau
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-07 17:49 UTC by Uwe Dippel
Modified: 2014-05-23 16:24 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Uwe Dippel 2010-05-07 17:49:56 UTC
Version:            (using KDE 4.4.2)
OS:                Linux
Installed from:    Ubuntu Packages

Any proxy settings are totally disregarded. I have tried Kterm, amarok, konqueror, firefox. None uses the prescribed proxy
Here is how to reproduce it for KDE 4.4.2, Kubuntu 10.04:

Set a (working) proxy in Network Settings->Proxy->Manually specify->Apply
Reboot
The proxy settings are there:
$ cat .kde/share/config/kioslaverc
PersistentProxyConnection=false

[$Version]
update_info=kioslave.upd:kde2.2/r1,kioslave.upd:kde2.2/r2,kioslave.upd:kde2.2/r3

[Proxy Settings]
AuthMode=0
NoProxyFor=
Proxy Config Script=
ProxyType=1
ReversedException=false
ftpProxy=//:8080
httpProxy=http://172.16.1.5:80
httpsProxy=//:8080

$ date && wget www.yahoo.com && date
Fri May  7 13:22:29 MYT 2010
--2010-05-07 13:22:29--  http://www.yahoo.com/
Resolving www.yahoo.com... 72.30.2.43, 98.137.149.56
Connecting to www.yahoo.com|72.30.2.43|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]
Saving to: `index.html'

    [                               <=>     ] 5,964        213B/s              ^C
$ date
Fri May  7 13:23:16 MYT 2010

(I stopped after 45 seconds, and 5964 Bytes.)

$ export http_proxy=http://172.16.1.5:80
$ date && wget www.yahoo.com && date
Fri May  7 13:24:00 MYT 2010
--2010-05-07 13:24:00--  http://www.yahoo.com/
Connecting to 172.16.1.5:80... connected.
Proxy request sent, awaiting response... 200 OK
Length: unspecified [text/html]
Saving to: `index.html.1'

    [          <=>                          ] 123,230     20.2K/s   in 5.9s    

2010-05-07 13:24:07 (20.2 KB/s) - `index.html.1' saved [123230]

Fri May  7 13:24:07 MYT 2010
$

So the proxy does work, after all.
Since I rebooted, and ProxyType=1 after the reboot, plus the correct proxy set, it becomes obvious that KDE doesn't read it at all. As simple as that. I can browse by setting the browser, but applications like amarok (no proxy settings) or apt-get cannot be run properly.

Uwe
Comment 1 Nick Shaforostoff 2010-05-25 22:29:35 UTC
see also bug 186872
Comment 2 Nick Shaforostoff 2010-05-27 09:22:13 UTC
SVN commit 1131073 by shaforo:

make kopete respect global KIO proxy settings when connecting to ICQ.

It uses 'https proxy' field of Systemsettings -> Network -> Proxy dialog.

CCBUG: 186872
CCBUG: 236721



 M  +24 -1     oscaraccount.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1131073
Comment 3 Nick Shaforostoff 2010-06-16 10:34:27 UTC
SVN commit 1138562 by shaforo:

add UI for proxy parameters configuration to ICQ account preferences dialog.

it will be more obvious to users as to where to configure proxy settings for ICQ.
and it is done the way WLM protocol plugin does.

future plans include:
-proxy requiring authentication
-SOCKS5
-system-wide proxy/account-wide proxy selection

CCBUG: 119806
CCBUG: 186872
CCBUG: 236721




 M  +229 -211  icq/ui/icqeditaccountui.ui  
 M  +17 -2     icq/ui/icqeditaccountwidget.cpp  
 M  +29 -5     oscaraccount.cpp  
 M  +8 -0      oscaraccount.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1138562
Comment 4 Dawit Alemayehu 2011-04-25 22:32:05 UTC
If you want  to set up system proxy, i.e. environment variables in Linux/Unix, then you MUST make sure that you at least restart KDE otherwise, the environment variables will not be available to KDE. You can always check this from konsole...

Also what is saved in your proxy configuration file is troubling! There should never be any entry like "ftpProxy=//:8080"! If no URL is specified for ftpProxy, then it should be blank. Dunno how you could have possibly got those entries!
Comment 5 Dawit Alemayehu 2011-05-28 04:52:12 UTC
(In reply to comment #0)
> Version:            (using KDE 4.4.2)
> OS:                Linux
> Installed from:    Ubuntu Packages
> 
> Any proxy settings are totally disregarded. I have tried Kterm, amarok,
> konqueror, firefox. None uses the prescribed proxy
> Here is how to reproduce it for KDE 4.4.2, Kubuntu 10.04:
> 
> Set a (working) proxy in Network Settings->Proxy->Manually specify->Apply
> Reboot
> The proxy settings are there:
> $ cat .kde/share/config/kioslaverc
> PersistentProxyConnection=false
> 
> [$Version]
> update_info=kioslave.upd:kde2.2/r1,kioslave.upd:kde2.2/r2,kioslave.upd:kde2.2/r3
> 
> [Proxy Settings]
> AuthMode=0
> NoProxyFor=
> Proxy Config Script=
> ProxyType=1
> ReversedException=false
> ftpProxy=//:8080
> httpProxy=http://172.16.1.5:80
> httpsProxy=//:8080
> 
> $ date && wget www.yahoo.com && date
> Fri May  7 13:22:29 MYT 2010
> --2010-05-07 13:22:29--  http://www.yahoo.com/
> Resolving www.yahoo.com... 72.30.2.43, 98.137.149.56
> Connecting to www.yahoo.com|72.30.2.43|:80... connected.
> HTTP request sent, awaiting response... 200 OK
> Length: unspecified [text/html]
> Saving to: `index.html'
> 
>     [                               <=>     ] 5,964        213B/s             
> ^C
> $ date
> Fri May  7 13:23:16 MYT 2010
> 
> (I stopped after 45 seconds, and 5964 Bytes.)
> 
> $ export http_proxy=http://172.16.1.5:80
> $ date && wget www.yahoo.com && date
> Fri May  7 13:24:00 MYT 2010
> --2010-05-07 13:24:00--  http://www.yahoo.com/
> Connecting to 172.16.1.5:80... connected.
> Proxy request sent, awaiting response... 200 OK
> Length: unspecified [text/html]
> Saving to: `index.html.1'
> 
>     [          <=>                          ] 123,230     20.2K/s   in 5.9s    
> 
> 2010-05-07 13:24:07 (20.2 KB/s) - `index.html.1' saved [123230]
> 
> Fri May  7 13:24:07 MYT 2010
> $
> 
> So the proxy does work, after all.
> Since I rebooted, and ProxyType=1 after the reboot, plus the correct proxy set,
> it becomes obvious that KDE doesn't read it at all. As simple as that. 

No it is not because what you did above it completely wrong.

> I can browse by setting the browser, but applications like amarok (no proxy settings)
> or apt-get cannot be run properly.

A lot of things that should not are being conflated together here.

First, manually configuring proxy in KDE only applies to applications that use KDE's KIO for accessing the network. The last I checked apt-get is not a KDE application. Secondly, as far as Amarok not working through proxy, you might want to checkout bug# 246828.

If you want both KDE and non-KDE applications to share proxy information, then you need to configure system wide proxy environment variables and configure KDE's proxy to "Use preset proxy environment variables", which it will gladly do so.
Comment 6 Pali Rohár 2014-05-23 16:24:44 UTC
Git commit c3ebe03d3fb61659e59ce58d1f452cd2d5cac16a by Pali Rohár.
Committed on 20/05/2014 at 00:00.
Pushed by pali into branch 'master'.

Add support for system proxy settings via KProtocolManager in ICQ protocol
Related: bug 186872

M  +1    -1    protocols/oscar/icq/ui/icqeditaccountui.ui
M  +12   -17   protocols/oscar/oscaraccount.cpp

http://commits.kde.org/kopete/c3ebe03d3fb61659e59ce58d1f452cd2d5cac16a