Bug 136123

Summary: cannot mount storage devices more than one time
Product: kio Reporter: Manuel Arguelles <manuel.arguelles>
Component: mediaAssignee: Kevin Ottens <ervin>
Status: RESOLVED UNMAINTAINED    
Severity: normal CC: millr4, public, rw, slack1_more
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Slackware Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Manuel Arguelles 2006-10-22 10:53:04 UTC
Version:            (using KDE KDE 3.5.4)
Installed from:    Slackware Packages
OS:                Linux

Can't mount devices using konqueror storage media more than once... if I click on the cdrom icon in the konqueror storage media, it mounts the device and open it, then I go back and right click on the cdrom icon and unmount it, then I click on it again and it keeps loading forever... however I do mounts the device, cause I can see it from console and file manager, once cancelled it doesn't show it as mounted, so there's no way to unmount it but command line...

I'm using slackware 11, not sure if it's a kde only bug or slackware too...

google search returned:
http://www.linuxquestions.org/questions/showthread.php?t=489330
Comment 1 Bram Schoenmakers 2006-10-25 18:59:25 UTC
*** Bug 136301 has been marked as a duplicate of this bug. ***
Comment 2 Manuel Arguelles 2006-10-27 06:57:45 UTC
Confirmed for kde 3.5.5 as well (system without hal, kernel 2.4.3.33 or 2.6.17.13)
Comment 3 Manuel Arguelles 2006-10-27 07:02:15 UTC
Errata: I'm not 100% sure of comment #2, sorry
Comment 4 public 2006-10-27 14:30:41 UTC
I can confirm it for kde 3.5.5
Comment 5 Dan Ciarniello 2006-11-01 20:27:37 UTC
This also happens on with KDE 3.5.5 on Fedora Core 6.  

I get similar behaviour to that described above with the CD drive but there's a more serious problem with USB connected devices.

I have an external hard drive connected via USB.  I can mount and unmount the drive once through the USB icon on my desktop.  If I try to mount a second time, my system hangs - i.e. the mouse and keyboard are frozen.  The only way to recover is to hit the reset button (it's possible that the system would eventually recover but I haven't had the patience to wait it out for more than a minute or so).  The drive can be remounted if it's first disconnected and reconnected but that, obviously, should not be required.
Comment 6 millr 2006-11-02 02:13:47 UTC
here is a snip from the slackware current changelog  before version 11.0 was released.
kde/kdebase-3.5.4-i486-7.tgz: Patched to fix media:/ URLs in Konqueror without
       requiring HAL. 
       
       

I am running slackware 11.0 and have the same problem. mount a cd or dvd view it's contents>unmount>eject>reload>error is now noticed.the media is being mounted according to /etc/mtab and the contents can be viewed in /mnt/cdrom, However the system:/media cdrom icon says it is a unmounted cdrom,click on it and nothing.I thought this was a KDE bug until I noticed the above snip from the slackware current changelog just prior to version 11 release. Perhaps whatever they patched broke
something else. The confusing part is there is a use HAL or not checkbox there why patch (hack) around it or better yet just include HAL and HAL support in
Slackware 11.
Comment 7 Bram Schoenmakers 2006-11-19 11:47:36 UTC
*** Bug 137556 has been marked as a duplicate of this bug. ***
Comment 8 Robby Workman 2006-12-21 04:00:30 UTC
*** This bug has been confirmed by popular vote. ***
Comment 9 Robby Workman 2006-12-21 04:07:08 UTC
@millr:
The patch that "they" used to fix the media:/ URLs in Slackware was Stephen Kulow's svn commit (backported for 3.5.4) - see http://bugs.kde.org/show_bug.cgi?id=132281 for more information.
As for adding HAL, well, future versions of HAL will require PolicyKit, and PolicyKit requires PAM, and Slackware's not likely to get PAM any time soon.  In any event, it's not as simple as it sounds.

@devs:
I can confirm that this is also present in 3.5.5.
Comment 10 Manuel Arguelles 2006-12-24 04:09:44 UTC
is there any workarounds for this? HAL and slackware are not compatible, and as far as it looks they will not be for a long time... question is, is HAL a requirement in kde? it will be cool to have like a flag in configure script to disable hal support and fall back to old behaviour? not sure if that will be as simple as it sounds (i have no idea about kde internals)

is HAL present in other os? (*bsd, (open)solaris, et cetera?)
  
Comment 11 Robby Workman 2006-12-24 04:17:34 UTC
If you read the bug report in my previous comment, the question about HAL is already answered.  To sum up, no, it's not required.  This bug isn't about HAL support at all - I only commented about it above because someone else seemed to have it confused...
Comment 12 David Unric 2006-12-29 15:21:00 UTC
I can confirm this bug.
All kio media managers from previous KDE versions until 3.5.3  did worked properly using /etc/fstab entries when kdebase was built without HAL support.
Even in KDE 3.5.5 there is officialy only optional requirement for HAL so it should work without it too.
Comment 13 Robby Workman 2007-01-11 20:28:47 UTC
To clarify the scope of this bug:
It was not present in 3.5.3 (it worked properly), but 3.5.4 broke it - we initially thought it was due to http://bugs.kde.org/show_bug.cgi?id=132281, but even after applying the backported patch, this bug still exists. 
Comment 14 Robby Workman 2007-04-06 15:49:24 UTC
Is there anything I can do to help get a better diagnosis of exactly what is causing this?   I'd really like to get a patch for this...
Comment 15 Rex Dieter 2007-04-16 18:03:23 UTC
*** Bug 144208 has been marked as a duplicate of this bug. ***
Comment 16 Claude Tamplenizza 2007-04-16 22:17:28 UTC
When, if ever, is anyoone going to look at this?
Can I help?
Someone talk to me.
Comment 17 Robby Workman 2007-06-28 23:16:38 UTC
For those Slackware users still following this bug, it won't be an issue in Slackware 12.0 (which is just around the corner) - it will have HAL.

For those of you still on 11.0, it seems that you'll have to learn to live with this bug :/
Comment 18 Kevin Ottens 2009-02-27 19:45:04 UTC
kio media is gone in KDE4.