Bug 137556 - Cannot see contents of CD ROM after Changing discs
Summary: Cannot see contents of CD ROM after Changing discs
Status: RESOLVED DUPLICATE of bug 136123
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Slackware Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-11-19 01:24 UTC by Claude Tamplenizza
Modified: 2006-11-19 21:24 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Claude Tamplenizza 2006-11-19 01:24:24 UTC
Version:           3.5.4 (using KDE KDE 3.5.4)
Installed from:    Slackware Packages

- Loaded a CD into CD ROM and viewed it OK.
- Pressed button on CD device to eject it but did not work (why?)
- Used right-click to get to Unmount and unmounted CD ROM
- Pressed button on CD device and CD was ejected OK (should have worked first time!)
- inserted new CD 
- double clicked on CD ROM icon in Konqueror. The Mount window is displayed briefly, the disc device runs, but nothing is displayed in the Konqueror main window.
- I change to a console and navigate to /mnt/cdrom and find all the contents of the CD listed appropriately!?
- I unmount the CD
- I get back to Konqueror and try to view the CD again, and again I get the same behavior as before: window pops up, CD runs but no display.

Seems to me there's some code changes required.
And here's a question: can we not obtain information from the device when:
1) the device is opened by the Open/Close button on the hardware?
2) a new disk is inserted?

The behavior should parallel the Windows approach (much as it pains me to say so), because that is the more obvious way of interacting with this device. It should be:
1) Press the Open/Close button on the device. This:
   - unmounts the /mnt/cdrom and opens the CD device
   - prompts KDE the CD device is to be mounted when ready (closed)
   - Now the device is mounted ALL other CD-oriented utilities in KDE must refer to /mnt/cdrom, AND must be aware of when the Open/Close button on the device is pressed.
It's optional whether all CD-oriented utilities in KDE re-load the contents of /mnt/cdrom, it depends on what they do, but it would be a good idea.
Comment 1 Bram Schoenmakers 2006-11-19 11:47:32 UTC
Not being able to eject the CD while it's mounted is a feature and not a bug.

*** This bug has been marked as a duplicate of 136123 ***
Comment 2 Claude Tamplenizza 2006-11-19 21:24:03 UTC
OK,
I agree some of it is a duplicate, but that does not solve the issue of the
Open/Close button on the device ...or does it?

Regards.

[bugs.kde.org quoted mail]