Bug 99931 - knotify stops working if volume < 100
Summary: knotify stops working if volume < 100
Status: RESOLVED DUPLICATE of bug 61438
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: knotify (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Carsten Pfeiffer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-02-21 15:45 UTC by Alex Sidorenko
Modified: 2005-03-27 18:59 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Sidorenko 2005-02-21 15:45:23 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
Compiler:          gcc-3.3.5 
OS:                Linux

knotify works fine (KDE Sound System) if volume=100 but there is no sound for .ogg files as soon as volume <100. If I do a fresh compile/install it works normally if I install arts+kdelibs+kdebase only. The problem is triggered by installation of 'kdemultimedia' package, more precisely as soon as I do 'make install' in 'akode' subdirectory of kdemultimedia knotify does not play .ogg files anymore (if volume < 100)

knotify continues to work normally even with volume < 100 if I specify .wav file instead of .ogg

I can see in knotify.cpp that a stack of effects is installed only 

        if ( d->volume != 100 )
        {
            // It works to access the playObject immediately because we don't allow
            // non-file URLs for sounds.
            Arts::StereoVolumeControl volumeControl = Arts::DynamicCast(soundSer
ver->server().createObject("Arts::StereoVolumeControl"));
            Arts::PlayObject player = playObject->object();
            Arts::Synth_AMAN_PLAY ap = d->audioManager->amanPlay();
            if( ! volumeControl.isNull() && ! player.isNull() && ! ap.isNull() )


So I suspect that installing akode breaks something in this code
Comment 1 Thomas Vollmer 2005-03-07 12:23:36 UTC
I also can confirm this bug with KDE_3_4_BRANCH and HEAD.
Comment 2 James Ots 2005-03-27 18:59:09 UTC

*** This bug has been marked as a duplicate of 61438 ***