Bug 97925 - Add option to disable KWallet integration completely
Summary: Add option to disable KWallet integration completely
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist with 247 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 130521 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-01-26 11:36 UTC by Maxim
Modified: 2008-02-20 01:27 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Avoid kmail asking everytime if passwords should be saved in config file (2.63 KB, patch)
2005-06-05 01:25 UTC, Miguel Angel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maxim 2005-01-26 11:36:10 UTC
Version:           1.1 (using KDE 3.3.91 (beta1), Gentoo)
Compiler:          gcc version 3.4.3 20041125 (Gentoo Linux 3.4.3-r1, ssp-3.4.3-0, pie-8.7.7)
OS:                Linux (i686) release 2.6.9-gentoo-r9n

I would prefer Kmail would not store passwords in Kwallet. Probably there should be an option either to store them in a file or in Kwallet. I would prefer to store them in a file and not to be asked for Kwallet-password at every mailcheck.
Comment 1 Stephan Binner 2005-01-27 10:18:15 UTC
If you cancel the opening of the wallet, then KMail asks you wether to store the password in the configuration file. Unfortunately that doesn't work, it will try to open the wallet before/instead of reading it from the configuration file. :-(
Comment 2 Aewyn Vienna 2005-03-07 16:57:35 UTC
It is a usability error too, because I must to give a password, but I just need to read my emails.

(So I dont want to access any KWallet protected info, just mails, simple mails.)
Comment 3 ewan dunbar 2005-03-28 04:39:34 UTC
I have kmail open on startup and having to type the password every time is VERY annoying. As long as opening the kwallet always prompts for a password (and I don't want to have NO password), having kmail use kwallet is a double edged sword - my IMAP passwords are secure and I don't have to remember them both, but since I DO know my passwords, I've lost everything I gained by storing them.
Comment 4 Janet 2005-04-13 14:16:58 UTC
It also happens in kmail 1.8/KDE 3.4.0, Debian Package 4:3.4.0-0pre3 and it is very annoying to have to enter the kwallet password when I just want to check my mail or look into the settings of my account. But I cannot store the passwords in the config file. When I answer the kwallet password question not with the kwallet password but with a "cancel" the password is deleted. And on kmail shutdown I get the "hint" that kdewallet isn't installed or something like that and if I therefore want to store the password in the config file or nowhere. I press the save-button but next time I start kmail I still have to enter the kwallet password when checking for mails or trying to look into the settings of the accounts... I just want to have back the convenience of kmail 1.7/KDE 3.3.2 (for this case) where I entered the account passwords in the account settings (once!) and then never been asked again for the password.
Comment 5 Leo Savernik 2005-04-21 16:46:55 UTC
Heh, I've just inadvertently attempted to report a bug with exactly the same title!

This effectively means this bug has at least one virtual duplicate ;-)

I'll also vote for it, as the current situation is quite annoying.

OTOH, if bug 92845 is implemented, I'll consider this bug a non-issue.
Comment 6 Leo Savernik 2005-04-21 16:49:22 UTC
*** This bug has been confirmed by popular vote. ***
Comment 7 Miguel Angel 2005-06-05 01:21:58 UTC
This bug is SO annoying, and it is still present in kde-3.4.1, so i have decided to put it to an end.
It is completely ilogical to force me to use a passwordless wallet to avoid kmail bugging me each time i check mail, leaving my important web passwords, like bank accounts, exposed.
Apply the patch to kdepim3 and recompile it. If you block kmail from opening the wallet, it will ask only ONE time for each account if the password should be saved to the config file. Once the password is saved, it will never ask again, as it should.
To do this I added a couple of new options to the config file kmailrc, store-passwd-in-config and storepasswdinconfig, that once they are set to true kmail avoids asking.
Hope the kmail developers add it to official kdepim3. A config option would be nice too.
Comment 8 Miguel Angel 2005-06-05 01:25:04 UTC
Created attachment 11330 [details]
Avoid kmail asking everytime if passwords should be saved in config file

This patch solves this bug.
A config option would be needed to give the user complete control over this.
Comment 9 Casey Allen Shobe 2005-12-15 02:11:02 UTC
If you don't like using a passwordless wallet for everything, then use separate wallets for kmail and konqueror.  Problem solved.  I don't see why this is a bug.
Comment 10 ewan dunbar 2005-12-15 03:35:20 UTC
if the solution is to use separate wallets, then there should be a kmail wallet by default, and it should always be passwordless, since there is already a mail password -- but at that point I fail to see the benefit of having kmail use kwallet.
Comment 11 Leo Savernik 2005-12-15 17:23:51 UTC
Am Donnerstag, 15. Dezember 2005 03:35 schrieb ewan dunbar:
> if the solution is to use separate wallets, then there should be a kmail
> wallet by default, and it should always be passwordless, since there is
> already a mail password -- but at that point I fail to see the benefit of
> having kmail use kwallet.


I fully support that approach. While *I* could set up a distinct wallet for 
kmail, e. g. my parents certainly cannot.

Why having a passwordless wallet? Well, it would be an interimistic solution 
until kwallet supports pam (bug 92845).
Comment 12 Miguel Angel 2005-12-15 21:08:42 UTC
> If you don't like using a passwordless wallet for everything, then use
> separate wallets for kmail and konqueror.  Problem solved.  I don't see why
> this is a bug.

Please note that driving the user mad asking every time he closes kmail/kontact and for each account if the password should be saved or lost should be considered a bug, even more since if you close the kde session with kmail open all passwords will be lost because the default action is not to save them.
Please note that the sollution is just a one liner, it is not such a big change.
Please, note too that having a passworless wallet with your banking passwords is a bad thing, while pop3 passwords are simply sent in clear plain text.

And I don't have any problem at all at using different wallets for kmail/kontact and konkeror, but please explain how to do it, because I fail to see any configuration option in kmail/kontact/konqueror to select any wallet, and I fail to see how to assign a wallet to any given application, and both kmail/kontact and konqueror insist in using the default wallet.

I agree too with Ewan and Leo about using a different passwordless wallet for kmail by default.
Comment 13 Stefan Mueller 2006-04-22 11:05:51 UTC
This bug title should be reworded to: "Use kmail without annoying kwallet password storage"

see also first hit on
http://www.google.de/search?q=kmail+without+kwallet

"KMail without KWallet?
From: Elena Lazar <ela (at) cs.tuiasi.ro>
Date: Thu, 9 Feb 2006 04:28:29 +0200 (EET)
Hello,

I am using KDE 3.5.1. I use KMail to get mail from an IMAP account. I am 
also using KWallet, (with password) which is great.

However, I want that for KMail in particlar, to not use KWallet. I need 
KMail to get my mail/contacts/todo-s/etc automatically when I start it, 
using the password stored in ints config file. I do not want to use 
passwordless KWallet, but to be able to tell KMail to not use it, but I 
did not found any option.

What should I do, please?
Merci"

I could not say it better.
Comment 14 Stefan Mueller 2006-04-22 11:19:25 UTC
re: #11 (set up a passwordless wallet) -- I tried that, too. But I did not figure it out after 5 Minutes -- kmail did not look in my new wallet -- so I left that kwallet/kmail pwd-config weirdness and spend 45 min's on bugreporting instead.

My workaround is a completely passwordless kwallet. So my onlinebanking password is passwordless, too. Hmm.

And big Thanks to all kmail/kde developers for that always improving work. Please look into that attached patch here!
Comment 15 Tanja Schulte 2006-04-22 19:20:42 UTC
I am only able to use kmail without nag-word when I completely abstain from using kwallet at all :( Why do I need a password to fetch/send mail? I have authenticated when logging in... I think the problem is that kmail does not have an en-/decryption module itself so that it can store the passwords in an encrypted not human-readable extra config-file.    

I guess this is one of the most hated bugs... 
Comment 16 Janet 2006-10-03 20:39:28 UTC
How can I set up a wallet that is only (and really only) used by kmail? Today I was asked by kmail 15 times to enter the password (and I did not close kmail between looking for email), that means 15 out of 16 times I was looking for mail manually :-/
Comment 17 Miguel Angel 2006-10-03 21:20:18 UTC
re #16: You could use the patch uploaded here. The passwords will be saved in the config file, not in a different wallet, but it will not ask you again.
Comment 18 Bram Schoenmakers 2007-01-10 18:47:57 UTC
*** Bug 130521 has been marked as a duplicate of this bug. ***
Comment 19 Thomas McGuire 2007-06-15 18:34:55 UTC
I consider this bug fixed in trunk (KDE4).
KMail will only show the wallet dialog when you change a password.
If the wallet is not available or if you disallow KMail the access to the wallet, the user is asked if he wants to store the password in a config file or if he doesn't want to store the password at all.
Unless the user changes the password again, the user won't be asked any password-related questions again, neither when checking mail nor when quitting KMail.

See SVN commit 674135 and 673632.
Comment 20 Miguel Angel 2007-06-15 21:30:20 UTC
Please, backport to kde 3.5
Comment 21 Julian Mehnle 2007-12-27 18:18:15 UTC
See bug 95615.

Let's just hope that KDE 4 gets released soon and that the new KMail will be usable from the start (unlike past releases that used to break important features because the maintainers decided those features were obsolete *rant*).  Otherwise a backport to the 3.5 branch might be in order.
Comment 22 Pal Körössy 2008-02-20 01:27:14 UTC
The solution described in bug 95615 and 131516 still not working properly for me. I prefer storing the account-passwords in the config-file to storing them in Kwallet. Up till now I've used Miguel Angel's patch to avoid unneccessary and annoying warnings which works OK, but it is a bit uncomfortable to recompile each new kdepim packages. I've just noticed the bugs mentioned above that contain solution for this problem. Now trying the recent kdepim-3.5.9 suse rpm to see how it works I experience that I still have been asked 'to store or not the password?' everytime I want to modify something except any passwords in the Identifications, Incoming- or Outgoing accounts section in the Settings menu of Kmail.