Bug 97718 - placement remember window settings
Summary: placement remember window settings
Status: RESOLVED DUPLICATE of bug 15329
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-23 14:51 UTC by Jarne Cook
Modified: 2005-01-25 12:52 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jarne Cook 2005-01-23 14:51:49 UTC
Version:           unknown (using KDE 3.3.1,  (3.1))
Compiler:          gcc version 3.3.5 (Debian 1:3.3.5-3)
OS:                Linux (i686) release 2.6.10-i8600

I have come across and compiled my thoughts on the crapulance that is window management with reguards to initial window placement.

Perhaps this could go into "smart" ... maybe into a new one maybe called "remember".


Its all too much.

I see kwin now has the extreme advanced window settings dialog.  In there I can set each app to have it's size/pos remembered.  This is a nice feature but it's is very inconvenient.  To have to right click for every application is just overboard.  

Kate on the other hand has the option built in.  Unfortunately this is not an ideal solution to the problem either.  If one does not use the kwin method and enabled the kate method the user will notice kate popup where kwin decides to put it.  Then when kate has loaded the files, it will move the window into the correct place.

Both method are less than optimal as options.  Hell, its a joke.

My thoughts on how it should have, and can still been done.

My theory is that of integration with other window managers.  I think that it would be selfish to implement the whole thing in kwin.  Bear with me.

This is how i see it happening.

In the config for kwin there would be maybe a checkbox "remember window settings", or maybe a new "remember" placement method.  If a user enables that option, then kde based applications do the work.  Before the window is created the application informs kwin of "remember" settings.  I say "remember" because it may not be limited to just size/pos.  When the application window is closed the application (at the kde libs level) saves the settings for later.

The reason it should be implemented at the app level (in the kde libs) is ... if the users is not using kwin, say whatever gnome uses, then it would be still possible to have the window restored (assuming the WM knows how to do it).

The kate developers should never have added that feature to the application.  It should have been integrated into the kdelibs and enabled in kcontrol for all applications to use.

This is something that has niggled at me for some time now, and I'm glad to have gotten that out.  I hope someone doesn't just dismiss this a a non-important feature.  I get the feeling most  people take it for granted in other OS's, and don't realise it is there.

I guess for the time being I will have to start configuring all the windows to be remembered manually.  Oh well.  Sucks to be me.
Comment 1 Lubos Lunak 2005-01-25 12:52:26 UTC

*** This bug has been marked as a duplicate of 15329 ***