Bug 97139 - Kmail can't send mails, authentication problem?
Summary: Kmail can't send mails, authentication problem?
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 97412 99911 108151 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-01-16 13:32 UTC by Raul Moratalla
Modified: 2007-09-14 12:17 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Raul Moratalla 2005-01-16 13:32:10 UTC
Version:            (using KDE KDE 3.3.91)
Installed from:    SuSE RPMs
OS:                Linux

I have been working ok with Kmail with all previous versions. I installed Kde 3.4 beta 1 and I can't send any mail.
I didn't modified any parameter of my smtp account.
This is the message:

Falló la autorización, autentificación An error occured during authentication: SASL(-4): no mechanism available: No worthy mechs found no soportada

"An error occured during authentication: SASL(-4): no mechanism available: No worthy mechs found"

I don't have any problem with my provider, so I don't know why this happens.
Comment 1 Jean Pierre Wenzel 2005-01-17 13:30:01 UTC
Same problem here :(
Comment 2 Jakob Schröter 2005-01-17 13:57:32 UTC
you probably need to get cyrus sasl installed
Comment 3 Jean Pierre Wenzel 2005-01-17 14:15:16 UTC
$ rpm -qa *sasl*
cyrus-sasl-2.1.19-7.2
cyrus-sasl-saslauthd-2.1.19-5.2

I think it is installed. libsasl2 should be included in the SuSE cyrus-sasl-2.1.19-7.2 package.

Comment 4 Jean Pierre Wenzel 2005-01-17 15:12:36 UTC
Well, I don't know what changed between KDE 3.3.2 and 3.3.91, but after I have now installed the following additional cyrus-sasl packages, everything works fine:

$ rpm -qa cyrus-sasl*
cyrus-sasl-plain-2.1.19-7.3
cyrus-sasl-2.1.19-7.2
cyrus-sasl-digestmd5-2.1.19-7.3
cyrus-sasl-saslauthd-2.1.19-5.2
cyrus-sasl-crammd5-2.1.19-7.3

The RPM packages can be found at any SuSE mirror, e.g. ftp://ftp.gwdg.de/pub/suse/i386/current/suse/i586/

This bug seems to be rather a problem of unsolved package dependencies than a KMail bug itself.
Comment 5 Raul Moratalla 2005-01-17 17:09:18 UTC
Yes, it seems a problem of package dependencies. I installed other cyrus packages and it works fine :)
Comment 6 Jakob Schröter 2005-01-19 10:58:56 UTC
*** Bug 97412 has been marked as a duplicate of this bug. ***
Comment 7 Mark 2005-02-01 17:44:19 UTC
On systems where sasl2 is compiled from source, you will probably have to run
ln -s /usr/local/lib/sasl2 /usr/lib/sasl2

to allow the library to find its plugins... this might be required on some RPM systems too, I don't know.

This fixed the above problem for me
Comment 8 Jakob Schröter 2005-02-21 13:50:33 UTC
*** Bug 99911 has been marked as a duplicate of this bug. ***
Comment 9 Jens 2005-03-05 03:11:52 UTC
You need to put /usr/lib/sasl2 (or similar) in your "OpenSSL path" in Konqueror's crypto config. After doing that, and restarting KMail / Kontact, sending worked for me, again.

IMHO KMail / Konq should auto detect these libraries somehow.

Comment 10 Coney 2005-03-19 00:34:29 UTC
All the above comments were very helpful.
Ran into the same problem and could fix it right away thanks to you all.

Coney, Berlin, germany
Comment 11 Łukasz Derkacz 2005-03-26 08:37:38 UTC
Giving Cyrus path in Konqueror is not all. One have to Check a "SEND" checkbox in Authorisation Tab, next to OpenSSL Tab.
Comment 12 Kenjiro Tanaka 2005-04-11 03:53:55 UTC
another approach, more elegant to my eyes, is to do the following before compiling cyrus-sasl:

./configure --prefix=/usr

(at least that is more elegant for Slackware users and it works).

I had downloaded the cyrus-sasl package for Slackware from KDE site and that didn't help me (yes, it could have worked if I had used the symlink you guys mentioned). So I downloaded the sources, compiled it (using the option I showed before) and now it works just fine.
Comment 13 Joffen 2005-04-27 13:27:03 UTC
Same problem here (the distro formerly known as mandrake 10.2 RC1).

Thanks to the comments above and John Layt (http://lists.zerezo.com/mandrake-expert/0668.html) it now works. The additional information I needed was that the saslauthd service needs to run.

A summary for Mandriva users:
 urpmi cyrus-sasl 
 urpmi libsasl2 
 urpmi libsasl2-plug-login 
 urpmi libsasl2-plug-plain
 service saslauthd start
Comment 14 Thiago Macieira 2005-06-26 18:52:37 UTC
*** Bug 108151 has been marked as a duplicate of this bug. ***
Comment 15 Martin Matusiak 2005-08-18 09:45:33 UTC
I'm having this same problem on Ubuntu.. as far as I can tell, all of the mentioned packages are installed (ubuntu's packaging is a bit different) and I have set the mentioned config setting in Konq. But I'm still getting the error message and I'm also seeing this on my shell:

kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libkdecore.so.4: undefined symbol: PKCS7_content_free
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libkdecore.so.4: undefined symbol: OpenSSL_add_all_algorithms
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libkdecore.so.4: undefined symbol: OpenSSL_add_all_algorithms_conf
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libkdecore.so.4: undefined symbol: OpenSSL_add_all_algorithms_noconf
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libkdecore.so.4: undefined symbol: PKCS7_content_free
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libkdecore.so.4: undefined symbol: OpenSSL_add_all_algorithms
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libkdecore.so.4: undefined symbol: OpenSSL_add_all_algorithms_conf
kdecore (KLibLoader): WARNING: KLibrary: /usr/lib/libkdecore.so.4: undefined symbol: OpenSSL_add_all_algorithms_noconf

In Konq's crypto config, under OpenSSL when I enter /usr/lib/sasl2 and click Test, I get "OpenSSL was successfully loaded", but again with the errors shown above in the shell.
Comment 16 Martin Matusiak 2005-08-18 10:31:52 UTC
My bad, the bug appeared when using different software which set SASL_PATH to a certain location and that broke kmail.