Bug 92931 - integrated support for flash mp3 players?
Summary: integrated support for flash mp3 players?
Status: RESOLVED DUPLICATE of bug 91639
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 1.1.1
Platform: Slackware Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-11-08 21:39 UTC by Dan
Modified: 2006-06-11 12:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dan 2004-11-08 21:39:39 UTC
Version:           1.1.1 (using KDE KDE 3.2.3)
Installed from:    Slackware Packages
Compiler:          gcc 3.3.4 
OS:                Linux

Any possibility of a plugin for mp3 players?

This is a ridiculously simple addition that would be a really nice option for those of us with mp3 players.... :)  I'd go ahead and do it myself, but I know there are much better coders than I who can do it much more cleanly.

Wishlist:

--mp3 player could appear as a tab on the left.
--Mount/unmount, either via /etc/fstab, or use command given in config.  Popup a password dialog if required.
--Drag-and-drop files from playlist.
--Give error message if capacity exceeded, or perhaps just ghost out the add feature if the device is full.
--Capacity should autodetect.
--Mount point can be set in config.
--"Add to mp3 player" in right-click context menu.

And for a bonus point:

--Allow directory structure options: all in root, 1-deep by album, 1-deep by genre, 1-deep by artist, arbitrarily deep.
Comment 1 Mark Kretschmann 2004-11-09 18:13:38 UTC
Find a means to provide us with such hardware (sponsoring), then we can implement.
Comment 2 Dan 2004-11-09 18:17:58 UTC
Do you have a usb key, pendrive, flash drive, whatever you call them?  It's the exact same thing, as far as the computer knows!  Just a VFAT usb flash drive.

I could give you some code, or at least some scripts... is python ok?
Comment 3 Seb Ruiz 2004-11-10 13:11:29 UTC
Inherently just copying to a device, so i am marking as duplicate.

*** This bug has been marked as a duplicate of 91639 ***