Bug 90678 - Fitts' Law for decoration buttons
Summary: Fitts' Law for decoration buttons
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: decorations (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR wishlist with 2 votes (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 94871 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-10-03 02:56 UTC by Roberto Alcantara
Modified: 2012-03-09 15:09 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roberto Alcantara 2004-10-03 02:56:20 UTC
Version:            (using KDE KDE 3.2.3)
Installed from:    SuSE RPMs
OS:                Linux

Trying close one windows moving  mouse all to left, and all to top you can't close maximized window.

That's kill "menu at 100 miles" concept - 99,99% from users never will click this point to other think except close the window.
Comment 1 Lubos Lunak 2004-10-06 11:45:33 UTC
I'm afraid it's up to the decoration styles to handle this.
Comment 2 Sandro Giessl 2004-12-11 00:38:22 UTC
What you are describing sounds like what e.g. the Keramik and Plastik window decorations already do: When the window is maximized, the borders shrink to 0 pixel and all you have to do to close the window is to throw the mouse into the corner and click...
Comment 3 Maksim Orlovich 2004-12-11 00:41:09 UTC
*** Bug 94871 has been marked as a duplicate of this bug. ***
Comment 4 Gabriel Gazzán 2005-12-10 19:49:43 UTC
I agree this should be the behaviour of all window decorations, it's annoying when it's not that way for users used to that practice.
Aren't there a set of rules (HIG) for all windows decorations to follow?
Perhaps it should be considered if there isn't already one.
Comment 5 Lubos Lunak 2007-06-04 12:49:50 UTC
Which decorations still don't support this?
Comment 6 Andrey Cherepanov 2007-06-04 17:42:01 UTC
Plastik at KDE 3.5.6. Normal border width.
Comment 7 Lubos Lunak 2007-06-05 14:00:26 UTC
It works fine with Plastik, it's even mentioned in comment #2. You don't have moving of maximized windows disabled, do you? It is required for this functionality. So, some other decorations?
Comment 8 Andrey Cherepanov 2007-06-05 15:03:58 UTC
I check all window decoration themes. Works fine:
- Alloy
- KStep
- Knifty
- RISC OS
- Smooth Blend
- Plastik

Other window decorations don't work.
Comment 9 Tristan Miller 2010-08-23 01:14:42 UTC
This works with Oxygen on KDE 4.5.0.
Comment 10 Martin Flöser 2012-03-09 15:09:36 UTC
Given that the decorations shipped with KWin nowadays properly implement fitts' law for maximized windows, I consider this feature request as implemented.