Bug 89805 - Add Webmail support
Summary: Add Webmail support
Status: RESOLVED INTENTIONAL
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: SVN trunk (KDE 4)
Platform: Debian testing Linux
: NOR wishlist with 40 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 142965 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-09-19 11:33 UTC by Juan Manuel García Molina
Modified: 2009-12-20 00:00 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Juan Manuel García Molina 2004-09-19 11:33:31 UTC
Version:            (using KDE KDE 3.3.0)
Installed from:    Debian testing/unstable Packages

It would be really nice have webmail support in kmail.

By "webmail support" I mean a way to access webmail accounts using kmail, like yahoo or gmail.
Comment 1 mhirsch 2004-09-27 20:14:20 UTC
You might want to check out libgmail, http://libgmail.sourceforge.net/.  It is a python modules for reading gmail.  Among other things, it can wrap gmail and make it look like a POP3 server.  So now kmail can use it!

I haven't tried it, but it sounds great, doesn't it?
Comment 2 Juan Manuel García Molina 2004-09-27 20:39:29 UTC
Hi, mhrisch.

gmail is just one of webmails. The wish is for general webmail support.

The library you refer to in your comment should be a nice idea to take as starting point. A general library to abstract webmail access and small modules to connect this general library with the real webmail sites. In this scenario, kmail just had to rely on the general library to access webmail.

Regards,
Juanma.
Comment 3 Bruno Seoane 2004-10-30 04:36:07 UTC
Well, you should take a look to Freepopsd, it features a POP3 daemon, which 
acts as a bridge between your mail program and the webmail resource.

Take a look at it: http://www.freepops.org/

Comment 4 Bram Schoenmakers 2007-03-14 16:41:39 UTC
*** Bug 142965 has been marked as a duplicate of this bug. ***
Comment 5 Sputnik 2007-08-12 11:26:23 UTC
I would like this to be assigned not to kmail but to "Systemsettings" or "kcontrol". There should be a possibiliy to choose between "kmail", "webmail" or "other" possibilities to handle email in KDE. - A small wizzard should help to set the right mail hoster.

There is a good solution that also seems to work in Konqueror as well by Scott Severance. ( http://ubuntuforums.org/showthread.php?t=398974 )

However there should be some kind of guarantee that the system is connected with the net. If a mail would be prepared while being offline it should be possible to rest waiting. - This should be a task for kmail again!
Comment 6 Sputnik 2007-08-12 11:33:24 UTC
I have added this wish to "Systemsettings" here: https://bugs.kde.org/show_bug.cgi?id=148765
Comment 7 J Wood 2007-08-26 14:26:31 UTC
I'd like to add my support of this wish.  Thunderbird 2 now has a feature to automatically set up the client with a Gmail account, so it can read and send Gmail.  Kmail can at best read it, and saves the files on local folders.  Sending is a bear; it works for some, doesn't for many.  I've never really gotten Kmail to send a message via a Gmail account, and the settings are a little nuts -- when you search for this issue, there's at least three different ports to try with smtp, with a number of other settings to try for each one, and none of them working all the time.  I managed to send one email, of over 130 attempts.
Comment 8 Richard Hartmann 2007-08-28 16:13:06 UTC
J Wood: Just use

Server : pop.gmail.com
Port   : 465
User   : wasteyourtimehere@gmail.com

then click 'check what this server supports' (that would be TLS and plain text)
then save and use it :)

------------------

When you use KMail 3.5.7. with GMail, it will delete the mails sent via GMail after fetching them (along with your received mail. Argh.) even though both GMail and KMail were told not to delete anything. But I suspect this is GMail's problem, not KMails, I just included this as it seems to fit here and I was writing, anyway :)
Comment 9 Richard Hartmann 2007-12-18 19:26:14 UTC
In light of the impeding KDE4 release, I am going through all bug reports I am involved in. To the best of my knowledge, this issue is still open.
Comment 10 FiNeX 2008-12-31 14:51:32 UTC
If the wish is about "adding a general webmail support", I think it is insane, it should be better add a freepopsd support. If the wish is adding a "gmail support", we can close this bug because now gmail supports POP and IMAP.
Comment 11 Björn Ruberg 2009-12-20 00:00:35 UTC
This must be implemented in its own libarys that can be used by different mail frontend software