Bug 85715 - KWin::setSavedConfig(WId id, bool save);
Summary: KWin::setSavedConfig(WId id, bool save);
Status: RESOLVED DUPLICATE of bug 15329
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Mandrake RPMs Linux
: HI wishlist with 2 votes (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-07-22 20:35 UTC by Sebastien
Modified: 2005-01-25 12:52 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastien 2004-07-22 20:35:08 UTC
Version:            (using KDE KDE 3.2.1)
Installed from:    Mandrake RPMs

Don't know if the bug should be in KWin or kdelib package.

It's merly frequent that some applications windows should save theire position ! For example : Kopete contactList or BasKet... perhapse JuK, KNote notes windows...

For that, every app that should remember position are obliged to code by themeselve the memorization and restoring of the position. Plus some hacks to override smart window placement.

I find it uggly, the user can check by herself the "Save window configuration" in Advanced submenu of the window title menu.

But some users do not know it and ask me (or author of other applications like Kopete) to code it myself :-/
I also dislike this solution because I should then code to remember on which desktop the window is, in KDE 3.2 if the window is above or below... And I don't take in account the future innovations... and the user is obligated to have the window position saved.

==>> Solution :

Instead of that the user must know and activate "Save window configuration", I would want to check this option programatically.

It's simple, remove A LOT of code redondancy / hacks / perhapse not well implemented algo...

It could even be presented as an option in the applications Settings dialog, or only aplied on the first start, so user is free to disabled it if he want (compared to the hardcoded thing it's better)...

A KWin::setSavedConfig(WId id, bool save); would be fine !

What about that solution ?
Comment 1 Lubos Lunak 2004-08-04 17:21:49 UTC
Noted down in my discussion todo list for aKademy.
Comment 2 Sebastien 2004-08-27 21:00:20 UTC
Why was you needed to talk about that on aKademy?
I've read anywhere that it was to make all KWin calls WM independant.
Do you mean it is possible? The class would then test the running of KWin, send it to KWin if it is running and "emulating" the call for other WM?
Then (if it is that), the "Save settings for this window" will work on every WM, and developers wouldn't to bother to code it by themselfs for users that do not use KWin...

Really good think (code duplication then reduced a lot), if I don't dream ;-)
Comment 3 Lubos Lunak 2005-01-25 12:52:17 UTC

*** This bug has been marked as a duplicate of 15329 ***