Bug 81778 - KMail should not always reply to mailing lists by default
Summary: KMail should not always reply to mailing lists by default
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail2
Classification: Applications
Component: composer (show other bugs)
Version: 5.4.0
Platform: Debian testing Linux
: NOR normal with 40 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-05-18 03:33 UTC by peter
Modified: 2019-08-15 04:33 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
List-Post and no Reply-To (4.64 KB, message/rfc822)
2019-07-11 01:20 UTC, gjditchfield
Details
List-Post and Reply-To (5.15 KB, message/rfc822)
2019-07-11 01:21 UTC, gjditchfield
Details

Note You need to log in before you can comment on or make changes to this bug.
Description peter 2004-05-18 03:33:49 UTC
Version:            (using KDE KDE 3.2.2)
Installed from:    Debian testing/unstable Packages
OS:                Linux

KMail seems to have the somewhat strange policy of always replying to a List-Post address in preference to the From address of a message.

For example, I received a message with the following headers in my Inbox (which is not associated with a mailing list).

From: someone@trinity.unimelb.edu.au
Sender: alist-admin@trinity.unimelb.edu.au
List-Post: <mailto:alist@trinity.unimelb.edu.au>
(no Reply-To header)

alist is a mailman mailing list, so the List-Post header is added whether you want it to be or not.

However, the list in question is not a public posting list - it's a list that sends mail to all students. It's very embarassing when the default action of clicking 'reply' is to send a mail message to the list. Reply to Author behaves as I expect here, as does Reply to Mailing List, just the wrong one is the default.

Could the default behaviour for Reply please be changed or at least made configurable? I think it is not a good behaviour for kmail to reply to lists that should not be posted to.
Comment 1 Tom Albers 2004-10-30 22:42:20 UTC
In most cases a reply should be send to the mailinglist. This is the way most mailinglists work. You should ask the system administrator to set a different address. You can also assign a shortcut to the 'reply to sender' action. I'll close this as invalid, because KMail is correct here.
Comment 2 Magnus Holmgren 2006-12-04 00:03:26 UTC
The advantage of KMail over most MUAs is that it has a Reply to List command at all. It's easy enough to use that. I don't think it's necessary to make the standard Reply command reply to the list (it should, IMHO, address mail to the Mail-Reply-To, Reply-To, or From address, while the Reply to List command should address mail to the Mail-Follow-Up or List-Post address. Reply to Author should bypass Reply-To and send to the From address in case the mail is from a list that munges the Reply-To field.
Comment 3 A S Alam 2007-03-31 04:15:16 UTC
I am facing same behaviour, but even strange, filing new bug for this as it is closed
New bug:
https://bugs.kde.org/show_bug.cgi?id=143651
Comment 4 Matt Blissett 2007-10-24 01:59:22 UTC
"In most cases a reply should be send to the mailinglist."
That's for the list admin to decide, not KMail's defaults.  "Reply" should reply to the "Reply to" address, or the "From" address if there isn't one.  If the list admin wants replies to go to the list, he can add a Reply-To header to every email -- Mailman includes this option for instance.
Comment 5 Jacques-Louis KREISS 2008-12-13 20:38:45 UTC
I think kmail should not reply to list when not told so by a "Reply-to" header.
It appeard to me as a non-standard behaviour, and is causing problems for one-way only mailing lists.
Comment 6 Philipp A. 2015-12-23 10:19:28 UTC
reopening, as mailing lists can be configured to use the “Reply-To” header, and this is the only way to signal that responses shouldn’t go to the “From” address
Comment 7 silentz0r 2016-02-22 20:20:55 UTC
Exactly as Phil mentioned, the Reply-To header should be used to reply. Reply All would cover the "From" address anyway, no?
Comment 8 Denis Kurz 2017-01-13 17:54:12 UTC
Is this still a thing? No commenter mentioned the KMail version she experienced this with. In particular, is the bug still valid for version 5.0 or later (a.k.a. 15.08.0 or later)?

I also migrated the bug to the kmail2 tracker. I sure hope that in 2016, noone still used kmail(1).
Comment 9 silentz0r 2017-01-13 18:01:59 UTC
(In reply to Denis Kurz from comment #8)
> Is this still a thing? No commenter mentioned the KMail version she
> experienced this with. In particular, is the bug still valid for version 5.0
> or later (a.k.a. 15.08.0 or later)?
> 
> I also migrated the bug to the kmail2 tracker. I sure hope that in 2016,
> noone still used kmail(1).

This is still a thing. As Phil Schaf mentioned mailing lists have the "Reply-To" header which should be used instead of the "From" header when replying on mailing lists.
Comment 10 silentz0r 2017-01-13 18:03:57 UTC
(In reply to silentz0r from comment #9)
> (In reply to Denis Kurz from comment #8)
> > Is this still a thing? No commenter mentioned the KMail version she
> > experienced this with. In particular, is the bug still valid for version 5.0
> > or later (a.k.a. 15.08.0 or later)?
> > 
> > I also migrated the bug to the kmail2 tracker. I sure hope that in 2016,
> > noone still used kmail(1).
> 
> This is still a thing. As Phil Schaf mentioned mailing lists have the
> "Reply-To" header which should be used instead of the "From" header when
> replying on mailing lists.

To make this response clearer, Reply and Reply-All are two different actions. Reply should reply to the person who sent the email (found in Reply-To header), whereas Reply-All should reply to the mailing list.
Comment 11 Denis Kurz 2017-01-13 18:06:48 UTC
I'm sorry, my question was ambiguous. What I meant was: does a reasonably recent version of KMail still misbehave in this regard? What version did you experience this with?
Comment 12 silentz0r 2017-01-13 18:16:47 UTC
(In reply to Denis Kurz from comment #11)
> I'm sorry, my question was ambiguous. What I meant was: does a reasonably
> recent version of KMail still misbehave in this regard? What version did you
> experience this with?

Yes, it's still a thing in 5.4.1 which is only a few weeks/month old I believe.

To reproduce: go to an email that's sent from a mailing list and press the default "R" key to reply, and you'll notice that the "From" field is populated by the mailing list instead of the person who sent it ("A" which stands for Reply All also does the exact same thing). The original email's Reply-To header is set properly to the specific person's email address, so this is definitely a KMail issue. At the moment you can achieve this by pressing "Shift+A" which is bound as "Reply to Author". The argument of this ticket is that Reply action means reply to sender, and there's a very specific header for that action called (Reply-To).
Comment 13 Denis Kurz 2017-01-13 19:19:15 UTC
I can only find mailing list messages where the reply-to field is set to the mailinglist address, so I cannot test this myself. Doesn't matter, though, since you obviously know what you're talking about. I set it to confirmed.
Comment 14 gjditchfield 2019-07-11 01:20:02 UTC
Created attachment 121458 [details]
List-Post and no Reply-To
Comment 15 gjditchfield 2019-07-11 01:21:44 UTC
Created attachment 121459 [details]
List-Post and Reply-To
Comment 16 gjditchfield 2019-07-11 02:02:10 UTC
I attached two messages for test cases, one that fails and one that passes.

"List-Post and Reply-To" contains a List-Post header with a mailing list address and a Reply-To header with a different address.  That is the test case that Denis Kurz needed in comment 13.  Using Kmail 5.7.3, when I select that message and press the "Reply" button, the reply's To address is set to the reply-to address, not the list's address, so this bug is fixed for that case.

The attachment "List-Post and no Reply-To" matches the original problem reported by Peter, 15 years ago.  It contains a List-Post header with a mailing list address, a Sender header with a different address, a From header with a third address, and no Reply-To header.  When I reply to it, the reply's To addresses are set to the original To and CC addresses, not the From address!  This behavior is different from the original report, but it is still incorrect.
Comment 17 gjditchfield 2019-07-16 18:14:06 UTC
Correction:  the message in attachment "List-Post and Reply-To" has a "Mail-followup-to" header, and KMail 5.7.3 sets the "To" address to that, as it should.

As far as I can tell, KMail no longer has this bug. Does anyone know of a case where replies to lists are handled incorrectly?
Comment 18 Bug Janitor Service 2019-07-31 04:33:09 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 19 Bug Janitor Service 2019-08-15 04:33:09 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!