Bug 81463 - "smart" window placement isn't
Summary: "smart" window placement isn't
Status: RESOLVED DUPLICATE of bug 15329
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-05-13 00:24 UTC by Jarne Cook
Modified: 2004-05-13 11:27 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jarne Cook 2004-05-13 00:24:33 UTC
Version:           unknown (using KDE 3.2.2,  (testing/unstable))
Compiler:          gcc version 3.3.3 (Debian 20040401)
OS:                Linux (i686) release 2.6.5

Background... I have no windows on the desktop.  I fire up kontact.  Window placement is set to "smart" thus the windows ends up @ 0,0.  That's crap so i move it near the centre of the screen.  I close it, and fire it back up again ... and the damn thing is back at 0,0.  

When a user moves an automaticly positioned window the offset (and maybe the size) should be remembered and restored for next time.  If the offset and size make the window appear of screen (maybe the desktop size has changed) then the setting should be scrapped and auto placement used.

Personally i would have expected that to be an implicit part of a kapplication.

Now in the case of image viewers and whatever.  If an existing window already exists it'd prob be nice to stagger additional ones so that they do not confuse the general user out their.  (as every day goes by i realize I will never completely comprehend the stupidity and lack of clue of "normal" users. The pain)
Comment 1 Lubos Lunak 2004-05-13 11:27:41 UTC

*** This bug has been marked as a duplicate of 15329 ***