Bug 81281 - url is truncated by click-to-open
Summary: url is truncated by click-to-open
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: messageviewer (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 104749 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-05-10 21:15 UTC by brian
Modified: 2007-09-14 12:17 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description brian 2004-05-10 21:15:23 UTC
Version:            (using KDE KDE 3.2.1)
Installed from:    Gentoo Packages
Compiler:          gcc 3.3.2 
OS:                Linux

I just received a ticket from Bugzilla so I could login in to close another bug!

The url was http://bugs.kde.org/token.cgi?a=cfmpw&t=Ukn1E_o-

But click to open lost the trailing ´-´
Comment 1 Andreas Gungl 2005-06-12 22:17:51 UTC
Seems like a problem in KHTML, Konqueror shows the same problem when looking at this report.
Comment 2 Jonathan Marten 2006-10-28 18:44:03 UTC
KDE-PIM bugs day:  confirmed.  Forward the URL above and view in kmail -> final character is missing.
Comment 3 Jonathan Marten 2006-10-29 15:47:36 UTC
*** Bug 104749 has been marked as a duplicate of this bug. ***
Comment 4 Jonathan Marten 2006-11-01 11:51:00 UTC
SVN commit 600917 by marten:

Correctly detect a URL that ends with '-' or '_'

BUG: 81281
CCMAIL: kmail-devel@kde.org



 M  +2 -2      branches/work/kdepim-3.5.5+/libkdepim/linklocator.cpp  


--- branches/work/kdepim-3.5.5+/libkdepim/linklocator.cpp #600916:600917
@@ -96,8 +96,8 @@
     {
       ++mPos;
     }
-    /* some URLs really end with:  # / &     */
-    const QString allowedSpecialChars = QString("#/&");
+    /* some URLs really end with:  # / & - _    */
+    const QString allowedSpecialChars = QString("#/&-_");
     while(mPos > start && mText[mPos-1].isPunct() &&
 		    allowedSpecialChars.find(mText[mPos-1]) == -1 )
     {
Comment 5 Allen Winter 2006-11-01 16:43:23 UTC
SVN commit 600981 by winterz:

merge SVN commit 600917 by marten:

Correctly detect a URL that ends with '-' or '_'

CCBUGS: 81281



 M  +2 -2      linklocator.cpp  


--- branches/KDE/3.5/kdepim/libkdepim/linklocator.cpp #600980:600981
@@ -96,8 +96,8 @@
     {
       ++mPos;
     }
-    /* some URLs really end with:  # / &     */
-    const QString allowedSpecialChars = QString("#/&");
+    /* some URLs really end with:  # / & - _    */
+    const QString allowedSpecialChars = QString("#/&-_");
     while(mPos > start && mText[mPos-1].isPunct() &&
 		    allowedSpecialChars.find(mText[mPos-1]) == -1 )
     {