Bug 81001 - sorting threads by date of newest message
Summary: sorting threads by date of newest message
Status: RESOLVED DUPLICATE of bug 32400
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist with 10 votes (vote)
Target Milestone: ---
Assignee: Till Adam
URL:
Keywords:
: 75603 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-05-05 23:24 UTC by Till Maas
Modified: 2008-06-06 19:20 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Till Maas 2004-05-05 23:24:07 UTC
Version:            (using KDE KDE 3.2.1)
Installed from:    Gentoo Packages
OS:          Linux

I wish kmail would sort threads by the date of the newest message in there and not by the date of the first message of the thread. The way it is, new messages in threads aren't on top of the list (I selected newest messages on top as order).
Comment 1 Marek Wawrzyczny 2004-06-25 04:37:26 UTC
I think the problem here is that a thread adopts the date/time of the first message sent (oldest message). It should in fact adopt the date/time of the last message sent to it (newest message). That way, a thread that has a new message will be moved to the top of a list sorted by newest date/time.

This would really help views which utilize the "thread view". At the moment, as a user, I find it difficult to see which threads have new messages.
Comment 2 Till Adam 2004-06-25 09:26:23 UTC
Agree with you two and this is a TODO of mine. I could have sworn I've seen another bug report about this, but I can't seem to find it right this minute.
Comment 3 Tom Albers 2004-06-25 09:32:47 UTC
*** Bug 75603 has been marked as a duplicate of this bug. ***
Comment 4 gnomeking 2004-07-13 00:05:50 UTC
*voted*

I'm very keen for this behaviour to be changed too :)
Comment 5 Michael Jahn 2004-07-26 21:59:27 UTC
till: found two :-)
The other one is bug 43104. 

*** This bug has been marked as a duplicate of 32400 ***
Comment 6 premierSullivan 2008-06-06 19:20:23 UTC
I have this problem too