Bug 43104 - Inverse thread grouping + sorting order
Summary: Inverse thread grouping + sorting order
Status: RESOLVED DUPLICATE of bug 32400
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.4.1
Platform: OpenSUSE Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-05-26 18:18 UTC by Andreas Hochsteger
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Hochsteger 2002-05-26 18:11:16 UTC
(*** This bug was imported into bugs.kde.org ***)

Package:           kmail
Version:           1.4.1 (using KDE 3.0.1 )
Severity:          wishlist
Installed from:    SuSE
Compiler:          gcc version 2.95.3 20010315 (SuSE)
OS:                Linux (i686) release 2.4.18-4GB
OS/Compiler notes: 

If you have subscribed to mailing lists you probably know this problem:
A thread gets very long and it gets harder and harder to keep track of new postings. It moves out of the visible area because the original post was done quite some time ago.

I've got two suggestions which could help with this problem:
1. (Optionally) sort threads by the time of the last reply.

2. Support an 'inverse grouping' view mode which sorts threads after the last post of a thread too but additionaly inverses the thread tree. This way you only have the most up-to-date replys first and navigate deeper only if you're interested in older postings to that thread. 

I'd like the second approach best though the only problem about it is that an inverse tree has not just one root node. This could be solved by providing a dummy root entry which takes the name of the thread and the number of unread messages in parenthesis. Just like the folder view does ist.
Additionally this thread-folder should be shown bold if there is at least one unread message in the thread.

Example:
+ Thread name (2) | Original poster | Date of last posting
| + Re: Thread name | poster | date
| | + Thread name | original poster | date of original posting

(Hope this comes through unchanged)

This would help very much to keep track of postings in mailing lists.

Thanks
Andreas


(Submitted via bugs.kde.org)
(Called from KBugReport dialog)
Comment 1 Datschge 2003-08-12 00:15:59 UTC
I think approach two would be very unintuitive and confusing since it's a 
non-obvious behavior. Unless there's more support for approach two I consider 
this report a duplicate of bug 32400 since imo approach one is more feasible. 
[dg] 
Comment 2 Michael Jahn 2004-07-26 22:05:06 UTC

*** This bug has been marked as a duplicate of 32400 ***