Bug 80196 - Sending window to background keeps it active
Summary: Sending window to background keeps it active
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist with 1 vote (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 123534 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-04-23 14:11 UTC by Wilbert Berendsen
Modified: 2012-03-10 20:24 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wilbert Berendsen 2004-04-23 14:11:19 UTC
Version:           onbekend (using KDE 3.2.2, Gentoo)
Compiler:          gcc version 3.3.2 20031218 (Gentoo Linux 3.3.2-r5, propolice-3.3-7)
OS:          Linux (i686) release 2.6.4-ck2

When I have multiple maximazed windows, e.g. Kontact, OpenOffice.org, KStars, Konqueror, I often middleclick the titlebars as a way to cycle around them (bringing the foremost window to the background).

However, when I bring the foremost window to the background, it keeps keyboard focus. The expected behaviour would be that the focus would change to the window the pointer is now in.
Comment 1 Lubos Lunak 2004-04-23 15:20:45 UTC
It's the intended behaviour of the lower operation that it only lowers and doesn't affect the activity of the window. If you want the new window to become active, simply click it.
Comment 2 Jan Essert 2005-02-06 13:09:05 UTC
The problem is: if you have 'sloppy focus' activated, you have to move the mouse out of the window and back into, which is really annoying.
If you want to keep the 'lower operation' as it is, perhaps you could create a new action: 'lower window and activate underlying' or sth like this?
Comment 3 Christian Reiser 2005-07-14 09:27:06 UTC
The current behavior is really annoying - maybe intended but not expected by the user. I cannot think of a situation, where it makes sense...
Comment 4 Lubos Lunak 2005-08-15 18:29:12 UTC
I'll reconsider this.
Comment 5 Lubos Lunak 2007-06-04 13:11:28 UTC
*** Bug 123534 has been marked as a duplicate of this bug. ***
Comment 6 Martin Flöser 2012-03-10 19:32:50 UTC
The idea behind lower is to keep the window active. While I understand your need I am sorry to say that this feature is too little known by our user base to justify further extending the functionality.

Because of that I think it is the most honest thing to say that we won't fix the request. I want to thank you for your suggestion and I am sorry that we were not able to implement the request.

In the current development version of KWin we have JavaScript bindings and I am very open to extend it if you need additions. I could imagine that a script could be written which reacts on the lower event and changes the active window to the uncovered window.
Comment 7 Thomas Lübking 2012-03-10 20:24:25 UTC
actually this was resolved for bug #182146 what consequently lead to bug #255052 and affected bug #80987
the regarding commits should have brought it under control, considering invocation (shortcut/mouse), focus model and mouse ./. focus chain preference.

should be fixed.