Bug 78575 - Cache is 2x slower than normal page load
Summary: Cache is 2x slower than normal page load
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: khtml (show other bugs)
Version: unspecified
Platform: Mandrake RPMs Linux
: NOR normal with 21 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 61290 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-03-27 20:37 UTC by Samuel Allen
Modified: 2008-01-14 19:39 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Javascript-timer testcase (118.41 KB, text/html)
2004-03-28 23:57 UTC, Samuel Allen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Allen 2004-03-27 20:37:07 UTC
Version:            (using KDE KDE 3.2.1)
Installed from:    Mandrake RPMs
OS:          Linux

I have been testing the performance of various browsers for Linux and have found Konqueror to be the fastest loading a page initially, either from the network or from the hard disk. However, the back/forward performance is considerably slower than Firefox or Mozilla. My recorded times indicate that it takes twice the time for a page to be loaded when going back or forward to it than it does for it to be loaded initially.

I have timed this both using a stopwatch and using javascript timers and the results are consistent. For one example page, Konqueror requires 2 seconds to load the page off the hard disk the first time. If you open another page and go back to the test page, it takes 4 seconds for the page to finish loading. I have reproduced this on pages of all sizes, from 1k to 3MB.

I have noted this behavior on two different Linux boxes, using Mandrake or Knoppix. I would appreciate it if someone could tell me if this is a bug, or a misconfiguration, and whether it can be fixed.
Comment 1 Sashmit Bhaduri 2004-03-28 18:00:45 UTC
Can you attach a test page w/ JS timers?
Comment 2 Samuel Allen 2004-03-28 23:57:00 UTC
Created attachment 5451 [details]
Javascript-timer testcase

Go back or forward to the page to see the time difference from the initial load
Comment 3 Samuel Allen 2004-03-29 00:00:38 UTC
Hmm, I think you need to save the testcase to the hard disk so the initial time isn't mostly spent in downloading the file.
Comment 4 Samuel Allen 2004-06-04 08:34:04 UTC
Has anyone been able to reproduce this? I can still reproduce it on my Fedora Core 2 box. This bug ruins KHTML performance on back and forward, and makes Konqueror much slower than Mozilla. I have spent a few minutes looking at the code, but if someone could point me in the right direction that would be great.
Comment 5 Rex Dieter 2004-06-04 16:05:01 UTC
Confirmed, kde-3.2.2, rh80.  Initial load time on my box was .08 seconds, onreload (or forward/back) 0.44 seconds
Comment 6 Leo Spalteholz 2005-02-03 06:12:22 UTC
Confirmed.  KDE 3.3.2 Debian unstable on Althon XP 1600+
Initial load time: 0.10s
Hitting refresh: 0.10s
Going back to or forward to the page: 0.39s

Strange.  I've noticed that konqueror's back performance is quite poor sometimes but I've never thought about it before.
Comment 7 Germain Garand 2005-02-05 12:28:09 UTC
CVS commit by ggarand: 

no need to delay chunks that much
BUG: 78575


  M +1 -1      khtml_pagecache.cpp   1.21


--- kdelibs/khtml/khtml_pagecache.cpp  #1.20:1.21
@@ -266,5 +266,5 @@ KHTMLPageCache::sendData()
      d->delivery.append( delivery );
   }
-  QTimer::singleShot(20, this, SLOT(sendData()));
+  QTimer::singleShot(0, this, SLOT(sendData()));
 }
 


Comment 8 Tommi Tervo 2005-02-18 09:05:37 UTC
*** Bug 61290 has been marked as a duplicate of this bug. ***
Comment 9 Filip 2005-07-16 23:31:01 UTC
hi, I have similar experiences with hitting back/forward in konqueror.  On a comparision of browsers a few months ago, i read that safari 2.0 was a lot faster on this issue compared to konqi.  So maybe there are some easy fixes/optimalisations to be found in the recently opened CVS history of webkit?  Or maybe some mac-developers can explain in 10 minutes what their main changes were on this issue...?
Comment 10 Filip 2005-07-17 00:21:10 UTC
the comparision is on http://www.howtocreate.co.uk/browserSpeed.html , if that might help.  It's using konqueror 3.2 but I still have the same experience with 3.4
Filip
Comment 11 Simon Becker 2008-01-14 19:39:46 UTC
I can confirm it, but it does not only affect reloading a page, rendering a page is inacceptably slow. Even if a simply built web-interface to setup the internet router is this slow.
This error exists already, as long as I use KDE 3.x, it is finally time to increase speed. I used it on different boxes; all the same: arch, crux and debian.