Bug 61290 - Please make "back" button quicker
Summary: Please make "back" button quicker
Status: RESOLVED DUPLICATE of bug 78575
Alias: None
Product: konqueror
Classification: Applications
Component: khtml (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist with 147 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-07-15 20:22 UTC by Erik Schnetter
Modified: 2005-02-18 09:05 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Schnetter 2003-07-15 20:22:41 UTC
Version:           unknown (using KDE 3.1.2)
Installed from:     (testing/unstable)
Compiler:          gcc version 3.3.1 20030626 (Debian prerelease)
OS:          Linux (i686) release 2.4.21-2-686

I notice that the back button makes Konqueror re-build the page, which can take a good fraction (or more) of a second.  Changing between tabs is much faster.  It would be nice if Konqueror saved the previous few pages in a way similar to "hidden tabs", so that it could switch back and forth much quicker.

This is especially important if one wants to read the gcc mailing list archive.  The mail subjects are presented in a huge page (which takes long to build), and one switches forth and back to and from individual mails.
Comment 1 Erik Schnetter 2004-05-10 21:15:36 UTC
KDE 3.2.2 still reloads the page.
Comment 2 Yves Glodt 2004-06-14 22:14:42 UTC
Opera e.g. just shows the cached page when you hit "Back" and doesn't reload it.

Well this is nice for speed, but OTOH if the page has meta-tags that force
a reload on each view, it's just a wrong behaviour.

IMHO the best would be that pages that don't wanna be cached, would be
reloaded on "Back", and all the other pages should be rendered from the
http-cache and not reloaded from the net.
Comment 3 Dik Takken 2004-07-06 15:11:16 UTC
There is another reason why the back button is slow: When you click the backbutton repeatedly, KDE thinks you are double-clicking and ignores the double-click. So, you cannot click faster than the configured double-click delay.

See Bug 62955, and vote.
Comment 4 Michael Jahn 2004-09-14 22:52:53 UTC
*** Bug has been marked as fixed ***.
Comment 5 Michael Jahn 2004-09-14 22:53:33 UTC
Stupid me. Sorry.
Comment 6 Michael Jahn 2004-09-14 22:54:14 UTC
...
Comment 7 Dik Takken 2004-09-15 10:48:28 UTC
I think you're right, this has been fixed in KDE 3.3. Right?
Comment 8 Michael Jahn 2004-09-15 14:52:25 UTC
I don't know. I accidentally closed this bug. I think it is faster than 3.2 but I might be wrong. But it is not as fast as switching tabs and I don't know if that is possible (me!=konq-dev), so I won't close this one.
Comment 9 Dik Takken 2004-09-15 23:51:46 UTC
Well, it's definitely not reloading the page, but it does do much more than just redrawing it. It can still take a few seconds to go back to a large page, while switching to it from another tab is instant.

Question is: What *is* KHTML doing when you press back?
Comment 10 Michael Jahn 2004-09-16 00:08:36 UTC
I think it is rerendering (not reloading) the page. I would think (not sure!!) if one wanted to fix this wish one would have save the rendered version of the page, which would make konqueror quite memory hogging.
Comment 11 Stephan Binner 2005-02-17 18:41:05 UTC
I read it's now quicker because some timers were changed to a shorter delay?
Comment 12 Tommi Tervo 2005-02-18 09:05:32 UTC

*** This bug has been marked as a duplicate of 78575 ***