Bug 78312 - No sound for system notifaications neither real nor as test in controlcenter. BUT: "Test sound" in controlcenter works, sound in general works. Mark in realtimepriority disappears.
Summary: No sound for system notifaications neither real nor as test in controlcenter....
Status: RESOLVED DUPLICATE of bug 69830
Alias: None
Product: kdelibs
Classification: Unclassified
Component: knotify (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Carsten Pfeiffer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-03-23 17:48 UTC by raberger.admin.wien
Modified: 2005-01-02 17:01 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description raberger.admin.wien 2004-03-23 17:48:06 UTC
Version:           arts 1.2.1 (using KDE KDE 3.2.1)
Installed from:    Compiled From Sources
Compiler:          gcc 3.2.3 
OS:          Linux

Although the sound system in Controlcenter is configured properly There is no sound at KDE start.
If I open Controlcenter - Soundsystem and press the Test sound butten sound is played as ofen I press the button.
All sound applications like kmidi, XMMS, KsCD work without any problem.
There is a process artsd running.
BUT:
I can get no sound for system notifaications.
If I open Controlcenter - System notification and test any sound (replaylevel is max) there happens absolutly nothing. Nothing but:The mark in realtimepriority disappears. And if I try to reset it I get "Der Start von aRts mit Echtzeit-Priorität ist nicht möglich, da das Programm "artswrapper" nicht vorhanden oder deaktiviert ist." (Start of arts in realtime impossible, because programm artswrapper is not there or deactivated) what is silly because of course artswrapper is there and of course is not deactivated. And who needs artswrapper when artsd is running?
If I try to start artswrapper in a console I get:
bash-2.05b$ /usr/kde/3.2/bin/artswrapper
can't register Arts::MidiManager
There are already artsd objects registered, looking if they are active...

Error: Can't add object reference (probably artsd is already running).
       If you are sure it is not already running, remove the relevant files:

       /tmp/mcop-xy/Arts_SoundServerV2
       /tmp/mcop-xy/Arts_SoundServer
       /tmp/mcop-xy/Arts_SimpleSoundServer
       /tmp/mcop-xy/Arts_PlayObjectFactory
       /tmp/mcop-xy/Arts_AudioManager

bash-2.05b$

Why it tries to register MidiManager is curious because such a file is just there like the others.
Deinstalling MIDI (timidity) does not change the situation, by the way MIDI works.

The problem arose with upgrade form arts 1.1.4 to 1.2.1 and kde 3.1.4 to 3.2.1.

Any ideas?
Comment 1 tswltd 2004-05-01 13:43:24 UTC
I have the exact same issue except my problem occured after I had to set artswapper suid in order to run realtime priority and after doing so lost all systems notifacations sounds.
Comment 2 Fred Wells 2004-05-07 05:08:55 UTC
I also have this problem after upgrade to kde3.2.2, but it's not every user.  For example, system notifications don't work for my wife, but they work fine for me.  As far as I can tell our sound settings are identical.  I corrected this problem earlier by removing her ~/.kde directory and starting over, which seemed to correct it for a while.  Any idea how to troubleshoot this?  I've tried running strace against artsd but that yields absolutely nothing useful that I can tell.
Comment 3 Marcelo Vivan Borro 2004-05-19 07:09:40 UTC
Exactly the same problem.  Bypassed it selecting artsplay as external player.  But there's a small delay on the sound.

Does anybody have another solution?
Comment 4 Marcelo Vivan Borro 2004-05-19 08:04:24 UTC
I've found the error!!  It's just a question of editing ~/.kde.share.config/knotifyrc

Your StartProgress section must be like this:

[StartProgress]
Arts Init=true
KNotify Init=true
Use Arts=true

The question is why kde don't change this automatically... 
Comment 5 Casey Allen Shobe 2004-07-10 21:20:05 UTC
kmidi no longer exists.
Comment 6 Stefan Gehn 2004-07-11 11:03:49 UTC
This is not a kmidi bug (and never was) but a knotify bug. And it doesn't look like it's fixed for everybody so I'll reopen it now.
Comment 7 Joe 2004-07-16 09:40:45 UTC
Same exact issue for me in SuSE 9.1, all was working well except after a few days no sound notifications work. I did exactly what the first person did and was able to replicate the issue. I found that the realtime checkmark will disappear after trying to test a notification sound. Using KDE 3.2.1. Also, using XMMS pluggin for arts works fine, no issues or clicks.
Comment 8 David 2004-09-28 03:05:28 UTC
Had the same problem with having to manually edit knotifyrc. This is still an issue with kde 3.2 and 3.3 . 

Just like poster, all sounds work with alsa except for system notifications. Edit the knotifyrc file and system notifications start working again. 
Comment 9 MaxAuthority 2004-11-04 19:28:49 UTC
Thanks, editing knotifyrc also worked for me.

Sound stopped playing for notifications, after I disabled "Enable sound system", and then enabled it later on again, so this is probably the source of the bug.
Comment 10 Stephan Binner 2005-01-02 14:05:09 UTC

*** This bug has been marked as a duplicate of 69830 ***
Comment 11 David Aldred 2005-01-02 15:21:36 UTC
Having just looked at 69830 I'm far from sure this is a duplicate.   I have had this issue even with the correct ('true') settings in the StartProgress section of knotifyrc, and I had at no time disabled and re-enabled notification sounds.  If you have evidence that the two are related - despite the conditions noted in 69830 not being met - then please identify why as this may help people resolve the problem. 
Comment 12 Stephan Binner 2005-01-02 16:46:10 UTC
> Having just looked at 69830 I'm far from sure this is a duplicate. 

Sorry, in which previous comment did *you* comment on this bug?

> I have had this issue even with the correct ('true') settings in the StartProgress section of knotifyrc

Then your problem may not match this report and it's another source of problem. Please file another bug report then and don't mix several problems within one.

>  please identify why as this may help people resolve the problem.

I can only conclude from *existing* comments and they say that it does.
Comment 13 David Aldred 2005-01-02 16:53:54 UTC
I hadn't previously added a comment since my situation was exactly as described above - doesn't seem much point in  simple 'me2'.  

It's not what's described on the other bug, though, as the situation on this one isn't related to disabling notifications then re-enabling them, which is what's described on bug 69830.  The two /may/ be related, but there does seem to be a significant difference. 
Comment 14 Stephan Binner 2005-01-02 17:01:04 UTC
> I hadn't previously added a comment since my situation was exactly as described above

One can also comment on the proposed solutions/work-arounds. ;-)

> there does seem to be a significant difference

Tell us about the difference to "all sounds but knotify works". :-)