Bug 78159 - don't expire important threads
Summary: don't expire important threads
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.6.1
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 139188 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-03-21 19:12 UTC by Felix Berger
Modified: 2007-09-14 12:17 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Berger 2004-03-21 19:12:34 UTC
Version:           1.6.1 (using KDE 3.2.1,  (testing/unstable))
Compiler:          gcc version 3.3.3 (Debian)
OS:          Linux (i686) release 2.4.21-rc1

It would be a great feature to not expire messages and whole threads which are specially marked:

Either add an extra marker like: "Never Expire Message" and "Never Expire Thread"
or change the Important Marker's semantics.

Thus one could mark one's own threads in mailing list folders as "Never Expire" and let the rest expire gracefully.

I had a look at maildirjob.cpp and it doesn't seem difficult to implement for messages. How it would be done for whole threads I don't know.

Sincerely,
Felix Berger
Comment 1 Till Adam 2004-03-21 19:45:50 UTC
Implemented in head. Settings -> Misc -> Exclude important messages from 
expiry. :)

Comment 2 Damir Perisa 2005-10-17 20:53:29 UTC
would it be possible to also be able to configure kmail that the whole thread to not expire, if one message is marked somehow special? especially in discussions on high-frequency mailinglists (like kernel mailinglist) it is useful to have this.

if needed, i can also open a new wish, but i think, because it's related to this one, i can recycle it - saving the environment ;-)
Comment 3 David Faure 2005-10-17 22:48:55 UTC
Right, the "exclude important" thing is only for messages, not for entire threads (afaik), so this wish can't really be closed yet.
Comment 4 Damir Perisa 2005-10-17 23:00:39 UTC
may i suggest, that we enhance this not only to "important" threads but define it a little bit more general:

do not expire threads, that contain messages marked as "important", "todo", "new"

the important is logically explained, the todo because this way, it would help also making todo's from folders with a mailinglist that is filling and emptying but the thread that todo is related stays as long it is not solved. the new i'm not yet sure, so maybe it is not essentially needed for "new" to be kept.
Comment 5 Bram Schoenmakers 2006-12-24 00:35:32 UTC
*** Bug 139188 has been marked as a duplicate of this bug. ***
Comment 6 Bram Schoenmakers 2006-12-24 13:21:51 UTC
Todo messages won't expire in KDE 3.5.6.

If you don't want to expire "new" messages, just disable that in the Expiry dialog of that folder.