Bug 74958 - no sounds from any multimediaprograms
Summary: no sounds from any multimediaprograms
Status: RESOLVED DUPLICATE of bug 69830
Alias: None
Product: kdelibs
Classification: Unclassified
Component: knotify (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Carsten Pfeiffer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-02-11 16:13 UTC by Sten Malmlund
Modified: 2005-01-02 14:01 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sten Malmlund 2004-02-11 16:13:21 UTC
Version:            (using KDE KDE 3.2.0)
Installed from:    Compiled From Sources
OS:          Linux

I installed kde 3.2 on a Suse 9.0 Linux platform with kernel version 2.4.21-166-athlon, machine i686. Former I had kde version 3.1.4. Now there are no sounds on my machine. There was a knotify-crash message when I started kde 3.2, and after that a questionbox, which allowed me to choose between unabling arts or continue to get the alarms from knotify rash. I chose disablig arts and now there's no sound. I mean no system sounds, no sounds from any multimediaprograms. What should I do?
Comment 1 Stephan Kulow 2004-02-11 20:14:27 UTC
for one thing: keep summaries short
Comment 2 Stefan Gehn 2004-02-11 20:30:07 UTC
if you have turned artsd off then you won't have sound in most kde apps because artsd is the standard soundserver kde ships with.
Try turning it on again in the control center and check the "test sound" button there as well.
Comment 3 Sten Malmlund 2004-02-11 21:41:25 UTC
I have turned it on, and from the process table i can see that artsd is 
running. Still no sound. If I kill knotify, still no sound. Here, by the 
  way is the exact dialog, where it is asked whether I want to disable arts:

"During the previous startup, KNotify crashed while instantiating 
KNotify. Do you want to try again or disable aRts sound output?"


Sten Malmlund                     http://www.helsinki.fi/~malmlund
3. linja 1 C 55                   sten.malmlund(at)pp.htv.fi
00530 HELSINKI                    sten.malmlund(at)helsinki.fi
FINLAND                           +358-(0)50-535 9826


Stefan Gehn wrote:
> ------- You are receiving this mail because: -------
> You reported the bug, or are watching the reporter.
>       
> http://bugs.kde.org/show_bug.cgi?id=74958      
> 
> 
> 
> 
> ------- Additional Comments From mETz81@web.de  2004-02-11 20:30 -------
> if you have turned artsd off then you won't have sound in most kde apps because artsd is the standard soundserver kde ships with.
> Try turning it on again in the control center and check the "test sound" button there as well.

Comment 4 Arnold Krille 2004-03-26 18:16:33 UTC
You have to edit .kde/share/config/knotifyrc and change the lines with "Arts Init=<something>" and "Use Arts=<something>" to "Arts Init=true" and "Use Arts=true".

Maybe this bug should be reassigned to knotify?

Arnold
Comment 5 Stephan Binner 2005-01-02 14:01:05 UTC

*** This bug has been marked as a duplicate of 69830 ***