Bug 71929 - "Automatically select icons" should only be enabled for icons, delay default should be longer
Summary: "Automatically select icons" should only be enabled for icons, delay default ...
Status: RESOLVED DUPLICATE of bug 135633
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal with 50 votes (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-01-05 20:17 UTC by Dominique Devriese
Modified: 2011-07-25 18:49 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Devriese 2004-01-05 20:17:25 UTC
Version:            (using KDE KDE 3.1.4)
Installed from:    Debian testing/unstable Packages

Hi,

This is a forward of the following Debian bug report:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=215678

When I enable "Automatically select icons" in KControl, this causes a hell of a lot of unexpected behaviour.  E.g. when opening Alt+f2, typing something, while the mouse is somewhere in the area occupied by the list of completion suggestions, this invariably causes some wrong suggestion to be selected.  Same thing ( unintended selection ) happens in a lot of other places, like KControl's list views etc.  This is broken behaviour, users do not expect to see this at all.  IMHO, the option should either be removed, or limited to selecting icons in KDesktop and Konqueror file view.  Also, the default delay is way too short, and should be increased a lot, currently the default is set to the lowest possible delay.

Frankly, I would suggest removing this option, it is not useful for the most people, it is badly named, badly described, causes confusion ( read the Debian bug I link to above ) etc.  At the least it should be removed from KControl, so that it can only be enabled with KConfEdit.

cheers
domi
Comment 1 Philippe Cloutier 2006-05-08 11:21:25 UTC
The wrong behavior you are describing appears to be fixed in KDE 3.3.2. Are you still able to reproduce with a current version?
Comment 2 munlinux 2006-05-21 15:45:35 UTC
The "Automatically select icons" would be a _very_ useful feature, since in a single-click-to-execute -environment this is the most useable way to select an icon. However, as stated in bug 95748's title, it should only do what it says: select _icons_.

Currently, in KDE 3.4.3., it affects for instance KDE kcontrol module menus, web page select boxes (NOTE: KDE bug tracking system is hard to use, because you have to avoid hitting any select boxes with your mouse to prevent the feature from selecting anything), and most probably also something else, as stated in the reports. Please seriously consider spending the effort to fix this.


KDE Bug Tracking System has this bug reported three times, for three different packages, and assigned to three different persons. The bug numbers are bug 45957, bug 71929, bug 95748. Please clarify the situation.
Comment 3 munlinux 2007-01-26 16:44:03 UTC
Still valid in KDE 3.5.5. I am copy-pasting this comment to the three separate reports, but I would much rather see a developer identify where exactly the bug is and unifying the information into one relevantly assigned bug report.
Comment 4 Christoph Feck 2011-07-25 18:49:10 UTC
As far as I know, the automatic icon selection feature has been removed from KDE 4, so it should no longer cause those problems. So also bug 135633.

*** This bug has been marked as a duplicate of bug 135633 ***