Bug 71434 - date boxes are too small in tools
Summary: date boxes are too small in tools
Status: RESOLVED WORKSFORME
Alias: None
Product: kstars
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kstars
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-12-29 15:26 UTC by gerard
Modified: 2006-01-12 10:53 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
impossible_to_move_the_separator_before_resizing_window.png (29.54 KB, image/png)
2003-12-31 18:51 UTC, gerard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gerard 2003-12-29 15:26:19 UTC
Version:           1.0 (using KDE 3.1.94 (CVS >= 20031206), compiled sources)
Compiler:          gcc version 3.3.1 (Mandrake Linux 9.2 3.3.1-2mdk)
OS:          Linux (i686) release 2.4.22-10mdk

In tools ->Calculators
->Time calculators->Day duration
	->Julian day
	->Sidereal time
->Coordinate converters
	->Apparent Coordinates
	->Horizontal Coordinates
The date boxes are too short, and I cannot see the last digit.

The vertical separator between the left and the right pane is impossible to resize when the whole window is not resized before

Thanks

Gerard
Comment 1 kstars 2003-12-31 18:22:40 UTC
I can't reproduce either of these bugs.  

I tried several different fonts and font sizes, and made the calculator window as small as I could.  In every case, the QDateEdit was always big enough to show the date.  This was with Qt 3.2.1.  What version of Qt are you running?

Likewise, I am always immediately able to move the QSlider separating the left and right panes of the calculator window.  Does it require a window resize every time you open the calculator window?

I suspect this may be a Qt issue, since we have not done anythihng special to these widgets.
Comment 2 gerard 2003-12-31 18:51:33 UTC
Subject: Re:  date boxes are too small in tools

Le mercredi 31 D
Comment 3 kstars 2003-12-31 19:06:26 UTC
The problem with the frozen slider is probably just that the calculator module being displayed cannot be made any smaller than its initial size.  Once you make the window wider, then there is room to move the slider.  I don't really consider this a bug.

If you make the calculator window wider, does the QDateWidget then display the full date string?  If so, then the fix will be to recompute the initial size of the calculator window.
Comment 4 gerard 2004-01-03 00:14:39 UTC
Subject: Re:  date boxes are too small in tools

Le mercredi 31 D
Comment 5 kstars 2004-01-03 18:28:30 UTC
Subject: RE:  date boxes are too small in tools         

>No. the qdate size does not grow.
>If I want to display the whole date, I must use arial 10 instead of 12,
which
>
>is very small.
>
>The size of the widget should take in account the size of what is actually
>
>displayed, or at least, a place a bit wider than now, in the hope nobody
>will
>use 16 or 18 fonts (don't forget about accessibility).
>
Right, but what I am saying is that what you describe is the behavior I
see on my system.  I can make the font size ridiculously large, and the
QDateEdit widget resizes itself correctly.  We haven't done anything special
to this widget, so again, I have no idea why it is not working correctly
for you.


Comment 6 gerard 2004-08-18 21:58:13 UTC
Seems working now (KDE 3.3.rc2) for the size of the date spinboxes.
The remaining (resizing only the left pane) is only a wish.

Thanks

Gerard
Comment 7 Shriramana Sharma 2006-01-12 10:53:11 UTC
This problem again visible with KStars 1.2 on KDE 3.5 on SUSE Linux 10.0. See attachment to bug 119963.