Bug 70852 - transferring ~4Gb file from ntfs -> vfat, file size ~16,777,216.0 TB
Summary: transferring ~4Gb file from ntfs -> vfat, file size ~16,777,216.0 TB
Status: RESOLVED UNMAINTAINED
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 67712 71200 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-12-19 16:06 UTC by Jarkko Haapalainen
Modified: 2009-09-14 00:57 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screen Shot (9 bytes, image/png)
2004-07-16 12:13 UTC, Michael Jahn
Details
Another smb:// huge file size (28.17 KB, image/png)
2006-11-13 22:13 UTC, Nicolas Ternisien
Details
Screenshot of reiser->reiser file transfer (147.92 KB, image/png)
2007-01-07 23:46 UTC, Zac Slade
Details
Transfering 3.9G File over SMB to local reiserfs (148.40 KB, image/png)
2007-01-09 02:45 UTC, Zac Slade
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jarkko Haapalainen 2003-12-19 16:06:33 UTC
Version:            (using KDE KDE 3.1.94)
Installed from:    Gentoo Packages
Compiler:          gcc version 3.2.3 20030422 (Gentoo Linux 1.4 3.2.3-r3, propolice) 
OS:          Linux

Started to transfer about 4,2Gb file from windows/ntfs partition to vfat partition. After ~2Gb transferred file size in window changed to ~16,777,216.0 TB.

Maybe this is vfat filesystem issue, i don't know but i guess you should now about this "minor" (?) bug.

Here is screenshot about this: http://tols17.oulu.fi/~jhaapala/kde3.2beta2/filetransfer1.jpg
Comment 1 Thiago Macieira 2003-12-19 17:39:07 UTC
Most surely a 32- and 64-bit mixup. There are a lot of reports in the bug tracking system of things like this, but they are very hard to identify.
Comment 2 Thiago Macieira 2003-12-25 05:59:38 UTC
To the reporter: do you get this only on ntfs -> vfat transfer, or do you get it in many other situations?
Comment 3 Jarkko Haapalainen 2003-12-26 14:58:15 UTC
More testing on this.. ntfs -> reiserfs and reiserfs -> reiserfs with same results. And after ~4Gb the progress bar started from the start (0%) and also other calculations: 0mb of 16..TB, 130mb of 16..TB and so on.

So there is a problem. File transfer is okay/successful.
Comment 4 Matt Rogers 2004-01-28 05:08:59 UTC
*** Bug 71200 has been marked as a duplicate of this bug. ***
Comment 5 Matt Rogers 2004-01-28 05:13:19 UTC
*** Bug 67712 has been marked as a duplicate of this bug. ***
Comment 6 Matt Rogers 2004-01-28 06:34:29 UTC
works for me. I transferred a 3GB file from reiserfs to FAT32 and didn't have a problem with the filesizes being wrong.
Comment 7 Andre Eisenbach 2004-02-27 11:44:39 UTC
This bug is *not* fixed in KDE 3.2. The problem still occurs. Screenshot upon request.
Comment 8 Michael Jahn 2004-07-16 12:11:46 UTC
I am reopening this. I just experienced this with HEAD. Copying a 4GB file via SMB from Windows XP to ~ results in the described behaviour at 2GB. 
samba (with libsmbclient) 3.0.4
Comment 9 Michael Jahn 2004-07-16 12:13:55 UTC
Created attachment 6695 [details]
Screen Shot
Comment 10 Stephan Kulow 2004-07-18 11:39:25 UTC
the PNG is corrupted. And smb:/ is a different bug - fixed too
Comment 11 Nicolas Ternisien 2006-11-13 22:11:57 UTC
As you can see in the screenshot, the bug still happens.

This time, it's a smb:// copy that displays this kind of huge file size.
Comment 12 Nicolas Ternisien 2006-11-13 22:13:16 UTC
Created attachment 18530 [details]
Another smb:// huge file size
Comment 13 Christophe Contant 2006-12-19 10:29:30 UTC
Same bug for me copying a 3.7 Go file with KDE 3.5.5 / openSuSE 10.2 / kernel 2.6.18.5-jen40b
FROM : samba on reiserfs  
TO : local on ext3
Comment 14 Zac Slade 2007-01-07 23:46:29 UTC
Created attachment 19171 [details]
Screenshot of reiser->reiser file transfer

Attached a screen shot showing a successful transfer of a 3.9 Gig file locally,
reiserfs3 to reiserfs3, on KDE 3.5.5 (Gentoo).
Comment 15 Zac Slade 2007-01-09 02:45:48 UTC
Created attachment 19202 [details]
Transfering 3.9G File over SMB to local reiserfs

This screenshot clearly shows the bug still exists in 3.5.5 for samba->local
file transfer.

This bug is confirmed.
Comment 16 JPD 2007-02-26 18:43:09 UTC
This bug exhibits itself using KFTPGrabber as well which should remove the FS specificity of it. The only thing to note is that it appears to be triggered well before 2GB of data, even 10-15MB triggers it for me. Could it be related to filecount as well ? It appears that the total filesize is miscalculated and as a result when the "data left to transfer" hits 0KB of data left, yet there is still more data to transfer, it drops into the 16'777'216.0 TB.
Screenshot also available on request.

JPD
Comment 17 FiNeX 2009-09-14 00:57:25 UTC
All reports about file management mode reported against KDE 3 (konqueror) has been closed: konqueror in KDE 3 is no more developed and mantained. All bugs and wishes which could be interesting for Dolphin in KDE 4 (the new KDE file manager) has been collected into a specific list.

Please try the new file manager before request new features and report bugs.

Before submitting new reports check carefully the already opened KDE/Dolphin reports in order not to add duplicates.

Many thanks.


P.S: I remember about this bug, it has been fixed a couple of years ago.