Bug 68732 - Disable automatic setting of Followup-To header for cross-posted articles
Summary: Disable automatic setting of Followup-To header for cross-posted articles
Status: RESOLVED UNMAINTAINED
Alias: None
Product: knode
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR wishlist with 212 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 113533 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-11-21 14:28 UTC by Tristan Miller
Modified: 2018-09-04 18:39 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Fix (4.29 KB, patch)
2006-02-02 23:11 UTC, Nick Leverton
Details
Bugfix (901 bytes, patch)
2008-04-06 17:51 UTC, Bodo Eggert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tristan Miller 2003-11-21 14:28:10 UTC
Version:            (using KDE KDE 3.1.4)
Installed from:    SuSE RPMs

When cross-posting to two or more groups, KNode always automatically selects the first group and inserts it into the Followup-To header.  Presumably this feature was implemented to prevent trolls and clueless newbies from disrupting Usenet with massive cross-posts.  For those of us long-term Usenet posters who actually know what we're doing, however, this behaviour is *extremely* annoying.  Cross-posting to a small number of carefully selected groups where the article is clearly relevant does not contravene established netiquette.

This feature is doubly annoying because even when the user goes to the trouble of removing KNode's default Followup-To header, upon trying to actually send the message, KNode pops up a warning window.  I think it's safe to say that if someone deliberately deleted the header, he doesn't need to be reminded of that fact two minutes later when he hits the submit button.

This feature is triply annoying because KNode will surreptitiously reinsert the deleted Followup-To header to articles saved as drafts when they are reopened for editing.  In this case the user must go out of his way to force the cross-posting not once, not twice, but three times before KNode will allow the message to be sent!

Please add an option in the configuration menu to disable this horrid, horrid feature.  It's a nice idea to leave it on by default, but please give those of us who know what we're doing a break and let us turn it off if we want.
Comment 1 Juliano F. Ravasi 2004-09-12 01:57:00 UTC
I'm not a KNode user, but I must state that this "feature" is kind of annoying for all other people also.

This is my scenario:
A reply was cross-posted to groups X and Y by a KNode user, which had Followup-to automatically set to group X. I (who read the ONLY group Y) reply to the message and don't notice the effect of Followup-To, which makes my newsreader send my message just to X. Then, I'll never read the replies to my message since I'm not subscribed to X.

Many KNode users I know don't figure this behavior of their client unless someone on the newsgroup calls their attention. Having a configuration option to disable this behavior is, IMHO, a must-have feature (and even if this behavior is still enabled by default, I'm sure that many (or even most?) users would disable it).
Comment 2 Leif Biberg Kristensen 2005-01-16 01:51:15 UTC
I completely agree with the other two guys. This is a kind of taking decisions away from the user that is totally unacceptable.

I could accept it if KNode warned me before sending the message that it had set follow-up to a specific group, but then it might as well warn me if I tried to post the message to more than one group, and leave the follow-up field alone.

It's actually considered bad behaviour on Usenet to set follow-up without  explicitly mentioning it in the message. Then, if you silently fut away from a discussion, and later try to explain that your news agent actually did it all by itself, you'll likely get an "Oh yeah? Dog ate your homework?" reaction. It is definitely not funny.

When I ran Windows, I used Forté Agent. I think that KNode on the whole is a good replacement for it, but I want this horrendous auto-fut "feature" banished from the face of the Earth.
Comment 3 Juliano F. Ravasi 2005-01-16 02:59:09 UTC
In one of my newsgroups, a user fixed this misbehaviour by commenting out 5 lines of code. I don't think there is any excuse to delay anymore this fix.

By not giving an option to turn this off, I have an impression that knode developers are just trying to dictate how users should use the newsgroups. This is just an impression, hope that I'm wrong.
Comment 4 Volker Krause 2005-01-16 17:26:57 UTC
CVS commit by vkrause: 

- Don't overwrite follow-up field when re-editing an article.
- Add 'Don't ask again' option to the missing follow-up warning.

CCBUG: 68732


  M +12 -5     kncomposer.cpp   1.204
  M +3 -0      kncomposer.h   1.70


--- kdepim/knode/kncomposer.cpp  #1.203:1.204
@@ -169,5 +169,6 @@ KNComposer::KNComposer(KNLocalArticle *a
     : KMainWindow(0,"composerWindow"), r_esult(CRsave), a_rticle(a), s_ignature(sig), u_nwraped(unwraped),
       n_eeds8Bit(true), v_alidated(false), a_uthorDislikesMailCopies(dislikesCopies), e_xternalEdited(false), e_xternalEditor(0),
-      e_ditorTempfile(0), s_pellChecker(0), a_ttChanged(false)
+      e_ditorTempfile(0), s_pellChecker(0), a_ttChanged(false),
+      mFirstEdit( firstEdit )
 {
     mSpellingFilter = 0;
@@ -582,8 +583,14 @@ bool KNComposer::hasValidData()
         return false;
 
-    if (!followUp && (groupCount>2))
-      if (!(KMessageBox::warningYesNo( this, i18n("You are crossposting to more than two newsgroups.\nPlease use the \"Followup-To\" header to direct\nthe replies to your article into one group.\nDo you want to re-edit the article or send it anyway?"),
-                                       QString::null, i18n("&Send"),i18n("edit article","&Edit")) == KMessageBox::Yes))
+    if ( !followUp && groupCount > 2 ) {
+      if ( KMessageBox::warningYesNo( this,
+           i18n("You are crossposting to more than two newsgroups.\n"
+                "Please use the \"Followup-To\" header to direct the replies "
+                "to your article into one group.\n"
+                "Do you want to re-edit the article or send it anyway?"),
+           QString::null, i18n("&Send"), i18n("edit article","&Edit"), "missingFollowUpTo" )
+           != KMessageBox::Yes )
         return false;
+    }
 
     if (fupCount>12) {
@@ -1438,5 +1445,5 @@ void KNComposer::slotGroupsChanged(const
   v_iew->f_up2->insertItem("");
 
-  if(!currText.isEmpty())
+  if ( !currText.isEmpty() || !mFirstEdit ) // user might have cleared fup2 intentionally during last edit
     v_iew->f_up2->lineEdit()->setText(currText);
 }

--- kdepim/knode/kncomposer.h  #1.69:1.70
@@ -199,4 +199,7 @@ class KNComposer : public KMainWindow , 
     void composerDone(KNComposer*);
 
+  private:
+    bool mFirstEdit;
+
 };
 


Comment 5 Adam Funk 2005-06-01 17:23:30 UTC
Every time I reply to a cross-posted newsgroup posting, KNode automatically sets the Followup-To header to the first group on the list, even if I don't subscribe to it.  Normally I don't want to set the Followup-To header at all, and I have to remember to manually change it for each message I post.  It should be possible to disable this behaviour.

As has been pointed out, this flaw annoys not only KNode users but also other people reading newsgroups in which KNode users accidentally set Followup-To headers. 

Does anyone know why the developers are ignoring this issue?
Comment 6 Volker Krause 2005-10-01 10:53:05 UTC
*** Bug 113533 has been marked as a duplicate of this bug. ***
Comment 7 Adam Funk 2005-10-01 13:20:47 UTC
People have been complaining about this (not just here but in other fora) for almost two years.  Why are the developers ignoring it?  Could we please have an explanation?
Comment 8 Volker Krause 2005-10-01 13:55:02 UTC
That's easy: lack of time and developers.
If someone provides a patch I'll happily test and apply it.
Comment 9 Nick Leverton 2006-02-02 13:48:40 UTC
It's at least three years old in fact: bug 56662 is an earlier request for the same bugfix.

The problem seems to be twofold:
Firstly, that followups are unnecessarily forced in the first place;
Secondly, that they are forced via a combo box which is reset from the newsgroups at the start of editing and every time the newsgroups change.  
As a combo box, it will only allow one followup group (an incorrect restriction in any case), and it will default to the first one in the list, regardless of which group the article was read in.

Though I know C++ I'm afraid I am new to developing KDE, so it may take me a little while to solve this in a "proper" way.  But I'll try to do so, before this bug causes too many more knode users to be accused of deliberately setting followups to different groups.  If there's a way to browse the class heirarchy for KDE and QT that's easier than find and grep, I'd be grateful to know ...
Comment 10 Nick Leverton 2006-02-02 23:11:44 UTC
Created attachment 14503 [details]
Fix

1. Don't populate Followup-To just because the Newsgroups change.
2. A combo box is inappropriate for Followup-To as the user can't see all
entries (and with the previous implementation was limited to only one newsgroup
as well).  Make it into a text box until time permits even better
implementation.  See TODO comments for ideas.
Comment 11 Bodo Eggert 2008-04-06 17:51:18 UTC
Created attachment 24242 [details]
Bugfix

This patch moves the empty entry to the list of the f'up2-doropdown-box. knode
will not silently select a group anymore, but ask you to select an appropriate
group if you fail to select one before sending.
Comment 12 Derek Broughton 2009-08-12 19:03:06 UTC
Is there no chance at all of ever getting this fixed after 6 years?  Volker asked for patches, after one had already been posted.  No doubt that can't even be applied anymore.

This is not a wishlist, it breaks Usenet behaviour.  On posts that are not cross-posted, there shouldn't even _be_ a Followup-To header in most cases (I just received an email complaint about a post with such a followup set).  On posts that _are_ cross-posted, I should be expected to be smart enough to know when that's right.  For the most part, it wouldn't bother me, but on one pair of groups, where the users expect, and want, everything cross-posted to both, I routinely screw everybody up by forgetting to remove the Followup that Knode specifies.
Comment 13 Raphaël Barrois 2010-01-22 11:28:09 UTC
I have this exact same problem, with my (private) Usenet server refusing messages which have a Followup-To flag set and aren't a reply to another post.

According to the RFC, what Knode does is bad :
The Followup-To header field SHOULD NOT appear in a message, unless its content is different from the content of the Newsgroups header field.
(http://tools.ietf.org/html/rfc5536#section-3.2.6)

If a developer tells me that, would I submit a patch for this, it would be taken into consideration, I am willing to try to write one.
Comment 14 Olivier Trichet 2010-01-23 20:49:22 UTC
SVN commit 1079182 by otrichet:

Place a hint inside the followup-to line edit when there are more than 2 groups selected.

Previous changes to the composer already remove the automatic modification of the followup-to headers:
The current and future behaviour is not to automatically set/change the followup-to headers.
BUG: 178208
BUG: 176418
BUG: 163240
BUG: 74275
BUG: 68732

Warning against posting to more than on groups without setting the followup-to will remain.

 M  +1 -0      CMakeLists.txt  
 M  +39 -15    composer/composer_view.ui  
 A             composer/followupto_combobox.cpp   [License: MIT]
 A             composer/followupto_combobox.h   [License: MIT]
 M  +44 -0     kncomposerview.cpp  
 M  +10 -0     kncomposerview.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1079182
Comment 15 Eckhart Wörner 2010-02-22 18:31:43 UTC
Will this change be backported to the 4.4 branch?
Comment 16 Tristan Miller 2010-08-15 23:19:26 UTC
This bug still exists in KDE 4.5.  The Followup-To header is set even when replying to an article that isn't cross-posted.
Comment 17 Andrew Crouthamel 2018-09-04 18:39:03 UTC
Hello! Sorry to be the bearer of bad news, but this project has been unmaintained for many years so I am closing this bug.