Bug 67250 - Icon displayed in top left corner instead of system tray area
Summary: Icon displayed in top left corner instead of system tray area
Status: RESOLVED FIXED
Alias: None
Product: kicker
Classification: Plasma
Component: systemtray (show other bugs)
Version: 3.2-beta
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Aaron J. Seigo
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-11-05 01:22 UTC by Andre Eisenbach
Modified: 2006-06-07 14:20 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screen shot of problem (65.39 KB, image/jpeg)
2003-11-05 01:23 UTC, Andre Eisenbach
Details
Snapshot of the problem (156.39 KB, image/jpeg)
2006-02-14 12:26 UTC, Beco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andre Eisenbach 2003-11-05 01:22:10 UTC
Version:            (using KDE KDE 3.1.93)
Installed from:    Gentoo Packages
Compiler:          gcc 3.2.3 
OS:          Linux

After upgrading to KDE 3.2 beta 1 (Rudi), some icons which should be display inside the system tray applet area are displayed in the upper right corner of the screen instead. The icons appear functional but cannot be moved into the system tray. The icons are drawn on top of any other window.
More than one icon can be in the top left corner at a time overlapping each other.

A screenshot is attached. Notice the 4 icons correctly placed in the system tray area and the KDE keyboard tool icon misplaced in the top left corner. Note that the keyboard tool is only an example, any other icon may take it's place (I've seen klaptop's battery monitor go up there as well).
Comment 1 Andre Eisenbach 2003-11-05 01:23:06 UTC
Created attachment 3026 [details]
Screen shot of problem
Comment 2 Jord Swart 2003-11-07 15:31:08 UTC
Seen this one as well. What also happens in my case is that the pager app doesn't see I have four desktops. It only displays one. 

If by some magic of starting kwin the icons are displayed where they should be, the pages also sees my four desktops.

I used Konstruct to install.
Comment 3 Yannick Cholette 2003-11-07 16:40:46 UTC
I have the exact same problem. My keyboard layout indicator always shows up at the top left corner of the screen at login. I'm also on gentoo.
Comment 4 Helge Deller 2003-11-09 00:18:03 UTC
confirmed here too, SuSE 9, KDE 3.2 beta 1 - not Gentoo specific
Comment 5 Lubos Lunak 2003-11-10 18:34:55 UTC
Should be fixed post-beta1. Please reopen if the problem persists.
Comment 6 dor shemer 2003-11-26 13:01:42 UTC
happens also in slackware 9.1 pre-built packages
Comment 7 Malte S. Stretz 2003-12-07 17:46:01 UTC
I can reproduce a variation of this bug in 3.2-beta2: The symbol for the klaptopdaemon appears in the top left corner -- kicker and such the tray area is not yet visible. As soon as the tray area is available, the klaptopdaemon disappears but doesn't reappear in the tray area.
Comment 8 Andre Eisenbach 2003-12-09 08:06:01 UTC
FWIW, I consider this bug resolved. Just installed KDE 3.2 beta 2 and the problem does not occour anymore.

Thanks to all the developers and testers - keep up the good work!

Cheers,
   André

PS: I will leave the status as reopened since Stretz still has the problem..
Comment 9 Malte S. Stretz 2003-12-09 19:34:23 UTC
I'm currently compiling latest CVS and will try again when it's finished.

One thing I noticed is, that the icon isn't displayed on startup but when I logoff and the desktop disappears (the screen is black for a short moment), the icon is displayed in the top left corner again. So it seems like it's only hidden by the desktop.
Comment 10 Malte S. Stretz 2003-12-13 17:48:14 UTC
This seems to be fixed with CVS from yesterday night. Thanks :)
Comment 11 Beco 2006-02-12 22:11:41 UTC
I had this problem when using SUSE 9.3, and I have it yet after upgrading to SUSE 10.0 and KDE 3.5.1-18.

I would like to re-open this bug, if this is possible.

Usually the icons are: knemo and keyboard-language-select, that appears in the top-left corner of screen.

On SUSE 9.3, it happenned when loggin out, and when starting. Now, it happens also during the session.

I can configure Knemo, deleting the icons, and then re-creating them, and I solve the problem: the icons reapper in the panel.

Thank you,
Beco.
Comment 12 Beco 2006-02-14 12:26:14 UTC
Created attachment 14689 [details]
Snapshot of the problem

In the left corner you will see a Knemo icon, and a context menu when clicking
in it. (Kde 3.5.1 and Suse 10.0)
Comment 13 Beco 2006-02-14 15:33:58 UTC
Look at bug:
http://bugs.kde.org/show_bug.cgi?id=121699
Comment 14 Alexander Konstantinov 2006-03-20 11:33:55 UTC
I have the same Problem with Knemo and Kpowersave.
I temporary solved this by starting Kpowersave with help of the Autostart Folder.
Knemo is not killable, so I cant restart it to fix the Problem
Comment 15 cjbackhouse 2006-06-04 20:17:53 UTC
This occurs with amarok (and only amarok) in GNOME. Presumably that means it isnt resolved by whatever you did to kde.
Is this the right place to report this (I assume it is an amarok/qt bug) or should I post it to eg GNOME?
Comment 16 Shriramana Sharma 2006-06-07 14:20:36 UTC
If it occurs in GNOME, you should report it at GNOME. This bug (in its later avatar as the regression bug 121699) was fixed for KDE 3.52 and remains fixed with 3.53.