Bug 121699 - regression: topmost tray-icon is placed into the top-left corner of the desktop on KDE-startup
Summary: regression: topmost tray-icon is placed into the top-left corner of the deskt...
Status: RESOLVED FIXED
Alias: None
Product: kicker
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal with 2 votes (vote)
Target Milestone: ---
Assignee: Aaron J. Seigo
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-10 12:16 UTC by S. Burmeister
Modified: 2007-02-22 23:17 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description S. Burmeister 2006-02-10 12:17:13 UTC
Version:            (using KDE KDE 3.5.1)
Installed from:    SuSE RPMs
OS:                Linux

Similar to bug 67250, since 3.5.1 the topmost tray-icon, in my case knemo, is sometimes placed at the top-left corner of the desktop, when KDE starts up. In the bug mentioned a number of icons are placed at the top-left, in my case it is always just one, i.e. knemo.

If I stop knemo and start it again, it is placed correctly into the tray.

This bug has been confirmed by other users on the SuSE-mailinglist.
Comment 1 Christian Ihle 2006-02-10 17:45:45 UTC
I experience the same thing on Gentoo with KDE 3.5.1, on my laptop. I only have 1 systray app running, and that is KLaptop, which ends up in the upper left corner often, but not always.
Comment 2 Beco 2006-02-14 14:01:42 UTC
I wrote a note and upload a snapshot on the closed bug 67250, but after that I found this openned bug.

I am having the same problem, SUSE 10.0, KDE 3.5.1-18.

Thank you,
Beco.
Comment 3 MM 2006-02-17 09:56:37 UTC
Same here on Gentoo, KDE 3.5.1, for me it is kxkb.
Comment 4 Maksim Orlovich 2006-02-17 14:51:15 UTC
Seems to randomly non-embed one of the icons part of the time here
Comment 5 Volkmar Wörner 2006-02-17 23:46:00 UTC
It's the same with my Kanotix and KDE 3.5.1, knemo (topleft or first visible! tray-icon) is often displaced, but only when I start the computer, not when I log off and on again. And the knemo icons always! shows up in the top-left desktop corner when I log off.
And it only happens with knemo.
Comment 6 Beco 2006-02-18 00:23:26 UTC
Hi all,

I have a workaround here, so we can use KDE withou see this ugly problem:

Try to enable "Hidden" some of the icons, even if not Knemo, when you enable to hidden the others are placed correctly. I hidden Klipper, kgpg, the keyboard-language-change, suse watch. Then Knemo is now ok, not hidden, and the plugger (energy) ok too.

Worked with me. I hope work with you till they found the bug.

Cheers, 
Beco.
Comment 7 Codo 2006-02-18 00:27:16 UTC
I don't know if this comment is accurate, but in my case it seems to happen when kicker is hidden.  If I start with my mouse on kicker, making it visible, it doesn't happen (though I'm not 100% sure about this)
Comment 8 Lubos Lunak 2006-02-20 15:38:21 UTC
Should be fixed by reverting the patch from bug #100177.
Comment 9 Beco 2006-02-20 17:31:20 UTC
From Beco to Percy:
On Wednesday 15 February 2006 00:45, you wrote:
> Hi Percy,
>
> Please, is there a problem with Knemo that the icon stay outside the panel
> (in the top-left of the screen)?
>
> Or this is a kicker problem? Like the one in this report:
>
> http://bugs.kde.org/show_bug.cgi?id=121699

From Percy to Beco:
Hi Beco,

as other applications are also affected this is definitely a problem with KDE. 
I am using OpenSuSE and didn't have the problem until I switched to another 
icon theme (slick icons). When switching back to Crystal Clear the problem 
vanished. Maybe this information helps you to work around the problem until 
there are updated packages of KDE 3.5.1 available for your distribution.

        Percy

------

Percy is one of the Knemo responsables.

I am not sure if this patch address the same problem this bug report, but let us hope yes.

Thank you,
Beco.
Comment 10 Aaron J. Seigo 2006-02-20 18:45:34 UTC
thanks, lubos.
Comment 11 S. Burmeister 2006-03-18 10:56:54 UTC
The SuSE 3.5.1 packages in supplementary were apparently updated recently to BRANCH. If the latter is correct, then the bug is not fixed yet, as I still see it with those packages.
Comment 12 Mikel Moore 2006-03-18 15:26:17 UTC
Why is this marked resolved?

Having hidden icons in the system tray has no effect on this issue, nor does the icon set seem to matter (my default is Crystal SVG anyway), nor is it boot related-after manually reentering the interface name, which seems to force the icon back into the system tray, then ending the session. On the next session start, the issue returns. 

Suse 10.0 KDE 3.5.1 Level 'a'
Comment 13 Aaron J. Seigo 2006-03-18 19:00:19 UTC
> Why is this marked resolved? 

see comment #8
Comment 14 Mats Ahlgren 2007-02-22 20:03:12 UTC
------- Additional Comment #13 From Aaron J. Seigo 2006-03-18 19:00 -------
> Why is this marked resolved?
see comment #8 

------- Additional Comment #8 From Lubos Lunak  2006-02-20 15:38 -------
Should be fixed by reverting the patch from bug #100177. 

What do you mean exactly? I'm still having this problem on multiple distributions, and it's well over a year later.
Comment 15 Beco 2007-02-22 22:26:30 UTC
Me too. I still have the same problem here. The icons sometimes scape from the taskbar  (system tray) and appear in the top left corner of the screen.

Now I am using SUSE 10.2, with KDE and kwin. Last week I tryed compiz and beryl and a strange thing happened: ALL icons from tray scaped to the corner they like most. I am back to default decorator now, but still knemo, during shutdown, scaped to the TL-corner.

Thanks,
Beco.
Comment 16 S. Burmeister 2007-02-22 22:39:14 UTC
If it happens during shutdown it is not really that important, is it? Does it happen on start-up too?
Comment 17 Beco 2007-02-22 23:17:52 UTC
Well, it is not the way I program. Unfortunately I have not the skill to solve this bug.

Anyway I should add that it is *very* important, yes. Not because it appear during boot, or whatever. It is important because one year later, the same (or maybe a combination of them) bug survives. It is esthetically important also. And I think the core is that it could be a little visible collateral effect, but related to some bigger problem, probably the way the system tray deal with icons.

As I told, when changing from kwin to compiz, the problem got worst. So, yes, it is important to solve it. Not for me, but for KDE itself (or maybe it is a SUSE problem). The taskbar and system tray are breaking all records in bugs, and it is such an important tool to a graphic environment, actually to a novice, the taskbar is the system itself!

So, please, take a look at this problem with a open mind to find others and maybe optmize the whole algorithm.

Beco.

BTW, about your question, some rare times the icons scape also during use. Mainly when configuring the themes or new panels, something related to that.