Bug 64673 - allow a syntax to say that a holiday occurs on a weekday
Summary: allow a syntax to say that a holiday occurs on a weekday
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Applications
Component: general (show other bugs)
Version: 3.1pre
Platform: Compiled Sources Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 65865 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-09-21 19:00 UTC by Cp Hennessy
Modified: 2010-01-07 18:12 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cp Hennessy 2003-09-21 19:00:57 UTC
Version:            (using KDE 3.1.9)
Compiler:          gcc version 3.2
OS:          Linux (i686) release 2.4.21-pre4

There are some holidays in Ireland which occur on the date in question ( e.g. May 1st ) or if that day is on a weekend, then the holiday is actually moved to the following Monday. I could find no way to actually describe this with the syntax in KOrganizer holiday file.
Comment 1 Reinhold Kainhofer 2003-10-11 16:07:06 UTC
The same seems to be the case for UK holidays (English & Welsh holidays file). 
Comment 2 Reinhold Kainhofer 2003-10-11 16:07:16 UTC
*** Bug 65865 has been marked as a duplicate of this bug. ***
Comment 3 Reinhold Kainhofer 2006-06-09 18:02:53 UTC
SVN commit 549721 by kainhofe:

The holiday library now also supports 
-) Multiple holidays on the same date (e.g. start of summer time and easter 
   on the same day, etc.)
-) conditional shifting of holidays (e.g. if a holiday occurs on a saturday 
   or sunday, it is actually celebrated on the following monday). Example: 
      small  "May holiday" weekend on 1.5. shift to monday if saturday || sunday
   The holiday data files still need to be adapted wherever such a system 
   applies (UK, Wales, Ireland are known from bug reports, but I don't 
   know which holidays are really affected).

It's incredible, how simple it is to hack these lex/yacc parsers (which had the fame that nobody in kde would understand them), once you take the ten minutes to print out a yacc tutorial and the 45 minutes to look at the code (and then the ~2 hours to fix the inadvertant bugs in the C code that come through the ancient pointer-increasing in C to walk through a list, when you are used to Qt-style list iterators  ;-) )

CCBUG:64673
CCBUG:92474


 M  +1 -1      Makefile.am  
 M  +33 -11    kholidays.cpp  
 M  +12 -4     kholidays.h  
 M  +162 -106  parseholiday.y  
 M  +3 -0      scanholiday.lex  
Comment 4 Reinhold Kainhofer 2006-11-02 19:03:28 UTC
Reassigning all KOrganizer bug reports and wishes to the newly created 
korganizer-devel mailing list.
Comment 5 John Layt 2010-01-07 18:12:09 UTC
I'd say it's safe to close this bug, it's been fixed for 3.5 years now, and the data files have long been updated!