Bug 58575 - Screensaver 'molecule' is flickering
Summary: Screensaver 'molecule' is flickering
Status: RESOLVED FIXED
Alias: None
Product: kscreensaver
Classification: Miscellaneous
Component: kxsrun (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal with 111 votes (vote)
Target Milestone: ---
Assignee: kscreensaver bugs tracking
URL:
Keywords:
: 59958 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-05-16 18:56 UTC by Mathias Heier
Modified: 2008-05-19 17:59 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Attached is my xorg.conf for the Radeon 8500 LE graphics card. (3.38 KB, text/plain)
2006-03-24 16:53 UTC, Beat Fasel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mathias Heier 2003-05-16 18:56:37 UTC
Version:           3.0.0 (using KDE KDE 3.1.1a)
Installed from:    SuSE RPMs
Compiler:          gcc version 3.3 20030226 
OS:          Linux

The screensaver 'molecule' works well fullscreen started out of xscreensaver (Ver. 4.07), also started with 'kxsrun molecule' in a window.
But out of the KDE Control-center the molecules flicker, seems to be something wrong with
GL-usage.
Comment 1 Chris Howells 2003-07-29 23:42:31 UTC
*** Bug 59958 has been marked as a duplicate of this bug. ***
Comment 2 Chris Howells 2003-08-27 15:38:11 UTC
This seems to be related to DRI; if I disable DRI then I do not get the problem. 
Comment 3 Carl Thompson 2003-12-16 19:33:00 UTC
Actually, this bug applies to all of the OpenGL screensavers not just "molecule."

Also, it also happens when the screensaver is started normally because of an activity timeout or started via the "test" button in the control center.

The same screensavers work fine in GNOME or directly from xscreensaver.
Comment 4 Sean E. Russell 2004-02-15 21:55:20 UTC
This bug is still present in KDE 3.2.

For the record, it my graphics card is a Radeon:

OpenGL vendor string: Tungsten Graphics, Inc.
OpenGL renderer string: Mesa DRI Radeon 20020611 AGP 4x x86/MMX/SSE TCL
OpenGL version string: 1.2 Mesa 4.0.4

Strangely, it reminds me of a double-buffering issue -- that is, it looks like it isn't double buffered.
Comment 5 jtscsousa 2005-04-07 00:58:44 UTC
Just using kde 3.4 from kubuntu and this problem persists on xscreensaver and rss screensavers enabled via the KDE desktop configuration. I am running xorg 6.8.2 radeon drivers with dri enabled. 

My video card is a radeon mobility 9200. Using the ATI fglrx drivers does not flicker the screensavers.
Comment 6 Erick Wipprecht 2005-07-12 23:34:00 UTC
I think this is actually related to the way KDE specifies the VisualID resource. I'm guessing KDE sets this to a generic default (default or any, not sure) when it should be specified as "GL" for OpenGL screensavers. Adding a tab that allows you to specify the visual used (and modify the command line arguements) ala xscreensaver-demo's advanced tab would be a step in the right direction. Why this doesn't exist already is beyond me.
Comment 7 Erick Wipprecht 2005-07-12 23:53:11 UTC
Ah, I forgot -- I'm running FreeBSD 5.4 (Radeon 9100, XOrg 6.8.2, DRI, radeon driver) and seeing the same thing, so it doesn't appear to be platform dependant.
Comment 8 Beat Fasel 2006-03-24 16:48:32 UTC
I am having the same problem with OpenGL screensavers running following system:

- Kubuntu Breezy Badger with KDE 3.5.1
- Graphics card: Radeon 8500 LE
- Opensource Radeon drivers that come with Xorg 6.8.2

Interestingly, whenever I start the screensaver manually via the test button in the Configure - KDesktop Dialog, the screensavers don't flicker anymore. It happens only when they are automatically activated  after a certain time span as specified in the KDestop Dialog.
Comment 9 Beat Fasel 2006-03-24 16:53:58 UTC
Created attachment 15282 [details]
Attached is my xorg.conf for the Radeon 8500 LE graphics card.

Attached is my xorg.conf for the Radeon 8500 LE graphics card. As mentioned
before, I am using KDE 3.5.1 under Kubuntu Breezy Badger and the SMP Kernel
2.6.12-10-686-smp as provided by Kubuntu.
Comment 10 Beat Fasel 2006-03-25 16:00:01 UTC
As I experienced crashes when working on the desktop, I deactivated rendering acceleration for my Radeon 8500 LE graphics card. There were no more crashes and in addition the flickering of the automatically activated OpenGl screensavers disappeared. Probably the flickering was caused by buggy Radeon drivers and appeared when KDE was already using rendering acceleration before the screensavers kicked in. Here the relevant sections of my new xorg.conf:

Section "Device"
        Identifier      "ATI Technologies, Inc. Radeon 8500 (R200 QL)"
        Driver          "radeon"
        BusID           "PCI:1:0:0"
        Option          "AGPMode"               "4"
        #Option         "AGPSize"               "64" # default: 8
        #Option         "RingSize"              "8"
        #Option         "BufferSize"            "2"
        Option          "EnablePageFlip"        "true"
        Option          "EnableDepthMoves"      "true"
        #Option         "RenderAccel"           "true"
        #Option         "AGPFastWrite"          "true"
EndSection

#Section "Extensions"
        #Option         "Composite"     "Enable"
        #Option          "RENDER"        "Enable"
#EndSection
Comment 11 Oswald Buddenhagen 2007-04-11 21:14:27 UTC
works for me. there have been some visual selection related fixes in the past, so i assume they might have fixed this issue.