Bug 57483 - konqueror crash with a javascript of caramail.com
Summary: konqueror crash with a javascript of caramail.com
Status: RESOLVED WORKSFORME
Alias: None
Product: konqueror
Classification: Applications
Component: khtml (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 47679 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-04-20 20:19 UTC by Le Gluon du Net
Modified: 2004-02-16 13:20 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Le Gluon du Net 2003-04-20 20:19:33 UTC
Version:            (using KDE KDE 3.1.1)
Installed from:    Debian testing/unstable Packages
OS:          Linux

http://www.caramail.lycos.fr/. You have to be a member to access chat. Once you identified, click 'chat' on the left menu. A new page appears with a yellow button "entrer dans le chat" to join the chat. When you click on the yellow button konqueror crash. Before that a khtml window ask me if i want to interrupt or continue this script.
This script is supported by mozilla 1.3.1.
Thanks.
Comment 1 Le Gluon du Net 2003-04-20 20:21:56 UTC
this is my console debug message: 
 
khtml (jscript): WARNING: Script threw exception: ReferenceError: Can't find variable:  
popup  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
NodeImpl::toHTML  
zone still contained 42 blocks  
Comment 2 Kai Lahmann 2003-06-14 22:11:59 UTC
could you add a backtrace (the second tab in the crash-dialog)? 
Comment 3 Le Gluon du Net 2003-08-01 13:42:05 UTC
I think i can't give you this, because with this error I never obtain a KDE crash dialog. I 
have to use xkill to kill konqueror  and after I have no crash dialog. Normally, when I 
click on the submit button  "entrer dans le chat", I obtain two popups, (in mozilla, 
that's ok) but in place  konqueror freeze. Now I upgraded to kde 3.1.3 (debian 
unstable) and this problem is always here. Did you try to create a count on caramail 
to reapeat again this problem? 
Comment 4 Quentin Anciaux 2003-08-02 22:18:47 UTC
I confirm this bug, I'm on mandrake cooker konqueror 3.1.2... When I click 
'open the chat' sometimes I get a warning about some scripts but the result is 
that the popup never opens and konqueror completely freeze, no crash dialog... 
need to kill -9 the process... 
Comment 5 Stephan Kulow 2003-10-19 11:02:42 UTC
then please do not kill -9 but kill -SEGV and then give the backtrace
Comment 6 Jo Øiongen 2003-11-10 12:21:37 UTC
This bug is duplicate of 47679.
Comment 7 Tommi Tervo 2003-11-10 15:24:36 UTC
*** Bug 47679 has been marked as a duplicate of this bug. ***
Comment 8 Kai Lahmann 2004-01-21 14:44:05 UTC
..we still have no trace ;)
Comment 9 Le Gluon du Net 2004-02-15 13:02:01 UTC
Since KDE 3.1.5 I have no longer this bug. But I can't say if this web site have changed the code or if it is khtml which are support it now. I've a knoppix live cd with kde 3.1.4, i'm going to do a test and give you backtrace.
Comment 10 Le Gluon du Net 2004-02-16 13:18:24 UTC
The web site caramail have changed his code. With the changes, konqueror is now able to connect to the chat without freeze. If I cannot reproduce the bug, I have to close this report.
Thank you to the team of kde for your interest and good work. 
And thank you for the vote of many people. 
Comment 11 Le Gluon du Net 2004-02-16 13:20:15 UTC
the code which cause the bug no longer exists.