Bug 5694 - searching folders: free selection of folders
Summary: searching folders: free selection of folders
Status: RESOLVED DUPLICATE of bug 324838
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: Git (master)
Platform: unspecified Other
: NOR wishlist with 81 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 79503 153443 (view as bug list)
Depends on:
Blocks:
 
Reported: 2000-06-27 22:03 UTC by Unknown
Modified: 2013-09-19 07:36 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfgang Rohdewald 2000-06-27 21:52:32 UTC
(*** This bug was imported into bugs.kde.org ***)

Package: kmail
Version: 1.1.50 (KDE 1.91 Beta >= 20000624)
Severity: wishlist

Now I can only search all folders or just one. I want to 
define an arbitrary selection of folders to be searched 
like in Eudora. Searching all folders just takes far too
long.
Comment 1 Chris Howells 2001-12-06 22:40:16 UTC
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Thank you for your bug report.
The feature that you requested has been implemented in the latest development
(CVS) version of KDE.
The feature request will be closed.

You can choose to search subfolders from any level.
- -- 
Cheers Chris Howells -- chris@chrishowells.co.uk howells@kde.org
Web: http://chrishowells.co.uk PGP key: http://chrishowells.co.uk/pgp.txt
KDE: http://www.koffice.org http://edu.kde.org http://usability.kde.org

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE8D/PRF8Iu1zN5WiwRAsI5AJ4soU2jQ8vgRSjOKj6RvN9mVCFzuACfY4xX
MaoSvKDQol7pv+KonkSjvho=
=LoQs
-----END PGP SIGNATURE-----
Comment 2 Tristan Miller 2003-12-11 10:51:54 UTC
Please re-open this bug; the fix does not address the original report.  KMail's "Find Messages" search dialog should provide a multiple-selection list rather than a single-selection drop-down box for the search folders, so that arbitrary folders can be selected with CTRL- and SHIFT-click.  This is not the same thing as automatically searching subfolders.

On my KMail I have an "Archive" folder containing old e-mails from the past ten years.  When I want to search my other folders for a message I know I've received recently, there's no point in having KMail search through all ten years of archives; I want to be able to exclude the Archive folder (and all its subfolders) from the search.
Comment 3 Ingo Klöcker 2003-12-11 14:11:42 UTC
re-open
Comment 4 Stephan Kulow 2004-05-17 19:42:08 UTC
Replaced wr@poboxes.com with psychonaut@nothingisreal.com due to bounces by reporter
Comment 5 Raga Prong 2004-07-04 08:53:13 UTC
Hello, I like to subscribe to this bug. Additional search features for KMail could be:
* Search only for messages within a given time period (by date)
* Search only for messages that have an attachment (add "w/attachment" to status list)

Sometimes things were easier when you just could drop one search condition in the middle of the list....

Thank you
Regards
Raga
Comment 6 Fergal Daly 2005-03-28 09:51:26 UTC
This is really important to make search folders useful, without it, a search folder cannot be the union of several other folders. This is the reason I'm currently using Evolution instead of KMail.

I'd suggest handling it a bit like the search criteria. There'd be More and Fewer buttons and then N drop-downs in which the user can select folders. Also beside each drop down there'd be a tick box for "include all subfolders". If you really wanted to be sophisticated you could have 3 things on each line

Includes/Exclude this folder : Folder Name : Include subfolders?

You also need special folders for "all local" and "all remote" and "all account X".
Comment 7 Thomas McGuire 2007-09-20 19:41:25 UTC
*** Bug 79503 has been marked as a duplicate of this bug. ***
Comment 8 Kris Kersten 2008-03-20 23:08:59 UTC
After more than 7 years on the kmail wishlist it seems like this would have been addressed.  Almost all full featured email clients allow a search across multiple folders.  I can see how this might not be the most useful feature for those with just a few local folders as it _is_ possible to search all local folders.  However, for those with many local folders or (gasp) IMAP accounts, the inability to search across an arbitrary subset of mail folders is a deal breaker.  Please add this feature!
Comment 9 Kris Kersten 2008-03-20 23:12:46 UTC
*** This bug has been confirmed by popular vote. ***
Comment 10 Tristan Miller 2009-04-25 23:47:34 UTC
Confirming feature is still missing from KDE 4.2.2.
Comment 11 Björn Ruberg 2009-12-29 22:16:18 UTC
*** Bug 153443 has been marked as a duplicate of this bug. ***
Comment 12 Myriam Schweingruber 2012-08-18 08:09:48 UTC
Thank you for your feature request. Kmail1 is currently unmaintained so we are closing all wishes. Please feel free to reopen a feature request for Kmail2 if it has not already been implemented.
Thank you for your understanding.
Comment 13 Luigi Toscano 2012-08-19 01:14:24 UTC
Instead of creating a new feature request, please confirm here if the wishlist is still valid for kmail2.
Comment 14 Bernd Oliver Sünderhauf 2012-11-24 07:49:05 UTC
Still valid for kmail2, component "general". High importance, I'd say.
Would be nice to have more components available to allow for better categorizing.
Comment 15 Laurent Montel 2012-11-24 09:25:20 UTC
Move to kmail2 please and reopen it if it's still valid :)
Comment 16 Bernd Oliver Sünderhauf 2012-11-24 10:54:28 UTC
Hmm, you're right in that I can mark multiple folders in the folder sidebar and then use the Search bar above the messagelist. So "high importance" is an overstatement.

However, the more advanced "Find Messages" dialog doesn't offer a flexible choice of folders. And as far as I can see, that's what this issue is about. "Find messages" still only gives me the choice of searching all folders or just a single one.

So, I'd still propose reopening this for kmail2 keeping "normal importance", but with a more specific issue summary.
Comment 17 Laurent Montel 2013-09-19 06:22:26 UTC
it was the first bug report opened about it but I set as duplicate as new bug because we will see it in top of list of bug (more easy to see it :) )

*** This bug has been marked as a duplicate of bug 324838 ***
Comment 18 Tristan Miller 2013-09-19 07:36:44 UTC
Laurent, perhaps a better way of seeing important bugs at the top of your list is to sort by votes rather than by bug number.  Marking a very old bug like this one as a duplicate means that everyone who's voted or CC'd on this one has to manually transfer their settings to the new bug. :(