Bug 52192 - using spamassassin as filter blocks kmail
Summary: using spamassassin as filter blocks kmail
Status: RESOLVED DUPLICATE of bug 41514
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist with 10 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 49578 56776 56794 58561 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-12-22 17:09 UTC by Ferdinand Gassauer
Modified: 2007-09-14 12:17 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ferdinand Gassauer 2002-12-22 17:09:04 UTC
Version:           1.5.9 (using KDE 3.1.9)
Compiler:          gcc version 3.2
OS:          Linux (i686) release 2.4.19-4GB

Hi!
I set up kmail to use spamc / spamd spamassassin programs to filter mail. (which BTW works pretty good for english spam)
During the filter check naviagtion in kmail is blocked but IMHO shouldn't be non blocking.
(or did I set up spammassassin incorrectly ?)

cu
ferdinand
Comment 1 Ferdinand Gassauer 2002-12-22 17:09:55 UTC
correction : ... should be nonblocking...!!! 
Comment 2 Ingo Klöcker 2002-12-22 18:15:36 UTC
Subject: Re:  New: using spamassassin as filter blocks kmail

It's unwise to pipe all incoming messages through spamassassin (I also 
did this when I first setup sa). It's much better to first check for 
mail from mailing lists, then for mail from known senders (like your 
friends and colleagues) and only then pipe all remaining messages 
through spamassassin. This will greatly reduce the time that's needed 
to filter the incoming mail and will make it much less annoying that 
KMail blocks while spamassassin checks the messages.

Comment 3 Ferdinand Gassauer 2002-12-22 21:18:32 UTC
Subject: Re:  using spamassassin as filter blocks kmail

On Sunday 22 December 2002 18:15, you wrote:
> ------- You are receiving this mail because: -------
> You reported the bug, or are watching the reporter.
>
> http://bugs.kde.org/show_bug.cgi?id=52192
>
>
>
>
> ------- Additional Comments From kloecker@kde.org  2002-12-22 18:15 -------
> Subject: Re:  New: using spamassassin as filter blocks kmail
>
> It's unwise to pipe all incoming messages through spamassassin (I also
> did this when I first setup sa). It's much better to first check for
> mail from mailing lists, then for mail from known senders (like your
> friends and colleagues) and only then pipe all remaining messages
> through spamassassin. This will greatly reduce the time that's needed
> to filter the incoming mail and will make it much less annoying that
> KMail blocks while spamassassin checks the messages.
Thanks
Yes you are rigth of course, I just followed the instructions 
http://kmail.kde.org/tools.html without thinking of this.

May be you can add this hint  there
cu
ferdinand


Comment 4 Malte S. Stretz 2002-12-23 19:10:49 UTC
This could be counted as a dup to bug 46654 :o) 
Comment 5 Roland Obermayer 2003-01-10 22:07:52 UTC
I just experienced the same with kde 3.0.5a.  What makes me wonder is that kmail itself eats up all the processor time. Shouldn't it just wait for SA to finish it's job? 
Comment 6 Malte S. Stretz 2003-01-10 22:46:46 UTC
I experience the same problem with SA 2.50-cvs. A workaround is to start KMail 
with nice -5. I'll try to check what KMail 3.1 says this weekend. 
Comment 7 Ingo Klöcker 2003-03-27 10:56:35 UTC
*** Bug 49578 has been marked as a duplicate of this bug. ***
Comment 8 Malte S. Stretz 2003-03-29 16:45:43 UTC
Forgot about this bug; it's still happening in 3.1. Anybody working on making the 
filters asynchronous? 
Comment 9 Ingo Klöcker 2003-03-31 01:15:09 UTC
Subject: Re:  using spamassassin as filter blocks kmail

AFAIK currently nobody is working on this.

Comment 10 Ingo Klöcker 2003-04-03 10:35:49 UTC
*** Bug 56776 has been marked as a duplicate of this bug. ***
Comment 11 Alexander McCormmach 2003-04-03 11:03:03 UTC
Ah, I am sorry for not catching this bug report which is certainly a duplicate 
of mine. Still, it just seems like, theoretically, any filter-activated program 
could take a very very long time to finish, even for legitimate reasons, 
depending on what it was designed to do--so it doesn't make much sense 
for KMail to stall while such a program runs to completion, does it? How 
difficult would it be to run the whole mail checking/filtering in a background 
thread? ... I would try to do this myself except I have no experience coding 
for KMail, and wouldn't know where to look first. On this note, do any of the 
more experienced KMail developers have any advice as to how a person 
like myself, a reasonably experienced C++ programmer (e.g. have used Qt 
quite a bit and some of the kdelibs), should start to figure out the massive 
codebase that is KMail? ... so that I could start solving my own problems... 
;-) Thanks for any suggestions! 
Comment 12 Ingo Klöcker 2003-04-03 17:29:45 UTC
*** Bug 56794 has been marked as a duplicate of this bug. ***
Comment 13 Ingo Klöcker 2003-05-17 20:36:14 UTC
*** Bug 58561 has been marked as a duplicate of this bug. ***
Comment 14 Dominik Stadler 2003-05-28 22:44:33 UTC
I think this is some sort of duplicate of Bug 41514 with title "KMail freezes the UI when checking 
for new mail"... 
Comment 15 Ingo Klöcker 2003-05-29 00:30:33 UTC

*** This bug has been marked as a duplicate of 41514 ***