Bug 51517 - Autoadd addresses onto spam filter's whitelist
Summary: Autoadd addresses onto spam filter's whitelist
Status: CONFIRMED
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: Mail Filter Agent (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist with 221 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 149268 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-12-05 05:12 UTC by spancom
Modified: 2022-01-31 22:43 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description spancom 2002-12-05 05:12:22 UTC
Version:            (using KDE KDE 3.0.3)

Would be nice to have an option to automatically add to the spamassassin whitelist every address in the Address Book as well as every address to which the user sends an email. Also a feature to right-click on any email address in kmail and have it added to the spamassassin whitelist or blacklist. 

This would greatly reduce the chance of spamassassin false positives on incoming emails from important persons.
Comment 1 Kjetil Kjernsmo 2004-05-19 12:33:37 UTC
Yep, this bug definately gets my votes. 

However it may be worth noting two other bugs of mine: KAddressbook Bug 72653
and Spamassassin bug #3408: http://bugzilla.spamassassin.org/show_bug.cgi?id=3408

Those deals with the use of Friend-of-a-Friend (FOAF), in the first case, export FOAF-files from KAddressbook, and in the second case use FOAF to build whitelists. 

There is a lot of interest in the latter, and in fact some running code. 
It may be better to use FOAF to build whitelists from KAddressbook, and you gain as a bonus a whitelist including the contacts of your friends. 
Comment 2 Thomas McGuire 2007-09-05 16:11:36 UTC
Changing this wish to be a bit more generic (generic spam filter instead of spamassassin)

Note that you can add the filter "From is in addressbook" before the spam filter. If that filter has no actions and "if this filter matches, stop processing", the spam filters will not get executed, therefore whitelisting all people in your addressbook. This is of course an incomplete solution.
Comment 3 Thomas McGuire 2007-09-05 16:13:12 UTC
*** Bug 149268 has been marked as a duplicate of this bug. ***
Comment 4 Maciej Pilichowski 2007-09-05 17:07:57 UTC
Just in case :-)

Please make setting sender as a "trusted person" easier -- I would like to RMB on mail marked as spam, choose "trusted sender" ("ham sender"?) and KMail will do the rest -- create appropriate filter so any mail from such sender would not be even thought as spam. 
 
Comment 5 Kjetil Kjernsmo 2007-09-05 19:54:48 UTC
BTW, I have this project running now: http://esw.w3.org/topic/SweoIG/TaskForces/CommunityProjects/FOAFWhitelisting

I've got a plugin for Spamassassin and QPSMTPD that can use a unidimensional trust metric, and some code to compute it based on social networks. It is not production ready, and not tested. Especially the trust metric computation is not there, it is not efficient enough. Nevertheless, I'd like to reemphasise the role that FOAF plays in this.
Comment 6 Thomas McGuire 2008-03-10 12:57:44 UTC
Related bugs about addressbook entries and spam filtering:
Bug 51517
Bug 158756
bug 158758
Comment 7 Anne-Marie Mahfouf 2011-11-30 12:43:33 UTC
Switching this bug to KMail2.
Maybe  http://www.w3.org/wiki/SweoIG/TaskForces/CommunityProjects/FOAFWhitelisting can be of interest.
Comment 8 Kjetil Kjernsmo 2011-11-30 17:50:48 UTC
Actually, Anne-Marie, that's my project. I really never had time to commit to it I'm afraid, so it is dormant :-(

The necessary infrastructure is there, however, the fine folks at Garlik Inc has done it at http://foaf.qdos.com/ (I know them personally), so it could be done. If we need anything on the client side, NEPOMUK components could be reused.

So, we're really, really close here, it just needs a bit of developer time and a bit of support from Garlik folks.
Comment 9 Justin Zobel 2021-03-09 05:46:27 UTC
Thank you for the bug report.

As this report hasn't seen any changes in 5 years or more, we ask if you can please confirm that the issue still persists.

If this bug is no longer persisting or relevant please change the status to resolved.
Comment 10 Kjetil Kjernsmo 2022-01-31 22:43:43 UTC
It isn't resolved in the sense that it isn't a problem anymore. However, in the current environment, there isn't a realistic fix. It might become realistic if https://solidproject.org/ or through some custom API. I guess this could be resolved as WONTFIX, and then we can return into it if it becomes a possibility.